87 lines
2.5 KiB
RPMSpec
87 lines
2.5 KiB
RPMSpec
%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
|
|
|
|
Name: perl-Locale-gettext
|
|
Version: 1.07
|
|
Release: 2mamba
|
|
Summary: Locale::gettext - Perl support for gettext
|
|
Group: System/Libraries/Perl
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://www.cpan.org/
|
|
Source: http://search.cpan.org/CPAN/authors/id/P/PV/PVANDRY/gettext-%{version}.tar.gz
|
|
License: Artistic
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libperl
|
|
BuildRequires: perl-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: perl >= 2:5.36.0
|
|
BuildRequires: perl-devel >= %{perl_major_ver}
|
|
Requires: perl >= %{perl_major_ver}
|
|
|
|
%description
|
|
Perl support for gettext.
|
|
|
|
%prep
|
|
%setup -q -n Locale-gettext-%{version}
|
|
|
|
%build
|
|
perl Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor
|
|
%make
|
|
make test
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
|
%makeinstall_perl
|
|
|
|
packlist=`find %{buildroot} -name .packlist`
|
|
[ -z "$packlist" ] && exit 1 || cat $packlist | \
|
|
sed "s,%buildroot,,g;s,.*/man/.*,&.gz,g" | \
|
|
sort -u > .packlist && rm $packlist
|
|
|
|
strid=`echo $packlist | sed 's,.*auto\(.*\)/.packlist,\1,'`
|
|
for dir in `find %{buildroot} -type d | grep $strid`; do
|
|
echo "%dir ${dir#%buildroot}" >> .packlist
|
|
done
|
|
|
|
find %{buildroot} -name *.so -exec chmod u+w {} \;
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
|
|
|
%files -f .packlist
|
|
%defattr(-,root,root)
|
|
|
|
%changelog
|
|
* Sun Apr 16 2023 Sdk Build System <sdk@mambasoft.it> 1.07-2mamba
|
|
- rebuilt with perl 5.36.0
|
|
|
|
* Sat Dec 02 2017 Automatic Build System <autodist@mambasoft.it> 1.07-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Wed Nov 09 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 1.06-2mamba
|
|
- rebuilt with perl 5.24
|
|
|
|
* Wed Sep 23 2015 Automatic Build System <autodist@mambasoft.it> 1.06-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Tue Nov 13 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.05-4mamba
|
|
- perl 5.16 mass rebuild
|
|
|
|
* Wed Nov 05 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.05-3mamba
|
|
- automatic rebuild by autodist
|
|
|
|
* Tue Sep 30 2008 Aleph0 <aleph0@openmamba.org> 1.05-2mamba
|
|
- specfile updated
|
|
|
|
* Thu Dec 22 2005 Stefano Cotta Ramusino <stefano.cotta@qilinux.it> 1.05-1qilnx
|
|
- update to version 1.05 by autospec
|
|
|
|
* Wed Apr 27 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.04-1qilnx
|
|
- update to version 1.04 by autospec
|
|
- fixed perl requirement
|
|
|
|
* Wed Mar 31 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 1.01-1qilnx
|
|
- first build
|