perl-IPC-Run/perl-IPC-Run.spec

89 lines
2.9 KiB
RPMSpec

%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
Name: perl-IPC-Run
Version: 20231003.0
Release: 1mamba
Summary: IPC::Run - system() and background procs w/ piping, redirs, ptys (Unix, Win32)
Group: System/Libraries/Perl
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://www.cpan.org
Source: https://cpan.metacpan.org/modules/by-module/IPC/IPC-Run-%{version}.tar.gz
License: GPL, Artistic
## AUTOBUILDREQ-BEGIN
BuildRequires: libperl
BuildRequires: perl-Scalar-List-Utils
BuildRequires: perl-devel
## AUTOBUILDREQ-END
BuildRequires: perl(ExtUtils::MakeMaker)
BuildRequires: perl(IO::Pty)
BuildRequires: perl(Test::More)
BuildRequires: perl-devel
Requires: perl >= %perl_major_ver
%description
IPC::Run allows you run and interact with child processes using files, pipes, and pseudo-ttys. Both system()-style and scripted usages are supported and may be mixed. Likewise, functional and OO API styles are both supported and may be mixed.
Various redirection operators reminiscent of those seen on common Unix and DOS command lines are provided.
%prep
%setup -q -n IPC-Run-%{version}
%build
perl Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor
%make
%make test
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall_perl
find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
find %{buildroot} -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
chmod -R u+w %{buildroot}/*
rm -rf %{buildroot}%{perl_vendorlib}/IPC/Run/Win32*.pm
rm -rf %{buildroot}%{_mandir}/man3/IPC::Run::Win32*.3*
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files
%defattr(-,root,root)
%{perl_vendorlib}/IPC
%{_mandir}/man3/*.3*
%doc LICENSE
%changelog
* Tue Oct 03 2023 Automatic Build System <autodist@mambasoft.it> 20231003.0-1mamba
- automatic version update by autodist
* Sun Aug 07 2022 Automatic Build System <autodist@mambasoft.it> 20220807.0-1mamba
- automatic version update by autodist
* Fri Feb 26 2021 Automatic Build System <autodist@mambasoft.it> 20200505.0-1mamba
- automatic version update by autodist
* Wed Apr 22 2020 Automatic Build System <autodist@mambasoft.it> 20180523.0-1mamba
- automatic update by autodist
* Thu Oct 26 2017 Automatic Build System <autodist@mambasoft.it> 0.96-1mamba
- automatic update by autodist
* Sat Aug 27 2016 Automatic Build System <autodist@mambasoft.it> 0.94_02-1mamba
- automatic update by autodist
* Sat Dec 27 2014 Automatic Build System <autodist@mambasoft.it> 0.94-1mamba
- automatic update by autodist
* Mon Sep 10 2012 Automatic Build System <autodist@mambasoft.it> 0.92_01-1mamba
- automatic version update by autodist
* Sun Jul 01 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.91-1mamba
- update to 0.91
* Sun Mar 13 2011 gil <puntogil@libero.it> 0.89-1mamba
- package created by autospec