88 lines
2.6 KiB
RPMSpec
88 lines
2.6 KiB
RPMSpec
%define PERL_VERSION %(eval `perl -V:version`; echo $version)
|
|
Name: perl-IO-Tty
|
|
Version: 1.14
|
|
Release: 1mamba
|
|
Summary: IO::Tty and IO::Pty provide an interface to pseudo tty's
|
|
Group: Development/Libraries/Perl
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
Source: http://search.cpan.org/CPAN/authors/id/T/TO/TODDR/IO-Tty-%{version}.tar.gz
|
|
URL: http://www.cpan.org
|
|
License: GPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libperl
|
|
BuildRequires: perl-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: perl-devel >= %PERL_VERSION
|
|
Requires: perl >= %PERL_VERSION
|
|
BuildRoot: %{_tmppath}/perl-root
|
|
|
|
%description
|
|
IO::Tty and IO::Pty provide an interface to pseudo tty's.
|
|
|
|
%prep
|
|
%setup -q -n IO-Tty-%{version}
|
|
|
|
%build
|
|
perl Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor
|
|
%make
|
|
%ifnarch x86_64 arm
|
|
make test
|
|
%endif
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall_perl
|
|
|
|
packlist=`find %{buildroot} -name .packlist`
|
|
[ -z "$packlist" ] && exit 1 || cat $packlist | \
|
|
sed "s,%{buildroot},,g;s,.*/man/.*,&.gz,g" | \
|
|
sort -u > .packlist && rm -f $packlist
|
|
|
|
strid=`echo $packlist | sed 's,.*auto\(.*\)/.packlist,\1,'`
|
|
for dir in `find %{buildroot} -type d | grep $strid`; do
|
|
echo "%dir ${dir#%buildroot}" >> .packlist
|
|
done
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%files -f .packlist
|
|
%defattr(-,root,root)
|
|
|
|
%changelog
|
|
* Wed Jan 22 2020 Automatic Build System <autodist@mambasoft.it> 1.14-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Wed Nov 09 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 1.13_01-2mamba
|
|
- rebuilt with perl 5.24
|
|
|
|
* Wed Aug 12 2015 Automatic Build System <autodist@mambasoft.it> 1.13_01-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Sun Oct 12 2014 Automatic Build System <autodist@mambasoft.it> 1.12-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Fri May 09 2014 Automatic Build System <autodist@mambasoft.it> 1.11_01-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Mon Nov 12 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.10-2mamba
|
|
- perl 5.16 mass rebuild
|
|
|
|
* Thu Apr 12 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.10-1mamba
|
|
- update to 1.10
|
|
|
|
* Wed Nov 05 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.07-2mamba
|
|
- automatic rebuild by autodist
|
|
|
|
* Fri Sep 26 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.07-1mamba
|
|
- update to 1.07
|
|
|
|
* Tue Feb 01 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 1.02-2qilnx
|
|
- changed perl version check to non strict (>=)
|
|
|
|
* Fri Apr 30 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 1.02-1qilnx
|
|
- First build
|