perl-IO-String/perl-IO-String.spec

62 lines
1.9 KiB
RPMSpec

%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
Name: perl-IO-String
Version: 1.08
Release: 1mamba
Summary: IO::String - Emulate file interface for in-core strings
Group: System/Libraries/Perl
Vendor: openmamba
Distribution: openmamba
Packager: gil <puntogil@libero.it>
URL: http://www.cpan.org
Source: http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/IO-String-%{version}.tar.gz
License: GPL, Artistic
BuildRequires: perl(ExtUtils::MakeMaker)
BuildRequires: perl-devel
Requires: perl >= %perl_major_ver
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
The "IO::String" module provides the "IO::File" interface for in-core
strings. An "IO::String" object can be attached to a string, and
makes it possible to use the normal file operations for reading or
writing data, as well as for seeking to various locations of the
string. This is useful when you want to use a library module that
only provides an interface to file handles on data that you have in a
string variable.
Note that perl-5.8 and better has built-in support for "in memory"
files, which are set up by passing a reference instead of a filename
to the open() call. The reason for using this module is that it makes
the code backwards compatible with older versions of Perl.
%prep
%setup -q -n IO-String-%{version}
%build
perl Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor
%make
%make test
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall_perl
find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null ';'
chmod -R u+w %{buildroot}/*
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files
%defattr(-,root,root)
%{perl_vendorlib}/IO/
%{_mandir}/man3/*.3pm.gz
%doc Changes README
%changelog
* Thu Feb 17 2011 gil <puntogil@libero.it> 1.08-1mamba
- package created by autospec