121 lines
3.8 KiB
RPMSpec
121 lines
3.8 KiB
RPMSpec
%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
|
|
|
|
Name: perl-Gtk2
|
|
Version: 1.24993
|
|
Release: 2mamba
|
|
Summary: Gtk2 - Perl bindings to the 2.x series of the Gtk+ graphical user interface library
|
|
Group: Development/Libraries/Perl
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://www.cpan.org
|
|
Source: https://cpan.metacpan.org/modules/by-module/Gtk2/Gtk2-%{version}.tar.gz
|
|
License: GPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libat-spi2-core-devel
|
|
BuildRequires: libcairo-devel
|
|
BuildRequires: libfontconfig-devel
|
|
BuildRequires: libfreetype-devel
|
|
BuildRequires: libgdk-pixbuf-devel
|
|
BuildRequires: libglib-devel
|
|
BuildRequires: libgtk2-devel
|
|
BuildRequires: libharfbuzz-devel
|
|
BuildRequires: libpango-devel
|
|
BuildRequires: libperl
|
|
BuildRequires: perl-Glib
|
|
BuildRequires: perl-Pango
|
|
BuildRequires: perl-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: perl >= 2:5.36.0
|
|
BuildRequires: perl-Cairo
|
|
Requires: perl >= %perl_major_ver
|
|
Provides: perl-Gtk
|
|
Obsoletes: perl-Gtk < 1.24993
|
|
|
|
%description
|
|
Perl bindings to the 2.x series of the Gtk+ graphical user interface library.
|
|
|
|
%prep
|
|
%setup -q -n Gtk2-%{version}
|
|
|
|
%build
|
|
perl Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor
|
|
%make
|
|
#FIXME: test failing on libgdk-pixbuf
|
|
#% make test
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall_perl
|
|
packlist=`find %{buildroot} -name .packlist`
|
|
[ -z "$packlist" ] && exit 1 || cat $packlist | \
|
|
sed "s,%buildroot,,g;s,.*/man/.*,&.gz,g" | \
|
|
sort -u > .packlist && rm $packlist
|
|
|
|
strid=`echo $packlist | sed 's,.*auto\(.*\)/.packlist,\1,'`
|
|
for dir in `find %{buildroot} -type d | grep $strid`; do
|
|
echo "%dir ${dir#%buildroot}" >> .packlist
|
|
done
|
|
|
|
find %{buildroot} -name *.so -exec chmod u+w {} \;
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
rm -f .packlist
|
|
|
|
%files -f .packlist
|
|
%defattr(-,root,root)
|
|
|
|
%changelog
|
|
* Sun Apr 16 2023 Sdk Build System <sdk@mambasoft.it> 1.24993-2mamba
|
|
- rebuilt with perl 5.36.0
|
|
|
|
* Wed Feb 24 2021 Automatic Build System <autodist@mambasoft.it> 1.24993-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Nov 09 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 1.245-3mamba
|
|
- rebuilt with perl 5.24
|
|
|
|
* Mon Nov 12 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.245-2mamba
|
|
- perl 5.16 mass rebuild
|
|
|
|
* Sat Aug 11 2012 Automatic Build System <autodist@mambasoft.it> 1.245-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue May 01 2012 Automatic Build System <autodist@mambasoft.it> 1.240-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Aug 06 2011 Automatic Build System <autodist@mambasoft.it> 1.224-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Oct 04 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.222-2mamba
|
|
- obsolete perl-Gtk
|
|
|
|
* Sat Jun 05 2010 Automatic Build System <autodist@mambasoft.it> 1.222-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Sat Jul 11 2009 Automatic Build System <autodist@mambasoft.it> 1.221-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Thu May 07 2009 Automatic Build System <autodist@mambasoft.it> 1.220-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Mon Mar 02 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.203-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Fri Jan 02 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.202-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Sat Nov 08 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.162-2mamba
|
|
- automatic rebuild by autodist
|
|
|
|
* Thu Nov 22 2007 Aleph0 <aleph0@openmamba.org> 1.162-1mamba
|
|
- update to 1.162
|
|
|
|
* Tue Aug 30 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.083-1qilnx
|
|
- update to version 1.083 by autospec
|
|
|
|
* Thu Nov 11 2004 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 1.061-1qilnx
|
|
- package created by autospec
|