automatic update by autodist [release 2.3-1mamba;Sat Feb 15 2014]
This commit is contained in:
parent
273c5f50e7
commit
f16c4ecf93
@ -1,2 +1,4 @@
|
|||||||
# perl-Gimp
|
# perl-Gimp
|
||||||
|
|
||||||
|
Perl extension for writing Gimp Extensions/Plug-ins/Load & Save-Handlers.
|
||||||
|
|
||||||
|
24
perl-Gimp-2.2pre1-glib-2.32.patch
Normal file
24
perl-Gimp-2.2pre1-glib-2.32.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
diff -Nru gimp-perl.orig/extra.c gimp-perl/extra.c
|
||||||
|
--- gimp-perl.orig/extra.c 2003-07-07 03:34:52.000000000 +0200
|
||||||
|
+++ gimp-perl/extra.c 2012-11-17 17:56:58.811341808 +0100
|
||||||
|
@@ -11,7 +11,7 @@
|
||||||
|
|
||||||
|
/* need to factor these out, otherwise we always need gtk :( */
|
||||||
|
#include <libgimp/gimp.h>
|
||||||
|
-#include <libgimpwidgets/gimpchainbutton.h>
|
||||||
|
+#include <libgimpwidgets/gimpwidgets.h>
|
||||||
|
#include <libgimpbase/gimpbasetypes.h>
|
||||||
|
|
||||||
|
#include "extra.h"
|
||||||
|
diff -Nru gimp-perl.orig/Gimp.xs gimp-perl/Gimp.xs
|
||||||
|
--- gimp-perl.orig/Gimp.xs 2004-04-25 01:46:33.000000000 +0200
|
||||||
|
+++ gimp-perl/Gimp.xs 2012-11-17 17:56:45.117464269 +0100
|
||||||
|
@@ -1,7 +1,7 @@
|
||||||
|
#include "config.h"
|
||||||
|
|
||||||
|
#include <libgimp/gimp.h>
|
||||||
|
-#include <libgimp/gimpexport.h>
|
||||||
|
+#include <libgimp/gimpui.h>
|
||||||
|
|
||||||
|
#include <locale.h>
|
||||||
|
|
92
perl-Gimp.spec
Normal file
92
perl-Gimp.spec
Normal file
@ -0,0 +1,92 @@
|
|||||||
|
%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
|
||||||
|
|
||||||
|
Name: perl-Gimp
|
||||||
|
Version: 2.3
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: Gimp - Perl extension for writing Gimp Extensions/Plug-ins/Load & Save-Handlers
|
||||||
|
Group: Development/Libraries/Perl
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Aleph0 <aleph0@openmamba.org>
|
||||||
|
URL: http://www.cpan.org
|
||||||
|
Source: http://www.cpan.org/modules/by-module/Gimp/Gimp-%{version}.tar.gz
|
||||||
|
Patch0: perl-Gimp-2.2pre1-glib-2.32.patch
|
||||||
|
License: GPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libatk-devel
|
||||||
|
BuildRequires: libcairo-devel
|
||||||
|
BuildRequires: libfontconfig-devel
|
||||||
|
BuildRequires: libfreetype-devel
|
||||||
|
BuildRequires: libgdk-pixbuf-devel
|
||||||
|
BuildRequires: libgimp-devel
|
||||||
|
BuildRequires: libglib-devel
|
||||||
|
BuildRequires: libgtk2-devel
|
||||||
|
BuildRequires: libpango-devel
|
||||||
|
BuildRequires: perl-devel
|
||||||
|
BuildRequires: perl-File-Slurp
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
#BuildRequires: gimp
|
||||||
|
#BuildRequires: perl-PDL
|
||||||
|
BuildRequires: perl-Gtk2
|
||||||
|
BuildRequires: perl-ExtUtils-Depends
|
||||||
|
BuildRequires: perl-ExtUtils-PkgConfig
|
||||||
|
BuildRequires: perl-devel >= %perl_major_ver
|
||||||
|
Requires: perl >= %perl_major_ver
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
# FIXME:
|
||||||
|
# Warning: prerequisite PDL 0 not found.
|
||||||
|
|
||||||
|
%description
|
||||||
|
Perl extension for writing Gimp Extensions/Plug-ins/Load & Save-Handlers.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n Gimp-%{version}
|
||||||
|
#%patch0 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
#GIMPTOOL=/usr/bin/gimptool-2.0 \
|
||||||
|
perl Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor
|
||||||
|
%make CC="gcc `pkg-config --cflags gtk+-2.0`"
|
||||||
|
%make test
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||||
|
%makeinstall_perl
|
||||||
|
|
||||||
|
packlist=`find %{buildroot} -name .packlist`
|
||||||
|
[ -z "$packlist" ] && exit 1 || cat $packlist | \
|
||||||
|
sed "s,%buildroot,,g;s,.*/man/.*,&.gz,g" | \
|
||||||
|
sort -u > .packlist && rm $packlist
|
||||||
|
|
||||||
|
strid=`echo $packlist | sed 's,.*auto\(.*\)/.packlist,\1,'`
|
||||||
|
for dir in `find %{buildroot} -type d | grep $strid`; do
|
||||||
|
echo "%dir ${dir#%buildroot}" >> .packlist
|
||||||
|
done
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
rm -f .packlist
|
||||||
|
|
||||||
|
%files -f .packlist
|
||||||
|
%defattr(-,root,root)
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sat Feb 15 2014 Automatic Build System <autodist@mambasoft.it> 2.3-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Fri Nov 16 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2pre1-3mamba
|
||||||
|
- perl 5.16 mass rebuild
|
||||||
|
|
||||||
|
* Sat Nov 08 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2pre1-2mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Tue Nov 20 2007 Aleph0 <aleph0@openmamba.org> 2.2-1mamba
|
||||||
|
- update to 2.2pre1
|
||||||
|
|
||||||
|
* Thu Nov 11 2004 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 2.0-2qilnx
|
||||||
|
- package created by autospec
|
||||||
|
|
||||||
|
* Thu Sep 09 2004 Matteo Bernasconi <voyagernm@virgilio.it> 2.0-1qilnx
|
||||||
|
- first build
|
Loading…
Reference in New Issue
Block a user