83 lines
2.6 KiB
RPMSpec
83 lines
2.6 KiB
RPMSpec
%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
|
|
|
|
Name: perl-Getopt-EvaP
|
|
Version: 2.8
|
|
Release: 1mamba
|
|
Summary: Getopt::EvaP - evaluate Perl command line parameters
|
|
Group: Development/Libraries/Perl
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Aleph0 <aleph0@openmamba.org>
|
|
URL: http://www.cpan.org
|
|
Source: http://www.cpan.org/modules/by-module/Getopt/Getopt-EvaP-%{version}.tar.gz
|
|
License: GPL
|
|
Requires: perl >= %perl_major_ver
|
|
BuildRequires: perl-devel >= %perl_major_ver
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
|
|
%description
|
|
Getopt::EvaP. A perl module useful to evaluate Perl command line parameters.
|
|
|
|
%prep
|
|
%setup -q -n Getopt-EvaP-%{version}
|
|
|
|
# use our own find-requires
|
|
%define __perl_requires %{_builddir}/Getopt-EvaP-%{version}/perl_requires.sh
|
|
cat > perl_requires.sh << _EOF
|
|
#! /bin/sh
|
|
%{_prefix}/lib/rpm/find-requires %{buildroot} %{_target_cpu} | grep -v "shellwords.p"
|
|
_EOF
|
|
chmod +x perl_requires.sh
|
|
|
|
%build
|
|
perl Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor
|
|
%make
|
|
%make test
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall_perl
|
|
packlist=`find %{buildroot} -name .packlist`
|
|
[ -z "$packlist" ] && exit 1 || cat $packlist | \
|
|
sed "s,%buildroot,,g;s,.*/man/.*,&.gz,g" | \
|
|
sort -u > .packlist && rm $packlist
|
|
|
|
strid=`echo $packlist | sed 's,.*auto\(.*\)/.packlist,\1,'`
|
|
for dir in `find %{buildroot} -type d | grep $strid`; do
|
|
echo "%dir ${dir#%buildroot}" >> .packlist
|
|
done
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
rm -f .packlist
|
|
|
|
%files -f .packlist
|
|
%defattr(-,root,root)
|
|
|
|
%changelog
|
|
* Mon Nov 03 2014 Automatic Build System <autodist@mambasoft.it> 2.8-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Fri Nov 01 2013 Automatic Build System <autodist@mambasoft.it> 2.7-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Wed May 15 2013 Automatic Build System <autodist@mambasoft.it> 2.6-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Nov 12 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 2.3.6.2-2mamba
|
|
- perl 5.16 mass rebuild
|
|
|
|
* Wed Mar 16 2011 Automatic Build System <autodist@mambasoft.it> 2.3.6.2-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Tue Nov 04 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.3.5-6mamba
|
|
- automatic rebuild by autodist
|
|
|
|
* Mon Nov 26 2007 Aleph0 <aleph0@openmamba.org> 2.3.5-5mamba
|
|
- rebuilt
|
|
|
|
* Fri Oct 22 2004 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 2.3.5-1qilnx
|
|
- package created by autospec (rebuilt after SRPM loss)
|
|
|
|
* Tue Nov 18 2003 Silvan Calarco <silvan.calarco@mambasoft.it> 2.3.5-1qilnx
|
|
- first build |