55 lines
1.7 KiB
RPMSpec
55 lines
1.7 KiB
RPMSpec
%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
|
|
|
|
Name: perl-Font-AFM
|
|
Version: 1.20
|
|
Release: 1mamba
|
|
Summary: Font::AFM - Interface to Adobe Font Metrics files
|
|
Group: System/Libraries/Perl
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: http://www.cpan.org
|
|
Source: http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/Font-AFM-%{version}.tar.gz
|
|
License: GPL, Artistic
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: perl-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: perl(ExtUtils::MakeMaker)
|
|
#BuildRequires: %{_datadir}/a2ps/afm/phvr.afm
|
|
BuildRequires: perl-devel
|
|
Requires: perl >= %perl_major_ver
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
|
|
%description
|
|
This module implements the Font::AFM class. Objects of this class are initialised from an AFM (Adobe Font Metrics) file and allow you to obtain information about the font and the metrics of the various glyphs in the font.
|
|
|
|
%prep
|
|
%setup -q -n Font-AFM-%{version}
|
|
sed -i -e 's,Helvetica,phvr,g' t/afm.t
|
|
|
|
%build
|
|
perl Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor
|
|
%make
|
|
%make test METRICS=%{_datadir}/a2ps/afm
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall_perl
|
|
|
|
find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
|
|
find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null ';'
|
|
chmod -R u+w %{buildroot}/*
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%{perl_vendorlib}/Font/*
|
|
%{_mandir}/man3/*.3pm.gz
|
|
%doc Changes README
|
|
|
|
%changelog
|
|
* Mon Feb 21 2011 gil <puntogil@libero.it> 1.20-1mamba
|
|
- package created by autospec
|