64 lines
2.1 KiB
RPMSpec
64 lines
2.1 KiB
RPMSpec
%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
|
|
|
|
Name: perl-File-Slurp
|
|
Version: 9999.32
|
|
Release: 1mamba
|
|
Summary: File::Slurp - Efficient Reading/Writing of Complete Files
|
|
Group: System/Libraries/Perl
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Automatic Build System <autodist@mambasoft.it>
|
|
URL: https://www.cpan.org
|
|
Source: https://cpan.metacpan.org/modules/by-module/File/File-Slurp-%{version}.tar.gz
|
|
License: GPL, Artistic
|
|
Requires: perl >= %perl_major_ver
|
|
BuildRequires: perl-devel >= %perl_major_ver
|
|
|
|
%description
|
|
This module provides subs that allow you to read or write entire files with one simple call. They are designed to be simple to use, have flexible ways to pass in or get the file contents and to be very efficient. There is also a sub to read in all the files in a directory other than . and ..
|
|
|
|
%prep
|
|
|
|
%setup -q -n File-Slurp-%{version}
|
|
|
|
%build
|
|
perl Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor
|
|
%make
|
|
%make test
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall_perl
|
|
packlist=`find %{buildroot} -name .packlist`
|
|
[ -z "$packlist" ] && exit 1 || cat $packlist | \
|
|
sed "s,%buildroot,,g;s,.*/man/.*,&.gz,g" | \
|
|
sort -u > .packlist && rm $packlist
|
|
|
|
strid=`echo $packlist | sed 's,.*auto\(.*\)/.packlist,\1,'`
|
|
for dir in `find %{buildroot} -type d | grep $strid`; do
|
|
echo "%dir ${dir#%buildroot}" >> .packlist
|
|
done
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
rm -f .packlist
|
|
|
|
%files -f .packlist
|
|
%defattr(-,root,root)
|
|
|
|
%changelog
|
|
* Wed Feb 24 2021 Automatic Build System <autodist@mambasoft.it> 9999.32-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Apr 27 2013 Automatic Build System <autodist@mambasoft.it> 9999.19-1mamba
|
|
- update to 9999.19
|
|
|
|
* Tue Nov 13 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 9999.13-3mamba
|
|
- perl 5.16 mass rebuild
|
|
|
|
* Tue Nov 04 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 9999.13-2mamba
|
|
- automatic rebuild by autodist
|
|
|
|
* Mon Oct 20 2008 gil <puntogil@libero.it> 9999.13-1mamba
|
|
- package created by autospec
|