perl 5.16 mass rebuild [release 1.52-2mamba;Mon Nov 12 2012]
This commit is contained in:
parent
62d05d010a
commit
c0c6ba4bf1
@ -1,2 +1,4 @@
|
|||||||
# perl-File-Remove
|
# perl-File-Remove
|
||||||
|
|
||||||
|
File::Remove - Remove files and directories.
|
||||||
|
|
||||||
|
28
perl-File-Remove-1.47_01-fix_deps_version.patch
Normal file
28
perl-File-Remove-1.47_01-fix_deps_version.patch
Normal file
@ -0,0 +1,28 @@
|
|||||||
|
diff -Nru File-Remove-1.47_01.orig//lib/File/Remove.pm File-Remove-1.47_01/lib/File/Remove.pm
|
||||||
|
--- File-Remove-1.47_01.orig//lib/File/Remove.pm 2011-02-18 07:53:58.000000000 +0100
|
||||||
|
+++ File-Remove-1.47_01/lib/File/Remove.pm 2011-03-03 18:34:28.939225447 +0100
|
||||||
|
@@ -17,8 +17,8 @@
|
||||||
|
|
||||||
|
use File::Path ();
|
||||||
|
use File::Glob ();
|
||||||
|
-use File::Spec 3.2701 ();
|
||||||
|
-use Cwd 3.2701 ();
|
||||||
|
+use File::Spec 3.28 ();
|
||||||
|
+use Cwd 3.28 ();
|
||||||
|
|
||||||
|
sub expand (@) {
|
||||||
|
map { -e $_ ? $_ : File::Glob::bsd_glob($_) } @_;
|
||||||
|
diff -Nru File-Remove-1.47_01.orig//META.yml File-Remove-1.47_01/META.yml
|
||||||
|
--- File-Remove-1.47_01.orig//META.yml 2011-02-18 07:54:19.000000000 +0100
|
||||||
|
+++ File-Remove-1.47_01/META.yml 2011-03-03 18:33:39.735272231 +0100
|
||||||
|
@@ -21,8 +21,8 @@
|
||||||
|
- t
|
||||||
|
- xt
|
||||||
|
requires:
|
||||||
|
- Cwd: 3.2701
|
||||||
|
- File::Spec: 3.2701
|
||||||
|
+ Cwd: 3.28
|
||||||
|
+ File::Spec: 3.28
|
||||||
|
perl: 5.00503
|
||||||
|
resources:
|
||||||
|
ChangeLog: http://fisheye2.atlassian.com/changelog/cpan/trunk/File-Remove
|
74
perl-File-Remove.spec
Normal file
74
perl-File-Remove.spec
Normal file
@ -0,0 +1,74 @@
|
|||||||
|
%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
|
||||||
|
|
||||||
|
Name: perl-File-Remove
|
||||||
|
Version: 1.52
|
||||||
|
Release: 2mamba
|
||||||
|
Summary: File::Remove - Remove files and directories
|
||||||
|
Group: System/Libraries/Perl
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://www.cpan.org
|
||||||
|
Source: http://search.cpan.org/CPAN/authors/id/A/AD/ADAMK/File-Remove-%{version}.tar.gz
|
||||||
|
Patch0: %{name}-1.47_01-fix_deps_version.patch
|
||||||
|
License: Artistic, GPL
|
||||||
|
Requires: perl >= %perl_major_ver
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: perl-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: perl-devel >= %perl_major_ver
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
File::Remove - Remove files and directories.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n File-Remove-%{version}
|
||||||
|
#%patch0 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
perl Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor
|
||||||
|
%make
|
||||||
|
%make test
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall_perl
|
||||||
|
packlist=`find %{buildroot} -name .packlist`
|
||||||
|
[ -z "$packlist" ] && exit 1 || cat $packlist | \
|
||||||
|
sed "s,%buildroot,,g;s,.*/man/.*,&.gz,g" | \
|
||||||
|
sort -u > .packlist && rm $packlist
|
||||||
|
|
||||||
|
strid=`echo $packlist | sed 's,.*auto\(.*\)/.packlist,\1,'`
|
||||||
|
for dir in `find %{buildroot} -type d | grep $strid`; do
|
||||||
|
echo "%dir ${dir#%buildroot}" >> .packlist
|
||||||
|
done
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
rm -f .packlist
|
||||||
|
|
||||||
|
%files -f .packlist
|
||||||
|
%defattr(-,root,root)
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Nov 12 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.52-2mamba
|
||||||
|
- perl 5.16 mass rebuild
|
||||||
|
|
||||||
|
* Wed Aug 08 2012 Automatic Build System <autodist@mambasoft.it> 1.52-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Mon Jul 25 2011 Automatic Build System <autodist@mambasoft.it> 1.50-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Tue May 17 2011 Automatic Build System <autodist@mambasoft.it> 1.49-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Fri Feb 25 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 1.47_01-2mamba
|
||||||
|
- added patch to fix version requirements for File::Spec and Cwd
|
||||||
|
|
||||||
|
* Tue Feb 22 2011 Automatic Build System <autodist@mambasoft.it> 1.47_01-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Sat Jan 23 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.42-1mamba
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user