70 lines
2.5 KiB
RPMSpec
70 lines
2.5 KiB
RPMSpec
%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
|
|
|
|
Name: perl-Event-ExecFlow
|
|
Version: 0.64
|
|
Release: 2mamba
|
|
Summary: Event::ExecFlow - High level API for event-based execution flow control
|
|
Group: System/Libraries/Perl
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Automatic Build System <autodist@mambasoft.it>
|
|
URL: http://www.cpan.org
|
|
Source: http://search.cpan.org/CPAN/authors/id/J/JR/JRED/Event-ExecFlow-%{version}.tar.gz
|
|
License: GPL, Artistic
|
|
Requires: perl >= %perl_major_ver
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: perl-AnyEvent
|
|
BuildRequires: perl-devel >= %perl_major_ver
|
|
BuildRequires: perl-libintl
|
|
## AUTOBUILDREQ-END
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
|
|
%description
|
|
Event::ExecFlow offers a high level API to declare jobs, which mainly execute external commands, parse their output to get progress or other status information, triggers actions when the command has been finished etc. Such jobs can be chained together in a recursive fashion to fulfill rather complex tasks which consist of many jobs.
|
|
|
|
Additionally it defines an extensible API for communication with the frontend application, which may be a written using Gtk2, Tk or Qt or is a simple text console program.
|
|
|
|
In case of Gtk2 a custom widget for displaying an Event::ExecFlow job plan, including progress updates, is shipped with the Gtk2::Ex::FormFactory package.
|
|
|
|
%prep
|
|
|
|
%setup -q -n Event-ExecFlow-%{version}
|
|
|
|
%build
|
|
perl Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor
|
|
%make
|
|
%make test
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall_perl
|
|
packlist=`find %{buildroot} -name .packlist`
|
|
[ -z "$packlist" ] && exit 1 || cat $packlist | \
|
|
sed "s,%buildroot,,g;s,.*/man/.*,&.gz,g" | \
|
|
sort -u > .packlist && rm $packlist
|
|
|
|
strid=`echo $packlist | sed 's,.*auto\(.*\)/.packlist,\1,'`
|
|
for dir in `find %{buildroot} -type d | grep $strid`; do
|
|
echo "%dir ${dir#%buildroot}" >> .packlist
|
|
done
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
rm -f .packlist
|
|
|
|
%files -f .packlist
|
|
%defattr(-,root,root)
|
|
|
|
%changelog
|
|
* Sun Dec 28 2014 Automatic Build System <autodist@mambasoft.it> 0.64-2mamba
|
|
- automatic rebuild by autodist
|
|
|
|
* Tue Jan 12 2010 Automatic Build System <autodist@mambasoft.it> 0.64-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Wed Nov 05 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.63-2mamba
|
|
- automatic rebuild by autodist
|
|
|
|
* Mon Oct 20 2008 gil <puntogil@libero.it> 0.63-1mamba
|
|
- package created by autospec
|