71 lines
2.3 KiB
RPMSpec
71 lines
2.3 KiB
RPMSpec
%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
|
|
|
|
Name: perl-DateTime-Format-Strptime
|
|
Epoch: 2
|
|
Version: 1.54
|
|
Release: 1mamba
|
|
Summary: DateTime::Format::Strptime - Parse and format strp and strf time patterns
|
|
Group: System/Libraries/Perl
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: http://www.cpan.org
|
|
Source: http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/DateTime-Format-Strptime-%{version}.tar.gz
|
|
License: GPL, Artistic
|
|
BuildRequires: perl(Class::ISA)
|
|
BuildRequires: perl(DateTime)
|
|
BuildRequires: perl(DateTime::Locale) >= 0.45
|
|
BuildRequires: perl(DateTime::TimeZone)
|
|
BuildRequires: perl(ExtUtils::MakeMaker)
|
|
BuildRequires: perl(Params::Validate)
|
|
BuildRequires: perl(Test::More)
|
|
BuildRequires: perl-devel
|
|
Requires: perl >= %perl_major_ver
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
|
|
%description
|
|
This module implements most of strptime(3), the POSIX function that is the reverse of strftime(3), for DateTime. While strftime takes a DateTime and a pattern and returns a string, strptime takes a string and a pattern and returns the DateTime object associated.
|
|
|
|
%prep
|
|
%setup -q -n DateTime-Format-Strptime-%{version}
|
|
|
|
%build
|
|
perl Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor
|
|
%make
|
|
%make test
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall_perl
|
|
|
|
find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
|
|
find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null ';'
|
|
chmod -R u+w %{buildroot}/*
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%{perl_vendorlib}/DateTime
|
|
%{_mandir}/man3/*.3pm.gz
|
|
%doc LICENSE
|
|
# README
|
|
|
|
%changelog
|
|
* Sun Apr 06 2014 Automatic Build System <autodist@mambasoft.it> 1.54-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Sat Apr 27 2013 Automatic Build System <autodist@mambasoft.it> 1.52-1mamba
|
|
- update to 1.52
|
|
|
|
* Wed Aug 22 2012 Automatic Build System <autodist@mambasoft.it> 1.5000-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Aug 16 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.52-1mamba
|
|
- update to 1.52
|
|
- imported in devel
|
|
|
|
* Mon Mar 07 2011 gil <puntogil@libero.it> 1.5000-1mamba
|
|
- package created by autospec
|