automatic version update by autodist [release 1.38_03-1mamba;Wed May 22 2013]
This commit is contained in:
parent
945180b620
commit
26ec02595f
@ -1,2 +1,8 @@
|
|||||||
# perl-DBD-SQLite
|
# perl-DBD-SQLite
|
||||||
|
|
||||||
|
SQLite is a public domain file-based relational database engine that you can find at
|
||||||
|
http://www.sqlite.org/.
|
||||||
|
|
||||||
|
This module provides a SQLite RDBMS module that uses the system SQLite
|
||||||
|
libraries.
|
||||||
|
|
||||||
|
12
perl-DBD-SQLite-1.27-bz543982.patch
Normal file
12
perl-DBD-SQLite-1.27-bz543982.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up DBD-SQLite-1.27/Makefile.PL.old DBD-SQLite-1.27/Makefile.PL
|
||||||
|
--- DBD-SQLite-1.27/Makefile.PL.old 2009-11-23 12:08:05.000000000 +0100
|
||||||
|
+++ DBD-SQLite-1.27/Makefile.PL 2010-01-11 15:40:56.456399143 +0100
|
||||||
|
@@ -123,7 +123,7 @@ if ( $@ or DBI->VERSION < $DBI_required
|
||||||
|
# a system sqlite is also sophisticated enough to have a patching system
|
||||||
|
# that can change the if ( 0 ) to if ( 1 )
|
||||||
|
my ($sqlite_local, $sqlite_base, $sqlite_lib, $sqlite_inc);
|
||||||
|
-if ( 0 ) {
|
||||||
|
+if ( 1 ) {
|
||||||
|
require File::Spec;
|
||||||
|
if ( $sqlite_base = (grep(/SQLITE_LOCATION=.*/, @ARGV))[0] ) {
|
||||||
|
$sqlite_base =~ /=(.*)/;
|
24
perl-DBD-SQLite-1.31-fts3-test.patch
Normal file
24
perl-DBD-SQLite-1.31-fts3-test.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
--- DBD-SQLite-1.31/t/43_fts3.t 2010-09-15 08:16:43.000000000 +0100
|
||||||
|
+++ DBD-SQLite-1.31/t/43_fts3.t 2010-09-15 14:50:58.529161202 +0100
|
||||||
|
@@ -90,6 +90,11 @@
|
||||||
|
}
|
||||||
|
|
||||||
|
# queries
|
||||||
|
+SKIP: {
|
||||||
|
+ skip "These tests require SQLite compiled with ENABLE_FTS3_PARENTHESIS option", scalar @tests
|
||||||
|
+ unless DBD::SQLite->can('compile_options') &&
|
||||||
|
+ grep /ENABLE_FTS3_PARENTHESIS/, DBD::SQLite::compile_options();
|
||||||
|
+
|
||||||
|
my $sql = "SELECT docid FROM try_fts3 WHERE content MATCH ?";
|
||||||
|
for my $t (@tests) {
|
||||||
|
my ($query, @expected) = @$t;
|
||||||
|
@@ -97,6 +102,9 @@
|
||||||
|
my $results = $dbh->selectcol_arrayref($sql, undef, $query);
|
||||||
|
is_deeply($results, \@expected, "$query (unicode is $use_unicode)");
|
||||||
|
}
|
||||||
|
+
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
}
|
||||||
|
|
||||||
|
|
80
perl-DBD-SQLite.spec
Normal file
80
perl-DBD-SQLite.spec
Normal file
@ -0,0 +1,80 @@
|
|||||||
|
%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
|
||||||
|
|
||||||
|
Name: perl-DBD-SQLite
|
||||||
|
Version: 1.38_03
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: DBD::SQLite - Self-contained RDBMS in a DBI Driver
|
||||||
|
Group: System/Libraries/Perl
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Automatic Build System <autodist@mambasoft.it>
|
||||||
|
URL: http://www.cpan.org
|
||||||
|
Source: http://search.cpan.org/CPAN/authors/id/A/AD/ADAMK/DBD-SQLite-%{version}.tar.gz
|
||||||
|
Patch0: perl-DBD-SQLite-1.27-bz543982.patch
|
||||||
|
Patch1: perl-DBD-SQLite-1.31-fts3-test.patch
|
||||||
|
License: GPL, Artistic
|
||||||
|
BuildRequires: libsqlite-devel
|
||||||
|
BuildRequires: perl(ExtUtils::MakeMaker)
|
||||||
|
BuildRequires: perl(Test::More)
|
||||||
|
BuildRequires: perl(File::Spec)
|
||||||
|
BuildRequires: perl(DBI)
|
||||||
|
BuildRequires: perl-DBI-Proxy
|
||||||
|
BuildRequires: perl-DBI-ProfileDumper-Apache
|
||||||
|
BuildRequires: perl-devel
|
||||||
|
Requires: perl >= %perl_major_ver
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
SQLite is a public domain file-based relational database engine that you can find at
|
||||||
|
http://www.sqlite.org/.
|
||||||
|
|
||||||
|
This module provides a SQLite RDBMS module that uses the system SQLite
|
||||||
|
libraries.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n DBD-SQLite-%{version}
|
||||||
|
%patch0 -p1
|
||||||
|
#%patch1 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
CFLAGS="$RPM_OPT_FLAGS" %{__perl} Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor
|
||||||
|
%make OPTIMIZE="$RPM_OPT_FLAGS"
|
||||||
|
make test || :
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall_perl
|
||||||
|
|
||||||
|
find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
|
||||||
|
find %{buildroot} -type f -name '*.bs' -empty -exec rm -f {} ';'
|
||||||
|
find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null ';'
|
||||||
|
chmod -R u+w %{buildroot}/*
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{perl_vendorarch}/auto/*
|
||||||
|
%{perl_vendorarch}/DBD/*
|
||||||
|
%{_mandir}/man3/*.3pm.gz
|
||||||
|
%doc Changes LICENSE README
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Wed May 22 2013 Automatic Build System <autodist@mambasoft.it> 1.38_03-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sat Apr 13 2013 Automatic Build System <autodist@mambasoft.it> 1.38_02-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Mon Nov 12 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.38_01-2mamba
|
||||||
|
- perl 5.16 mass rebuild
|
||||||
|
|
||||||
|
* Thu Oct 11 2012 Automatic Build System <autodist@mambasoft.it> 1.38_01-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Thu Aug 09 2012 Automatic Build System <autodist@mambasoft.it> 1.37-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sun Feb 20 2011 gil <puntogil@libero.it> 1.31-1mamba
|
||||||
|
- package created by autospec
|
Loading…
x
Reference in New Issue
Block a user