perl-Crypt-SSLeay/perl-Crypt-SSLeay.spec

85 lines
2.6 KiB
RPMSpec

%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
Name: perl-Crypt-SSLeay
Version: 0.73_06
Release: 2mamba
Summary: Crypt::SSLeay - OpenSSL support for LWP
Group: System/Libraries/Perl
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://www.cpan.org/
Source: https://cpan.metacpan.org/authors/id/N/NA/NANIS/Crypt-SSLeay-%{version}.tar.gz
License: GPL, Artistic
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libopenssl-devel
BuildRequires: libperl
BuildRequires: libz-devel
BuildRequires: perl-Bytes-Random-Secure
BuildRequires: perl-devel
## AUTOBUILDREQ-END
BuildRequires: perl >= 2:5.36.0
BuildRequires: perl-Devel-CheckLib
BuildRequires: perl-IO-Interactive-Tiny
BuildRequires: perl-Path-Class
BuildRequires: perl-Bytes-Random-Secure
Requires: perl >= %perl_major_ver
%description
This Perl module provides support for the HTTPS protocol under LWP, to allow an LWP::UserAgent object to perform GET, HEAD and POST requests.
The Crypt::SSLeay package provides Net::SSL, which is loaded by LWP::Protocol::https for https requests and provides the necessary SSL glue.
%prep
%setup -q -n Crypt-SSLeay-%{version}
%build
PERL_USE_UNSAFE_INC=1 \
PERL_MM_USE_DEFAULT=1 \
%{__perl} Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor \
OPTIMIZE="%{optflags}"
%make
%make test
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall_perl
packlist=`find %{buildroot} -name .packlist`
[ -z "$packlist" ] && exit 1 || cat $packlist | \
sed "s,%{buildroot},,g;s,.*/man/.*,&.gz,g" | \
sort -u > .packlist && rm -f $packlist
strid=`echo $packlist | sed 's,.*auto\(.*\)/.packlist,\1,'`
for dir in `find %{buildroot} -type d | grep $strid`; do
echo "%dir ${dir#%buildroot}" >> .packlist
done
find %{buildroot} -name *.so -exec chmod u+w {} \;
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files -f .packlist
%defattr(-,root,root)
%changelog
* Mon Apr 17 2023 Sdk Build System <sdk@mambasoft.it> 0.73_06-2mamba
- rebuilt with perl 5.36.0
* Fri Oct 27 2017 Automatic Build System <autodist@mambasoft.it> 0.73_06-1mamba
- automatic update by autodist
* Wed Nov 09 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 0.73_04-2mamba
- rebuilt with perl 5.24
* Thu Jan 29 2015 Automatic Build System <autodist@mambasoft.it> 0.73_04-1mamba
- automatic update by autodist
* Tue Jan 15 2013 Automatic Build System <autodist@mambasoft.it> 0.65_02-1mamba
- automatic version update by autodist
* Tue Jan 01 2013 Davide Madrisan <davide.madrisan@gmail.com> 0.58-1mamba
- package created by autospec