79 lines
2.2 KiB
RPMSpec
79 lines
2.2 KiB
RPMSpec
%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
|
|
|
|
Name: perl-Crypt-Random
|
|
Version: 1.54
|
|
Release: 2mamba
|
|
Summary: Crypt::Random - Cryptographically Secure, True Random Number Generator
|
|
Group: System/Libraries/Perl
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://www.cpan.org/
|
|
Source: https://cpan.metacpan.org/modules/by-module/Crypt/Crypt-Random-%{version}.tar.gz
|
|
License: GPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: libperl
|
|
BuildRequires: perl-Class-Loader
|
|
BuildRequires: perl-Math-Pari
|
|
BuildRequires: perl-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: perl-Statistics-ChiSquare
|
|
|
|
%description
|
|
Crypt::Random - Cryptographically Secure, True Random Number Generator.
|
|
|
|
%prep
|
|
%setup -q -n Crypt-Random-%{version}
|
|
|
|
%build
|
|
perl Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor
|
|
|
|
%make
|
|
|
|
%ifnarch %{ix86}
|
|
%make test
|
|
%endif
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall_perl
|
|
packlist=`find %{buildroot} -name .packlist`
|
|
[ -z "$packlist" ] && exit 1 || cat $packlist | \
|
|
sed "s,%buildroot,,g;s,.*/man/.*,&.gz,g" | \
|
|
sort -u > .packlist && rm $packlist
|
|
|
|
strid=`echo $packlist | sed 's,.*auto\(.*\)/.packlist,\1,'`
|
|
for dir in `find %{buildroot} -type d | grep $strid`; do
|
|
echo "%dir ${dir#%buildroot}" >> .packlist
|
|
done
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
rm -f .packlist
|
|
|
|
%files -f .packlist
|
|
%defattr(-,root,root)
|
|
|
|
%changelog
|
|
* Sun Nov 28 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 1.54-2mamba
|
|
- fix build requirement for perl-Class-Loader
|
|
|
|
* Sun Oct 24 2021 Automatic Build System <autodist@mambasoft.it> 1.54-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun May 30 2021 Automatic Build System <autodist@mambasoft.it> 1.52-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Aug 28 2013 Automatic Build System <autodist@mambasoft.it> 1.25-3mamba
|
|
- automatic rebuild by autodist
|
|
|
|
* Wed Nov 05 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.25-2mamba
|
|
- automatic rebuild by autodist
|
|
|
|
* Wed Sep 12 2007 Aleph0 <aleph0@openmamba.org> 1.25-1mamba
|
|
- update to 1.25
|
|
- spec file fixed and updated
|
|
|
|
* Thu May 06 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 1.13-1qilnx
|
|
- first build
|