70 lines
2.5 KiB
RPMSpec
70 lines
2.5 KiB
RPMSpec
%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
|
|
|
|
Name: perl-Crypt-DES_EDE3
|
|
Version: 0.01
|
|
Release: 4mamba
|
|
Summary: Crypt::DES_EDE3 - Triple-DES EDE encryption/decryption
|
|
Group: System/Libraries/Perl
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: http://www.cpan.org
|
|
Source: http://www.cpan.org/modules/by-module/Crypt/Crypt-DES_EDE3-%{version}.tar.gz
|
|
License: Artistic, GPL
|
|
Requires: perl >= %perl_major_ver
|
|
BuildRequires: perl-devel >= %perl_major_ver
|
|
BuildRequires: perl-Crypt-DES
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
|
|
%description
|
|
Crypt::DES_EDE3 implements DES-EDE3 encryption.
|
|
This is triple-DES encryption where an encrypt operation is encrypt-decrypt-encrypt, and decrypt is decrypt-encrypt-decrypt.
|
|
This implementation uses Crypt::DES to do its dirty DES work, and simply provides a wrapper around that module: setting up the individual DES ciphers, initializing the keys, and performing the encryption/decryption steps.
|
|
|
|
DES-EDE3 encryption requires a key size of 24 bytes.
|
|
|
|
You're probably best off not using this module directly, as the encrypt and decrypt methods expect 8-octet blocks.
|
|
You might want to use the module in conjunction with Crypt::CBC, for example.
|
|
This would be DES-EDE3-CBC, or triple-DES in outer CBC mode.
|
|
|
|
%prep
|
|
%setup -q -n Crypt-DES_EDE3-%{version}
|
|
|
|
%build
|
|
perl Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor
|
|
%make
|
|
%make test
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall_perl
|
|
packlist=`find %{buildroot} -name .packlist`
|
|
[ -z "$packlist" ] && exit 1 || cat $packlist | \
|
|
sed "s,%buildroot,,g;s,.*/man/.*,&.gz,g" | \
|
|
sort -u > .packlist && rm $packlist
|
|
|
|
strid=`echo $packlist | sed 's,.*auto\(.*\)/.packlist,\1,'`
|
|
for dir in `find %{buildroot} -type d | grep $strid`; do
|
|
echo "%dir ${dir#%buildroot}" >> .packlist
|
|
done
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
rm -f .packlist
|
|
|
|
%files -f .packlist
|
|
%defattr(-,root,root)
|
|
|
|
%changelog
|
|
* Tue Nov 13 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.01-4mamba
|
|
- perl 5.16 mass rebuild
|
|
|
|
* Wed Nov 05 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.01-3mamba
|
|
- automatic rebuild by autodist
|
|
|
|
* Wed Aug 29 2007 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 0.01-2mamba
|
|
- fixed package license
|
|
- added missing build requirement
|
|
|
|
* Thu May 06 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 0.01-1qilnx
|
|
- first build |