79 lines
2.5 KiB
RPMSpec
79 lines
2.5 KiB
RPMSpec
%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
|
|
|
|
Name: perl-Convert-BinHex
|
|
Version: 1.125
|
|
Release: 1mamba
|
|
Summary: Convert::BinHex - Extract data from Macintosh BinHex files
|
|
Group: Development/Libraries/Perl
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Aleph0 <aleph0@openmamba.org>
|
|
URL: http://www.cpan.org
|
|
Source: http://www.cpan.org/modules/by-module/Convert/Convert-BinHex-%{version}.tar.gz
|
|
Patch0: perl-Convert-BinHex-1.121-dont_require_Mac_Files.patch
|
|
License: GPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: perl-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: perl-devel >= %perl_major_ver
|
|
Requires: perl >= %perl_major_ver
|
|
BuildRoot: %{_tmppath}/perl-root
|
|
|
|
%description
|
|
BinHex is a format used by Macintosh for transporting Mac files safely through electronic mail, as short-lined, 7-bit, semi-compressed data streams.
|
|
Ths module provides a means of converting those data streams back into into binary data.
|
|
|
|
%prep
|
|
%setup -q -n Convert-BinHex-%{version}
|
|
%patch0 -p1
|
|
|
|
%build
|
|
perl Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor
|
|
%make
|
|
%make test || :
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall_perl
|
|
packlist=`find %{buildroot} -name .packlist`
|
|
[ -z "$packlist" ] && exit 1 || cat $packlist | \
|
|
sed "s,%buildroot,,g;s,.*/man/.*,&.gz,g" | \
|
|
sort -u > .packlist && rm $packlist
|
|
|
|
strid=`echo $packlist | sed 's,.*auto\(.*\)/.packlist,\1,'`
|
|
for dir in `find %{buildroot} -type d | grep $strid`; do
|
|
echo "%dir ${dir#%buildroot}" >> .packlist
|
|
done
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
rm -f .packlist
|
|
|
|
%files -f .packlist
|
|
%defattr(-,root,root)
|
|
|
|
%changelog
|
|
* Tue Dec 15 2015 Automatic Build System <autodist@mambasoft.it> 1.125-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Tue Sep 10 2013 Automatic Build System <autodist@mambasoft.it> 1.123-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Sun Sep 01 2013 Automatic Build System <autodist@mambasoft.it> 1.122-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Sun Aug 25 2013 Automatic Build System <autodist@mambasoft.it> 1.121-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Tue Nov 13 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.119-4mamba
|
|
- perl 5.16 mass rebuild
|
|
|
|
* Tue Nov 04 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.119-3mamba
|
|
- automatic rebuild by autodist
|
|
|
|
* Tue Nov 13 2007 Aleph0 <aleph0@openmamba.org> 1.119-2mamba
|
|
- rebuilt
|
|
|
|
* Mon May 09 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.119-1qilnx
|
|
- package created by autospec
|