87 lines
2.9 KiB
RPMSpec
87 lines
2.9 KiB
RPMSpec
%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
|
|
|
|
Name: perl-Convert-ASN1
|
|
Version: 0.34
|
|
Release: 1mamba
|
|
Summary: Convert::ASN1 - Pars ASN.1 descriptions and encode from and decode to perl data structures
|
|
Group: Development/Libraries/Perl
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://www.cpan.org/
|
|
Source: https://cpan.metacpan.org/modules/by-module/Convert/Convert-ASN1-%{version}.tar.gz
|
|
License: Artistic, GPL
|
|
BuildRequires: perl-devel >= %perl_major_ver
|
|
BuildRequires: perl-Digest-HMAC >= 1.01
|
|
Requires: perl >= %perl_major_ver
|
|
|
|
%description
|
|
Convert::ASN1 will parse ASN.1 descriptions and will encode from and decode to perl data structures using a hierarchy of references.
|
|
|
|
%prep
|
|
%setup -q -n Convert-ASN1-%{version}
|
|
|
|
%build
|
|
echo "y" | perl Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor
|
|
%make
|
|
make test
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall_perl
|
|
packlist=`find %{buildroot} -name .packlist`
|
|
[ -z "$packlist" ] && exit 1 || cat $packlist | \
|
|
sed "s,%buildroot,,g;s,.*/man/.*,&.gz,g" | \
|
|
sort -u > .packlist && rm $packlist
|
|
|
|
strid=`echo $packlist | sed 's,.*auto\(.*\)/.packlist,\1,'`
|
|
for dir in `find %{buildroot} -type d | grep $strid`; do
|
|
echo "%dir ${dir#%buildroot}" >> .packlist
|
|
done
|
|
|
|
%files -f .packlist
|
|
%defattr(-,root,root)
|
|
|
|
%changelog
|
|
* Tue Aug 08 2023 Automatic Build System <autodist@mambasoft.it> 0.34-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Sep 23 2021 Automatic Build System <autodist@mambasoft.it> 0.33-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Jun 03 2021 Automatic Build System <autodist@mambasoft.it> 0.31-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue May 25 2021 Automatic Build System <autodist@mambasoft.it> 0.29-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Jun 28 2014 Automatic Build System <autodist@mambasoft.it> 0.27-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Mon Nov 12 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.26-2mamba
|
|
- perl 5.16 mass rebuild
|
|
|
|
* Sat Aug 11 2012 Automatic Build System <autodist@mambasoft.it> 0.26-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat May 05 2012 Automatic Build System <autodist@mambasoft.it> 0.23-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Feb 05 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.22-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Tue Nov 04 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.21-2mamba
|
|
- automatic rebuild by autodist
|
|
|
|
* Thu Sep 13 2007 Aleph0 <aleph0@openmamba.org> 0.21-1mamba
|
|
- update to 0.21
|
|
|
|
* Wed May 10 2006 Stefano Cotta Ramusino <stefano.cotta@qilinux.it> 0.20-1qilnx
|
|
- update to version 0.20 by autospec
|
|
|
|
* Thu Jan 18 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 0.18-2qilnx
|
|
- fix requirement for perl (>= instead of > )
|
|
|
|
* Fri Apr 30 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 0.18-1qilnx
|
|
- First build
|