62 lines
2.1 KiB
RPMSpec
62 lines
2.1 KiB
RPMSpec
%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
|
|
|
|
Name: perl-CSS-Tiny
|
|
Version: 1.19
|
|
Release: 1mamba
|
|
Summary: CSS::Tiny - Read/Write .css files with as little code as possible
|
|
Group: System/Libraries/Perl
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: gil <puntogil@libero.it>
|
|
URL: http://www.cpan.org
|
|
Source: http://search.cpan.org/CPAN/authors/id/A/AD/ADAMK/CSS-Tiny-%{version}.tar.gz
|
|
License: GPL, Artistic
|
|
BuildRequires: perl(Clone)
|
|
BuildRequires: perl(Test::Pod)
|
|
Requires: perl(Clone)
|
|
BuildRequires: perl-devel
|
|
Requires: perl >= %perl_major_ver
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
|
|
%description
|
|
CSS::Tiny is a perl class to read and write .css stylesheets with as little code as possible, reducing load time and memory
|
|
overhead. CSS.pm requires about 2.6 meg or ram to load, which is a large amount of overhead if you only want to do trivial
|
|
things. Memory usage is normally scoffed at in Perl, but in my opinion should be at least kept in mind.
|
|
|
|
This module is primarily for reading and writing simple files, and anything we write shouldn't need to have
|
|
documentation/comments. If you need something with more power, move up to CSS.pm. With the increasing complexity of CSS,
|
|
this is becoming more common, but many situations can still live with simple CSS files.
|
|
|
|
%prep
|
|
%setup -q -n CSS-Tiny-%{version}
|
|
|
|
%build
|
|
perl Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor
|
|
%make
|
|
%make test
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall_perl
|
|
|
|
find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
|
|
find %{buildroot} -type f -name '*.bs' -empty -exec rm -f {} ';'
|
|
find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null ';'
|
|
chmod -R u+w %{buildroot}/*
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%{perl_vendorlib}/CSS/
|
|
%{_mandir}/man3/*.3pm.gz
|
|
%doc Changes LICENSE README
|
|
|
|
%changelog
|
|
* Sun May 01 2011 Automatic Build System <autodist@mambasoft.it> 1.19-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Thu Feb 17 2011 gil <puntogil@libero.it> 1.15-1mamba
|
|
- package created by autospec
|