rebuilt with perl 5.36.0 [release 0.16-5mamba;Mon Apr 17 2023]
This commit is contained in:
parent
df4a064cb5
commit
6d061cce62
32
perl-Authen-PAM-0.16-perl-5.36.0.patch
Normal file
32
perl-Authen-PAM-0.16-perl-5.36.0.patch
Normal file
@ -0,0 +1,32 @@
|
||||
From cad0178cc0bdacd33f7faf2f86afa6d2a118f730 Mon Sep 17 00:00:00 2001
|
||||
From: Kent Fredric <kentfredric@gmail.com>
|
||||
Date: Wed, 14 Jun 2017 20:39:17 +1200
|
||||
Subject: [PATCH] Fix for '.' removal from @INC in Perl 5.26
|
||||
|
||||
require "foo.ext"
|
||||
|
||||
Never really implied it would load files from ./ , it only did so
|
||||
as a side effect of '.' being in @INC.
|
||||
|
||||
The only way which works after 5.26 is to use an explicit ./ prefix,
|
||||
which is special-cased for this purpose.
|
||||
---
|
||||
Makefile.PL | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile.PL b/Makefile.PL
|
||||
index f6e2d49..c7ffd45 100644
|
||||
--- a/Makefile.PL
|
||||
+++ b/Makefile.PL
|
||||
@@ -10,7 +10,7 @@ sub configure {
|
||||
|
||||
# returns a reference to anonymous hash which is then interpreted as
|
||||
# additional options to the WriteMakeFile
|
||||
- $options = require "pam.cfg";
|
||||
+ $options = require "./pam.cfg";
|
||||
|
||||
if ( $Config{'osname'} eq 'solaris' && $Config{'osvers'} eq '2.6') {
|
||||
print "Adding a workaround for a bug in the Solaris 2.6 pam library\n";
|
||||
--
|
||||
2.13.1
|
||||
|
@ -2,23 +2,25 @@
|
||||
|
||||
Name: perl-Authen-PAM
|
||||
Version: 0.16
|
||||
Release: 4mamba
|
||||
Release: 5mamba
|
||||
Summary: Authen::PAM - Perl interface to PAM library
|
||||
Group: System/Libraries/Perl
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.cpan.org
|
||||
URL: https://www.cpan.org/
|
||||
Source: http://search.cpan.org/CPAN/authors/id/N/NI/NIKIP/Authen-PAM-%{version}.tar.gz
|
||||
Patch0: %{name}-0.16-disable_login_test.patch
|
||||
Patch1: perl-Authen-PAM-0.16-perl-5.36.0.patch
|
||||
License: Artistic, GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: pam-devel
|
||||
BuildRequires: libpam-devel
|
||||
BuildRequires: libperl
|
||||
BuildRequires: perl-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: perl >= 2:5.36.0
|
||||
Requires: perl >= %perl_major_ver
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
Authen::PAM - Perl interface to PAM library.
|
||||
@ -26,6 +28,7 @@ Authen::PAM - Perl interface to PAM library.
|
||||
%prep
|
||||
%setup -q -n Authen-PAM-%{version}
|
||||
%patch 0 -p1
|
||||
%patch 1 -p1 -b .perl-5.36.0
|
||||
|
||||
%build
|
||||
perl Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor
|
||||
@ -46,6 +49,8 @@ for dir in `find %{buildroot} -type d | grep $strid`; do
|
||||
echo "%dir ${dir#%buildroot}" >> .packlist
|
||||
done
|
||||
|
||||
find %{buildroot} -name *.so -exec chmod u+w {} \;
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
rm -f .packlist
|
||||
@ -54,6 +59,9 @@ rm -f .packlist
|
||||
%defattr(-,root,root)
|
||||
|
||||
%changelog
|
||||
* Mon Apr 17 2023 Sdk Build System <sdk@mambasoft.it> 0.16-5mamba
|
||||
- rebuilt with perl 5.36.0
|
||||
|
||||
* Thu Dec 10 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 0.16-4mamba
|
||||
- rebuilt
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user