perl 5.16 mass rebuild [release 0.16-2mamba;Fri Nov 16 2012]
This commit is contained in:
parent
12a463210f
commit
0054a92d09
@ -1,2 +1,4 @@
|
|||||||
# perl-Authen-PAM
|
# perl-Authen-PAM
|
||||||
|
|
||||||
|
Authen::PAM - Perl interface to PAM library
|
||||||
|
|
||||||
|
30
perl-Authen-PAM-0.16-disable_login_test.patch
Normal file
30
perl-Authen-PAM-0.16-disable_login_test.patch
Normal file
@ -0,0 +1,30 @@
|
|||||||
|
diff -Nru Authen-PAM-0.16.orig/test.pl Authen-PAM-0.16/test.pl
|
||||||
|
--- Authen-PAM-0.16.orig/test.pl 2005-09-21 20:08:46.000000000 +0200
|
||||||
|
+++ Authen-PAM-0.16/test.pl 2009-05-02 16:50:18.000000000 +0200
|
||||||
|
@@ -120,26 +120,6 @@
|
||||||
|
# skip(10, 'custom fail delay function is not supported by your PAM library');
|
||||||
|
# }
|
||||||
|
|
||||||
|
- if ($login_name) {
|
||||||
|
- print
|
||||||
|
- "---- Now, you may be prompted to enter the password of '$login_name'.\n";
|
||||||
|
- } else{
|
||||||
|
- print
|
||||||
|
- "---- Now, you may be prompted to enter a user name and a password.\n";
|
||||||
|
- }
|
||||||
|
-
|
||||||
|
- $res = pam_authenticate($pamh, 0);
|
||||||
|
-# $res = pam_chauthtok($pamh);
|
||||||
|
- {
|
||||||
|
- my $old_failures = $failures;
|
||||||
|
- pam_ok(9, $pamh, $res);
|
||||||
|
- print
|
||||||
|
- "---- The failure of test 9 could be due to your PAM configuration\n",
|
||||||
|
- "---- or typing an incorrect password.\n"
|
||||||
|
- if ($res != PAM_SUCCESS());
|
||||||
|
- $failures = $old_failures; # Authentication failures don't count
|
||||||
|
- }
|
||||||
|
-
|
||||||
|
# if (HAVE_PAM_FAIL_DELAY()) {
|
||||||
|
# ok(12, $res == $fd_status);
|
||||||
|
# } else {
|
60
perl-Authen-PAM.spec
Normal file
60
perl-Authen-PAM.spec
Normal file
@ -0,0 +1,60 @@
|
|||||||
|
%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
|
||||||
|
|
||||||
|
Name: perl-Authen-PAM
|
||||||
|
Version: 0.16
|
||||||
|
Release: 2mamba
|
||||||
|
Summary: Authen::PAM - Perl interface to PAM library
|
||||||
|
Group: System/Libraries/Perl
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://www.cpan.org
|
||||||
|
Source: http://search.cpan.org/CPAN/authors/id/N/NI/NIKIP/Authen-PAM-%{version}.tar.gz
|
||||||
|
Patch0: %{name}-0.16-disable_login_test.patch
|
||||||
|
License: Artistic, GPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: pam-devel
|
||||||
|
BuildRequires: perl-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
Requires: perl >= %perl_major_ver
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
Authen::PAM - Perl interface to PAM library
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n Authen-PAM-%{version}
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
perl Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor
|
||||||
|
%make
|
||||||
|
/usr/bin/tty && make test
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall_perl
|
||||||
|
packlist=`find %{buildroot} -name .packlist`
|
||||||
|
[ -z "$packlist" ] && exit 1 || cat $packlist | \
|
||||||
|
sed "s,%buildroot,,g;s,.*/man/.*,&.gz,g" | \
|
||||||
|
sort -u > .packlist && rm $packlist
|
||||||
|
|
||||||
|
strid=`echo $packlist | sed 's,.*auto\(.*\)/.packlist,\1,'`
|
||||||
|
for dir in `find %{buildroot} -type d | grep $strid`; do
|
||||||
|
echo "%dir ${dir#%buildroot}" >> .packlist
|
||||||
|
done
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
rm -f .packlist
|
||||||
|
|
||||||
|
%files -f .packlist
|
||||||
|
%defattr(-,root,root)
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Nov 16 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.16-2mamba
|
||||||
|
- perl 5.16 mass rebuild
|
||||||
|
|
||||||
|
* Thu Apr 30 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.16-1mamba
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user