79 lines
2.2 KiB
RPMSpec
79 lines
2.2 KiB
RPMSpec
%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
|
|
|
|
Name: perl-Array-Diff
|
|
Epoch: 1
|
|
Version: 0.09
|
|
Release: 1mamba
|
|
Summary: Array::Diff - Diff two arrays
|
|
Group: System/Libraries/Perl
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://www.cpan.org/
|
|
Source: https://cpan.metacpan.org/authors/id/N/NE/NEILB/Array-Diff-%{version}.tar.gz
|
|
License: GPL, Artistic
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: perl-Algorithm-Diff
|
|
BuildRequires: perl-Class-Accessor
|
|
BuildRequires: perl-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: perl-Module-Build
|
|
Requires: perl >= %perl_major_ver
|
|
|
|
%description
|
|
Array::Diff - Diff two arrays.
|
|
|
|
%prep
|
|
%setup -q -n Array-Diff-%{version}
|
|
|
|
%build
|
|
perl Makefile.PL installdirs=vendor
|
|
%make
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall_perl
|
|
#./Build install \
|
|
# destdir="%{buildroot}" \
|
|
# --install_path bindoc="%{_mandir}/man1" \
|
|
# --install_path libdoc="%{_mandir}/man3"
|
|
|
|
packlist=`find %{buildroot} -name .packlist`
|
|
[ -z "$packlist" ] && exit 1 || cat $packlist | \
|
|
sed "s,%buildroot,,g;s,.*/man/.*,&.gz,g" | \
|
|
sort -u > .packlist && rm $packlist
|
|
|
|
find %{buildroot}%{perl_vendorlib} \
|
|
-type d -depth -exec rmdir {} 2>/dev/null \;
|
|
|
|
strid=`echo $packlist | sed 's,.*auto\(.*\)/.packlist,\1,'`
|
|
for dir in `find %{buildroot} -type d | grep $strid`; do
|
|
echo "%dir ${dir#%buildroot}" >> .packlist
|
|
done
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
rm -f .packlist
|
|
|
|
%files -f .packlist
|
|
%defattr(-,root,root)
|
|
|
|
%changelog
|
|
* Sat Oct 21 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 0.09-1mamba
|
|
- update to 0.09
|
|
|
|
* Mon Jul 15 2013 Automatic Build System <autodist@mambasoft.it> 0.05002-2mamba
|
|
- automatic rebuild by autodist
|
|
|
|
* Thu May 28 2009 Automatic Build System <autodist@mambasoft.it> 0.05002-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Mon Mar 02 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.05-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Mon Nov 03 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.04-2mamba
|
|
- automatic rebuild by autodist
|
|
|
|
* Fri Nov 09 2007 Aleph0 <aleph0@openmamba.org> 0.04-1mamba
|
|
- package created by autospec
|