81 lines
2.3 KiB
RPMSpec
81 lines
2.3 KiB
RPMSpec
%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
|
|
|
|
Name: perl-Archive-Any
|
|
Version: 0.0942
|
|
Release: 1mamba
|
|
Summary: Archive::Any - Single interface to deal with file archives
|
|
Group: System/Libraries/Perl
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Aleph0 <aleph0@openmamba.org>
|
|
URL: http://www.cpan.org
|
|
Source: http://www.cpan.org/modules/by-module/Archive/Archive-Any-%{version}.tar.gz
|
|
License: GPL, Artistic
|
|
Requires: perl >= %perl_major_ver
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: perl-Archive-Tar
|
|
BuildRequires: perl-Archive-Zip
|
|
BuildRequires: perl-devel
|
|
BuildRequires: perl-File-MMagic
|
|
BuildRequires: perl-MIME-Types
|
|
BuildRequires: perl-Module-Find
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: perl-Test-Warn
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
|
|
# FIXME:
|
|
#BuildRequires: perl-Test-Perl-Critic
|
|
|
|
%description
|
|
Archive::Any - Single interface to deal with file archives.
|
|
|
|
%prep
|
|
%setup -q -n Archive-Any-%{version}
|
|
|
|
%build
|
|
perl Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor
|
|
%make
|
|
%make test
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall_perl
|
|
packlist=`find %{buildroot} -name .packlist`
|
|
[ -z "$packlist" ] && exit 1 || cat $packlist | \
|
|
sed "s,%buildroot,,g;s,.*/man/.*,&.gz,g" | \
|
|
sort -u > .packlist && rm $packlist
|
|
|
|
strid=`echo $packlist | sed 's,.*auto\(.*\)/.packlist,\1,'`
|
|
for dir in `find %{buildroot} -type d | grep $strid`; do
|
|
echo "%dir ${dir#%buildroot}" >> .packlist
|
|
done
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
rm -f .packlist
|
|
|
|
%files -f .packlist
|
|
%defattr(-,root,root)
|
|
|
|
%changelog
|
|
* Sun Feb 01 2015 Automatic Build System <autodist@mambasoft.it> 0.0942-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Sat May 24 2014 Automatic Build System <autodist@mambasoft.it> 0.0941-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Sun Oct 20 2013 Automatic Build System <autodist@mambasoft.it> 0.0940-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Tue Nov 13 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.0932-3mamba
|
|
- perl 5.16 mass rebuild
|
|
|
|
* Wed Nov 05 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.0932-2mamba
|
|
- automatic rebuild by autodist
|
|
|
|
* Mon Oct 20 2008 gil <puntogil@libero.it> 0.0932-1mamba
|
|
- update to 0.0932
|
|
|
|
* Fri Nov 09 2007 Aleph0 <aleph0@openmamba.org> 0.093-1mamba
|
|
- package created by autospec
|