157 lines
5.0 KiB
RPMSpec
157 lines
5.0 KiB
RPMSpec
%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
|
|
|
|
Name: perl-AnyEvent
|
|
Epoch: 1
|
|
Version: 7.17
|
|
Release: 2mamba
|
|
Summary: AnyEvent - Framework for multiple event loops
|
|
Group: System/Libraries/Perl
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://www.cpan.org/
|
|
Source: http://search.cpan.org/CPAN/authors/id/M/ML/MLEHMANN/AnyEvent-%{version}.tar.gz
|
|
License: Artistic, GPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: libperl
|
|
BuildRequires: perl(EV)
|
|
BuildRequires: perl(Event)
|
|
BuildRequires: perl(Event::Lib)
|
|
BuildRequires: perl(IO::AIO)
|
|
BuildRequires: perl(Irssi)
|
|
BuildRequires: perl(Tk)
|
|
BuildRequires: perl(UV)
|
|
BuildRequires: perl-AnyEvent-AIO
|
|
BuildRequires: perl-Glib
|
|
BuildRequires: perl-IO-Async
|
|
BuildRequires: perl-Net-SSLeay
|
|
BuildRequires: perl-POE
|
|
BuildRequires: perl-Scalar-List-Utils
|
|
BuildRequires: perl-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: perl >= 2:5.36.0
|
|
BuildRequires: perl-Tk >= 804.030
|
|
Requires: perl >= %perl_major_ver
|
|
Obsoletes: %{name}-Qt3
|
|
|
|
%description
|
|
AnyEvent provides a framework for multiple event loops.
|
|
|
|
%package Qt3
|
|
Group: System/Libraries/Perl
|
|
Summary: Qt3 bindings for perl-AnyEvent
|
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description Qt3
|
|
AnyEvent provides a framework for multiple event loops.
|
|
|
|
This package contains the Qt3 binsings for perl-AnyEvent.
|
|
|
|
%prep
|
|
%setup -q -n AnyEvent-%{version}
|
|
|
|
%build
|
|
perl Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor
|
|
%make
|
|
#% make test
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall_perl
|
|
packlist=`find %{buildroot} -name .packlist`
|
|
[ -z "$packlist" ] && exit 1 || cat $packlist | \
|
|
sed "s,%buildroot,,g;s,.*/man/.*,&.gz,g" | \
|
|
sort -u | grep -v Cocoa > .packlist && rm $packlist
|
|
|
|
strid=`echo $packlist | sed 's,.*auto\(.*\)/.packlist,\1,'`
|
|
for dir in `find %{buildroot} -type d | grep $strid`; do
|
|
echo "%dir ${dir#%buildroot}" >> .packlist
|
|
done
|
|
|
|
# remove Cocoa (MacOSX) depdendency
|
|
rm -f %{buildroot}%{_prefix}/lib/perl5/vendor_perl/*/*-linux-thread-multi/AnyEvent/Impl/Cocoa.pm
|
|
rm -f %{buildroot}%{_mandir}/man3/AnyEvent::Impl::Cocoa.3pm*
|
|
|
|
# remove FLTK module because perl-FLTK currently can't be build
|
|
find %{buildroot} -name FLTK.pm -exec rm -f {} \;
|
|
sed -i "/FLTK.pm/d" .packlist
|
|
|
|
# don't build Qt3 module
|
|
sed -i "/AnyEvent\/Impl\/Qt\.pm/d" .packlist
|
|
sed -i "/AnyEvent\:\:Impl\:\:Qt\.3pm\.gz/d" .packlist
|
|
#% if "%{stage1}" == "1"
|
|
rm -f %{buildroot}%{_prefix}/lib/perl5/vendor_perl/*/*-linux-thread-multi/AnyEvent/Impl/Qt.pm
|
|
rm -f %{buildroot}%{_mandir}/man3/AnyEvent::Impl::Qt.3pm*
|
|
#% endif
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
rm -f .packlist
|
|
|
|
%files -f .packlist
|
|
%defattr(-,root,root)
|
|
|
|
#%if "%{stage1}" != "1"
|
|
#%files Qt3
|
|
#%defattr(-,root,root)
|
|
#%{_libdir}/perl5/vendor_perl/*/*-linux-thread-multi/AnyEvent/Impl/Qt.pm
|
|
#%{_mandir}/man3/AnyEvent::Impl::Qt.3pm.gz
|
|
#%endif
|
|
|
|
%changelog
|
|
* Sun Apr 16 2023 Sdk Build System <sdk@mambasoft.it> 7.17-2mamba
|
|
- rebuilt with perl 5.36.0
|
|
|
|
* Sat May 02 2020 Automatic Build System <autodist@mambasoft.it> 7.17-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Wed Nov 15 2017 Automatic Build System <autodist@mambasoft.it> 7.14-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Wed Nov 09 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 7.12-2mamba
|
|
- rebuilt with perl 5.24
|
|
|
|
* Mon Feb 01 2016 Automatic Build System <autodist@mambasoft.it> 7.12-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Thu May 07 2015 Automatic Build System <autodist@mambasoft.it> 7.09-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Thu Jan 01 2015 Automatic Build System <autodist@mambasoft.it> 7.08-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Wed Dec 25 2013 Automatic Build System <autodist@mambasoft.it> 7.07-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Fri Aug 23 2013 Automatic Build System <autodist@mambasoft.it> 7.05-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Thu Jan 10 2013 Automatic Build System <autodist@mambasoft.it> 7.04-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Nov 15 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 7.02-3mamba
|
|
- remove FLTK module because perl-FLTK currently can't be built
|
|
- remove and obsolete Qt3 binding
|
|
|
|
* Tue Nov 06 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 7.02-2mamba
|
|
- perl 5.16 rebuild
|
|
|
|
* Tue Sep 25 2012 Automatic Build System <autodist@mambasoft.it> 7.02-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Sep 25 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 5.34-2mamba
|
|
- rebuilt with perl 5.10.1 (previous release was using perl 5.14)
|
|
|
|
* Sat Nov 19 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 5.34-1mamba
|
|
- update to 5.34
|
|
- moved Qt bindings to perl-AnyEvent-Qt3 subpackage
|
|
|
|
* Tue Jan 12 2010 Automatic Build System <autodist@mambasoft.it> 5.202-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Mon Nov 03 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 4.152-2mamba
|
|
- automatic rebuild by autodist
|
|
|
|
* Wed Jul 02 2008 gil <puntogil@libero.it> 4.152-1mamba
|
|
- package created by autospec
|