88 lines
2.6 KiB
RPMSpec
88 lines
2.6 KiB
RPMSpec
%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
|
|
|
|
Name: perl-Alien-wxWidgets
|
|
Version: 0.69
|
|
Release: 1mamba
|
|
Summary: Building, finding and using wxWidgets binaries
|
|
Group: System/Libraries/Perl
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: http://www.cpan.org
|
|
Source: http://search.cpan.org/CPAN/authors/id/M/MD/MDOOTSON/Alien-wxWidgets-%{version}.tar.gz
|
|
License: GPL, Artistic
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: libperl
|
|
BuildRequires: perl-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: libwxGTK-unicode-devel
|
|
Requires: perl >= %perl_major_ver
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
|
|
%description
|
|
Building, finding and using wxWidgets binaries.
|
|
|
|
%prep
|
|
%setup -q -n Alien-wxWidgets-%{version}
|
|
|
|
%build
|
|
%{__perl} Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor OPTIMIZE="%{optflags}" << _EOF
|
|
no
|
|
_EOF
|
|
|
|
%make
|
|
%make test
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall_perl
|
|
|
|
packlist=`find %{buildroot} -name .packlist`
|
|
[ -z "$packlist" ] && exit 1 || cat $packlist | \
|
|
sed "s,%{buildroot},,g;s,.*/man/.*,&.gz,g" | \
|
|
sort -u > .packlist && rm -f $packlist
|
|
|
|
strid=`echo $packlist | sed 's,.*auto\(.*\)/.packlist,\1,'`
|
|
for dir in `find %{buildroot} -type d | grep $strid`; do
|
|
echo "%dir ${dir#%buildroot}" >> .packlist
|
|
done
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%files -f .packlist
|
|
%defattr(-,root,root)
|
|
%doc README.txt
|
|
#%{perl_vendorarch}/Alien/wxWidgets/gtk_*_uni/*
|
|
|
|
%changelog
|
|
* Sun Oct 22 2017 Automatic Build System <autodist@mambasoft.it> 0.69-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Mon Mar 16 2015 Automatic Build System <autodist@mambasoft.it> 0.67-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Sat Apr 12 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 0.65-2mamba
|
|
- use system wxWidgets
|
|
|
|
* Thu Apr 10 2014 Automatic Build System <autodist@mambasoft.it> 0.65-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Sun May 19 2013 Automatic Build System <autodist@mambasoft.it> 0.64-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Thu Apr 04 2013 Automatic Build System <autodist@mambasoft.it> 0.63-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Oct 15 2012 Automatic Build System <autodist@mambasoft.it> 0.62-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Sep 14 2012 Automatic Build System <autodist@mambasoft.it> 0.60-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Aug 07 2012 Automatic Build System <autodist@mambasoft.it> 0.59-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Oct 20 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.53-1mamba
|
|
- package created by autospec
|