update to 2.2.2e [release 2.2.2e-1mamba;Thu May 22 2014]
This commit is contained in:
parent
910a88d82d
commit
973809ba96
18
pdfsam-2.2.2e-build.properties.patch
Normal file
18
pdfsam-2.2.2e-build.properties.patch
Normal file
@ -0,0 +1,18 @@
|
|||||||
|
diff -Nru pdfsam-2.2.2e.orig/pdfsam-maine/ant/build.properties pdfsam-2.2.2e/pdfsam-maine/ant/build.properties
|
||||||
|
--- pdfsam-2.2.2e.orig/pdfsam-maine/ant/build.properties 2012-10-30 16:06:08.000000000 +0100
|
||||||
|
+++ pdfsam-2.2.2e/pdfsam-maine/ant/build.properties 2014-05-22 14:17:08.758450179 +0200
|
||||||
|
@@ -1,11 +1,11 @@
|
||||||
|
#deploy target destination dir (if you want to deploy)
|
||||||
|
-pdfsam.deploy.dir=/home/torakiki/tmp
|
||||||
|
+pdfsam.deploy.dir=../deploy
|
||||||
|
|
||||||
|
#root dir where every src directory is located
|
||||||
|
-workspace.dir=/media/LACIE/pdfsam/workspace-enhanced
|
||||||
|
+workspace.dir=../
|
||||||
|
|
||||||
|
#where classes will be compiled, jars distributed, javadocs created and release created
|
||||||
|
-build.dir=/media/LACIE/build-2
|
||||||
|
+build.dir=../build
|
||||||
|
|
||||||
|
#version to build
|
||||||
|
pdfsam.version=enhanced
|
16
pdfsam-2.2.2e-run-console.patch
Normal file
16
pdfsam-2.2.2e-run-console.patch
Normal file
@ -0,0 +1,16 @@
|
|||||||
|
diff -ru pdfsam-2.2.2e.orig/pdfsam-maine/bin/run-console.sh pdfsam-2.2.2e/pdfsam-maine/bin/run-console.sh
|
||||||
|
--- pdfsam-2.2.2e.orig/pdfsam-maine/bin/run-console.sh 2009-05-21 16:48:26.000000000 +0200
|
||||||
|
+++ pdfsam-2.2.2e/pdfsam-maine/bin/run-console.sh 2014-05-22 14:36:13.914745949 +0200
|
||||||
|
@@ -15,8 +15,10 @@
|
||||||
|
}
|
||||||
|
|
||||||
|
|
||||||
|
-DIRNAME="../lib/"
|
||||||
|
-CONSOLEJAR="$DIRNAME/@CONSOLE_JAR_NAME.jar"
|
||||||
|
+DIRNAME="`dirname $0`"
|
||||||
|
+DIRNAME="${DIRNAME%bin}"
|
||||||
|
+DIRNAME="${DIRNAME%/}/lib"
|
||||||
|
+CONSOLEJAR="$DIRNAME/pdfsam-console-2.4.1e.jar"
|
||||||
|
|
||||||
|
# Setup the classpath
|
||||||
|
if [ ! -f "$CONSOLEJAR" ]; then
|
70
pdfsam.spec
Normal file
70
pdfsam.spec
Normal file
@ -0,0 +1,70 @@
|
|||||||
|
Name: pdfsam
|
||||||
|
Version: 2.2.2e
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: Split and merge PDF documents
|
||||||
|
Group: Applications/Publishing
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://www.pdfsam.org/
|
||||||
|
Source: http://downloads.sourceforge.net/project/pdfsam/pdfsam-enhanced/%{version}/pdfsam-%{version}-out-src.zip
|
||||||
|
#Source: http://downloads.sourceforge.net/project/pdfsam/pdfsam/%{version}/pdfsam-%{version}-out-src.zip
|
||||||
|
Patch0: pdfsam-2.2.2e-build.properties.patch
|
||||||
|
Patch1: pdfsam-2.2.2e-run-console.patch
|
||||||
|
License: GPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: apache-ant
|
||||||
|
BuildRequires: java-openjdk
|
||||||
|
Requires: java-openjdk
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
Split and merge PDF documents.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -c %{name}-%{version}
|
||||||
|
for f in *.zip; do unzip $f; done
|
||||||
|
rm -f *.zip
|
||||||
|
%patch0 -p1
|
||||||
|
%patch1 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
cd pdfsam-maine/ant/
|
||||||
|
ant
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
install -d -m0755 %{buildroot}/opt/pdfsam %{buildroot}%{_bindir}
|
||||||
|
cp -a build/pdfsam-maine/release/dist/pdfsam-enhanced/* %{buildroot}/opt/pdfsam/
|
||||||
|
rm -f %{buildroot}/opt/pdfsam/bin/*.bat %{buildroot}/opt/pdfsam/pdfsam-starter.exe
|
||||||
|
chmod +x %{buildroot}/opt/pdfsam/bin/*
|
||||||
|
|
||||||
|
cat > %{buildroot}%{_bindir}/pdfsam << _EOF
|
||||||
|
#!/bin/sh
|
||||||
|
sh /opt/pdfsam/bin/run.sh \$@
|
||||||
|
_EOF
|
||||||
|
chmod +x %{buildroot}%{_bindir}/pdfsam
|
||||||
|
|
||||||
|
cat > %{buildroot}%{_bindir}/pdfsam-console << _EOF
|
||||||
|
#!/bin/sh
|
||||||
|
sh /opt/pdfsam/bin/run-console.sh \$@
|
||||||
|
_EOF
|
||||||
|
chmod +x %{buildroot}%{_bindir}/pdfsam-console
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/pdfsam
|
||||||
|
%{_bindir}/pdfsam-console
|
||||||
|
%dir /opt/pdfsam
|
||||||
|
/opt/pdfsam/*
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Thu May 22 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.2e-1mamba
|
||||||
|
- update to 2.2.2e
|
||||||
|
|
||||||
|
* Thu May 22 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.2-1mamba
|
||||||
|
- package created by silvan using the webbuild interface
|
Loading…
Reference in New Issue
Block a user