update to 0.9.1 [release 0.9.1-1mamba;Fri Sep 25 2020]
This commit is contained in:
parent
46f17f0e59
commit
0a47827db4
@ -1,4 +1,3 @@
|
||||
# pdfmod
|
||||
|
||||
With PDF Mod you can reorder, rotate, and remove pages, export images from a PDF, edit the title, subject, author, and keywords, and combine documents via drag and drop.
|
||||
|
||||
|
25
pdfmod-0.9.1-mono-4.2.2.30.patch
Normal file
25
pdfmod-0.9.1-mono-4.2.2.30.patch
Normal file
@ -0,0 +1,25 @@
|
||||
From: Nuno Araujo <nuno.araujo@russo79.com>
|
||||
Date: Mon, 21 Mar 2011 12:10:52 +0800
|
||||
Subject: Fix compilation under Mono 2.10 (bgo#644516)
|
||||
|
||||
Force use of the overloaded implicit operator of Hyena.Gui.DragDropList
|
||||
to solve mono 2.10 compilation problems.
|
||||
|
||||
Signed-off-by: Alexander Kojevnikov <alexander@kojevnikov.com>
|
||||
---
|
||||
src/PdfMod/Gui/DocumentIconView.cs | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/PdfMod/Gui/DocumentIconView.cs b/src/PdfMod/Gui/DocumentIconView.cs
|
||||
index 5796c72..386d662 100644
|
||||
--- a/src/PdfMod/Gui/DocumentIconView.cs
|
||||
+++ b/src/PdfMod/Gui/DocumentIconView.cs
|
||||
@@ -319,7 +319,7 @@ namespace PdfMod.Gui
|
||||
if (to_index < 0)
|
||||
return;
|
||||
|
||||
- var pages = args.SelectionData.Data as Hyena.Gui.DragDropList<Page>;
|
||||
+ Hyena.Gui.DragDropList<Page> pages = args.SelectionData;
|
||||
to_index -= pages.Count (p => p.Index < to_index);
|
||||
var action = new MoveAction (document, pages, to_index);
|
||||
action.Do ();
|
15
pdfmod.spec
15
pdfmod.spec
@ -1,5 +1,5 @@
|
||||
Name: pdfmod
|
||||
Version: 0.9.0
|
||||
Version: 0.9.1
|
||||
Release: 1mamba
|
||||
Summary: A simple application for modifying PDF documents
|
||||
Group: Graphical Desktop/Applications/Publishing
|
||||
@ -8,18 +8,24 @@ Distribution: openmamba
|
||||
Packager: Stefano Cotta Ramusino <stefano.cotta@openmamba.org>
|
||||
URL: http://live.gnome.org/PdfMod
|
||||
Source: http://ftp.gnome.org/pub/GNOME/sources/pdfmod/0.9/pdfmod-%{version}.tar.bz2
|
||||
Patch0: pdfmod-0.9.1-mono-4.2.2.30.patch
|
||||
License: GPL
|
||||
BuildRequires: gtk-sharp-devel
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: gnome-sharp-devel
|
||||
BuildRequires: gtk-sharp2-devel
|
||||
BuildRequires: mono-core
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: hyena-devel
|
||||
Requires: gtk-sharp
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
With PDF Mod you can reorder, rotate, and remove pages, export images from a PDF, edit the title, subject, author, and keywords, and combine documents via drag and drop.
|
||||
|
||||
#% debug_package
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
%configure
|
||||
@ -44,5 +50,8 @@ With PDF Mod you can reorder, rotate, and remove pages, export images from a PDF
|
||||
%doc AUTHORS COPYING NEWS README
|
||||
|
||||
%changelog
|
||||
* Fri Sep 25 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.1-1mamba
|
||||
- update to 0.9.1
|
||||
|
||||
* Mon Oct 04 2010 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 0.9.0-1mamba
|
||||
- package created by autospec
|
||||
|
Loading…
Reference in New Issue
Block a user