rebuilt [release 3.6-2mamba;Tue Nov 05 2024]
This commit is contained in:
parent
c5f2d90dd6
commit
93e5fe2534
@ -1,91 +0,0 @@
|
|||||||
--- parted-1.8.6/libparted/labels/sun.c.pix 2007-03-13 18:01:09.000000000 +0100
|
|
||||||
+++ parted-1.8.6/libparted/labels/sun.c 2007-04-20 11:07:10.000000000 +0200
|
|
||||||
@@ -86,6 +86,7 @@
|
|
||||||
int is_boot;
|
|
||||||
int is_root;
|
|
||||||
int is_lvm;
|
|
||||||
+ int is_raid;
|
|
||||||
};
|
|
||||||
|
|
||||||
struct _SunDiskData {
|
|
||||||
@@ -344,6 +345,7 @@
|
|
||||||
sun_data->type = label->infos[i].id;
|
|
||||||
sun_data->is_boot = sun_data->type == 0x1;
|
|
||||||
sun_data->is_root = sun_data->type == 0x2;
|
|
||||||
+ sun_data->is_raid = sun_data->type == 0xfd;
|
|
||||||
sun_data->is_lvm = sun_data->type == 0x8e;
|
|
||||||
|
|
||||||
part->num = i + 1;
|
|
||||||
@@ -479,6 +481,7 @@
|
|
||||||
sun_data->type = 0;
|
|
||||||
sun_data->is_boot = 0;
|
|
||||||
sun_data->is_root = 0;
|
|
||||||
+ sun_data->is_raid = 0;
|
|
||||||
sun_data->is_lvm = 0;
|
|
||||||
} else {
|
|
||||||
part->disk_specific = NULL;
|
|
||||||
@@ -512,6 +515,7 @@
|
|
||||||
new_sun_data->type = old_sun_data->type;
|
|
||||||
new_sun_data->is_boot = old_sun_data->is_boot;
|
|
||||||
new_sun_data->is_root = old_sun_data->is_root;
|
|
||||||
+ new_sun_data->is_raid = old_sun_data->is_raid;
|
|
||||||
new_sun_data->is_lvm = old_sun_data->is_lvm;
|
|
||||||
return new_part;
|
|
||||||
}
|
|
||||||
@@ -542,6 +546,10 @@
|
|
||||||
return 1;
|
|
||||||
}
|
|
||||||
if (sun_data->is_lvm) {
|
|
||||||
+ sun_data->type = 0xfd;
|
|
||||||
+ return 1;
|
|
||||||
+ }
|
|
||||||
+ if (sun_data->is_lvm) {
|
|
||||||
sun_data->type = 0x8e;
|
|
||||||
return 1;
|
|
||||||
}
|
|
||||||
@@ -572,19 +580,25 @@
|
|
||||||
case PED_PARTITION_BOOT:
|
|
||||||
sun_data->is_boot = state;
|
|
||||||
if (state)
|
|
||||||
- sun_data->is_root = sun_data->is_lvm = 0;
|
|
||||||
+ sun_data->is_root = sun_data->is_raid = sun_data->is_lvm = 0;
|
|
||||||
return ped_partition_set_system (part, part->fs_type);
|
|
||||||
|
|
||||||
case PED_PARTITION_ROOT:
|
|
||||||
sun_data->is_root = state;
|
|
||||||
if (state)
|
|
||||||
- sun_data->is_boot = sun_data->is_lvm = 0;
|
|
||||||
+ sun_data->is_boot = sun_data->is_raid = sun_data->is_lvm = 0;
|
|
||||||
+ return ped_partition_set_system (part, part->fs_type);
|
|
||||||
+
|
|
||||||
+ case PED_PARTITION_RAID:
|
|
||||||
+ sun_data->is_raid = state;
|
|
||||||
+ if (state)
|
|
||||||
+ sun_data->is_root = sun_data->is_boot = sun_data->is_lvm = 0;
|
|
||||||
return ped_partition_set_system (part, part->fs_type);
|
|
||||||
|
|
||||||
case PED_PARTITION_LVM:
|
|
||||||
sun_data->is_lvm = state;
|
|
||||||
if (state)
|
|
||||||
- sun_data->is_root = sun_data->is_boot = 0;
|
|
||||||
+ sun_data->is_root = sun_data->is_boot = sun_data->is_raid = 0;
|
|
||||||
return ped_partition_set_system (part, part->fs_type);
|
|
||||||
|
|
||||||
default:
|
|
||||||
@@ -608,6 +622,8 @@
|
|
||||||
return sun_data->is_boot;
|
|
||||||
case PED_PARTITION_ROOT:
|
|
||||||
return sun_data->is_root;
|
|
||||||
+ case PED_PARTITION_RAID:
|
|
||||||
+ return sun_data->is_raid;
|
|
||||||
case PED_PARTITION_LVM:
|
|
||||||
return sun_data->is_lvm;
|
|
||||||
|
|
||||||
@@ -625,6 +641,7 @@
|
|
||||||
case PED_PARTITION_BOOT:
|
|
||||||
case PED_PARTITION_ROOT:
|
|
||||||
case PED_PARTITION_LVM:
|
|
||||||
+ case PED_PARTITION_RAID:
|
|
||||||
return 1;
|
|
||||||
|
|
||||||
default:
|
|
@ -1,22 +0,0 @@
|
|||||||
diff -Nru parted-1.8.8.orig/configure parted-1.8.8/configure
|
|
||||||
--- parted-1.8.8.orig/configure 2007-08-09 20:49:21.000000000 +0200
|
|
||||||
+++ parted-1.8.8/configure 2008-02-12 02:37:04.000000000 +0100
|
|
||||||
@@ -12816,7 +12816,6 @@
|
|
||||||
# native cc issues annoying warnings and then ignores it,
|
|
||||||
# which would cause us to incorrectly conclude that it worked.
|
|
||||||
for gl_flags in \
|
|
||||||
- '-Wl,--as-needed' \
|
|
||||||
'-Wl,-z,ignore' \
|
|
||||||
'-z ignore'
|
|
||||||
do
|
|
||||||
diff -Nru parted-1.8.8.orig/m4/lib-ignore.m4 parted-1.8.8/m4/lib-ignore.m4
|
|
||||||
--- parted-1.8.8.orig/m4/lib-ignore.m4 2006-07-03 10:32:46.000000000 +0200
|
|
||||||
+++ parted-1.8.8/m4/lib-ignore.m4 2008-02-12 02:36:36.000000000 +0100
|
|
||||||
@@ -26,7 +26,6 @@
|
|
||||||
# native cc issues annoying warnings and then ignores it,
|
|
||||||
# which would cause us to incorrectly conclude that it worked.
|
|
||||||
for gl_flags in \
|
|
||||||
- '-Wl,--as-needed' \
|
|
||||||
'-Wl,-z,ignore' \
|
|
||||||
'-z ignore'
|
|
||||||
do
|
|
@ -1,17 +0,0 @@
|
|||||||
diff --git a/libparted/arch/linux.c b/libparted/arch/linux.c
|
|
||||||
index aeaf98f..111816c 100644
|
|
||||||
--- a/libparted/arch/linux.c
|
|
||||||
+++ b/libparted/arch/linux.c
|
|
||||||
@@ -610,7 +610,11 @@ _get_linux_version ()
|
|
||||||
|
|
||||||
if (uname (&uts))
|
|
||||||
return kver = 0;
|
|
||||||
- if (sscanf (uts.release, "%u.%u.%u", &major, &minor, &teeny) != 3)
|
|
||||||
+ if (sscanf (uts.release, "%u.%u.%u", &major, &minor, &teeny) == 3)
|
|
||||||
+ ; /* ok */
|
|
||||||
+ else if (sscanf (uts.release, "%u.%u", &major, &minor) == 2)
|
|
||||||
+ teeny = 0;
|
|
||||||
+ else
|
|
||||||
return kver = 0;
|
|
||||||
|
|
||||||
return kver = KERNEL_VERSION (major, minor, teeny);
|
|
18
parted.spec
18
parted.spec
@ -4,18 +4,15 @@
|
|||||||
|
|
||||||
Name: parted
|
Name: parted
|
||||||
Version: 3.6
|
Version: 3.6
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: Tools for creating, destroying, resizing, checking and copying partitions
|
Summary: Tools for creating, destroying, resizing, checking and copying partitions
|
||||||
Group: System/Tools
|
Group: System/Tools
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://www.gnu.org/software/parted/
|
URL: https://www.gnu.org/software/parted/
|
||||||
Source0: http://ftp.gnu.org/gnu/parted/parted-%{version}.tar.xz
|
Source0: http://ftp.gnu.org/gnu/parted/parted-%{version}.tar.xz
|
||||||
Patch1: %{name}-1.8.6-disk_dos.patch
|
Patch1: %{name}-1.8.6-disk_dos.patch
|
||||||
Patch2: %{name}-1.8.8-readline.patch
|
|
||||||
Patch3: %{name}-1.8.6-disk_sun_raid.patch
|
|
||||||
Patch4: %{name}-2.4-kernel-3.0.patch
|
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -25,7 +22,6 @@ BuildRequires: libncurses-devel
|
|||||||
BuildRequires: libreadline-devel
|
BuildRequires: libreadline-devel
|
||||||
BuildRequires: libuuid-devel
|
BuildRequires: libuuid-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: libreiserfs-devel >= 0.3.0.4
|
|
||||||
BuildRequires: gettext-devel
|
BuildRequires: gettext-devel
|
||||||
BuildRequires: libcheck-devel
|
BuildRequires: libcheck-devel
|
||||||
Requires(post):%{__install_info}
|
Requires(post):%{__install_info}
|
||||||
@ -61,12 +57,8 @@ This package contains static libraries and header files needed for development.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch 1 -p1
|
%patch 1 -p1
|
||||||
#%patch2 -p1
|
|
||||||
#%patch3 -p1
|
|
||||||
#%patch4 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
#autoconf
|
|
||||||
%configure \
|
%configure \
|
||||||
--enable-device-mapper \
|
--enable-device-mapper \
|
||||||
%if "%{stage1}" != "1"
|
%if "%{stage1}" != "1"
|
||||||
@ -93,9 +85,6 @@ rm -f %{buildroot}%{_bindir}/label
|
|||||||
%preun
|
%preun
|
||||||
%uninstall_info %{name}.info
|
%uninstall_info %{name}.info
|
||||||
|
|
||||||
%post -n %{libname} -p /sbin/ldconfig
|
|
||||||
%postun -n %{libname} -p /sbin/ldconfig
|
|
||||||
|
|
||||||
%files -f %{name}.lang
|
%files -f %{name}.lang
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
#%{_bindir}/disk
|
#%{_bindir}/disk
|
||||||
@ -119,6 +108,9 @@ rm -f %{buildroot}%{_bindir}/label
|
|||||||
%doc BUGS ChangeLog NEWS README THANKS TODO
|
%doc BUGS ChangeLog NEWS README THANKS TODO
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Nov 05 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 3.6-2mamba
|
||||||
|
- rebuilt
|
||||||
|
|
||||||
* Wed Apr 12 2023 Automatic Build System <autodist@mambasoft.it> 3.6-1mamba
|
* Wed Apr 12 2023 Automatic Build System <autodist@mambasoft.it> 3.6-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user