rebuilt with libraw 0.15.4

added Mesa 10 build patch [release 0.9.4-2mamba;Thu Dec 26 2013]
This commit is contained in:
Silvan Calarco 2024-01-06 08:21:50 +01:00
parent 2e87bf2600
commit 1f5018ac2e
3 changed files with 165 additions and 0 deletions

View File

@ -1,2 +1,5 @@
# oyranos
Oyranos is a Colour Management System (CMS) on operating system level. It allows applications and users to match predictably input device colours to output device colours. To do so in a consistent manner, applications and workflows need to support the Oyranos CMS.
Oyranos is based one the well established ICC standard and various other specifications. System wide settings in Oyranos shall enshure consistency in a portable fashion. Oyranos will provide in the future a Colour Matching Module (CMM) framework. Users can then transparently select a desired colour engine.

View File

@ -0,0 +1,10 @@
--- oyranos-0.9.4/src/examples/image_display/GLee.h.orig 2013-12-28 15:34:24.738352277 +0100
+++ oyranos-0.9.4/src/examples/image_display/GLee.h 2013-12-28 15:33:35.821820338 +0100
@@ -64,6 +64,7 @@
#define GLX_GLXEXT_PROTOTYPES
#include <GL/gl.h>
#include <GL/glx.h>
+ typedef XID GLXContextID;
#endif
#ifndef APIENTRY

152
oyranos.spec Normal file
View File

@ -0,0 +1,152 @@
%define majver %(echo %version | cut -d. -f1-2)
Name: oyranos
Version: 0.9.4
Release: 2mamba
Summary: A Colour Management System (CMS) on operating system level
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.oyranos.org/
Source: http://downloads.sourceforge.net/project/oyranos/Oyranos/Oyranos%20%{majver}/oyranos-%{version}.tar.bz2
Patch0: oyranos-0.9.4-Mesa-10.patch
License: BSD
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libGL-devel
BuildRequires: libICE-devel
BuildRequires: libSM-devel
BuildRequires: libX11-devel
BuildRequires: libXcm-devel
BuildRequires: libXext-devel
BuildRequires: libXfixes-devel
BuildRequires: libXft-devel
BuildRequires: libXinerama-devel
BuildRequires: libXrandr-devel
BuildRequires: libXxf86vm-devel
BuildRequires: libcairo-devel
BuildRequires: libcups-devel
BuildRequires: libelektra-devel
BuildRequires: libexiv2-devel
BuildRequires: libfltk-devel
BuildRequires: libfontconfig-devel
BuildRequires: libgcc
BuildRequires: libgomp-devel
BuildRequires: liblcms-devel
BuildRequires: liblcms2-devel
BuildRequires: libltdl-devel
BuildRequires: libpng-devel
BuildRequires: libqt4-devel
BuildRequires: libraw-devel
BuildRequires: libstdc++6-devel
BuildRequires: libxml2-devel
BuildRequires: libyajl-devel
## AUTOBUILDREQ-END
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
Oyranos is a Colour Management System (CMS) on operating system level. It allows applications and users to match predictably input device colours to output device colours. To do so in a consistent manner, applications and workflows need to support the Oyranos CMS.
Oyranos is based one the well established ICC standard and various other specifications. System wide settings in Oyranos shall enshure consistency in a portable fashion. Oyranos will provide in the future a Colour Matching Module (CMM) framework. Users can then transparently select a desired colour engine.
%package devel
Summary: Devel package for %{name}
Group: Development/Libraries
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description devel
Oyranos is a Colour Management System (CMS) on operating system level. It allows applications and users to match predictably input device colours to output device colours. To do so in a consistent manner, applications and workflows need to support the Oyranos CMS.
Oyranos is based one the well established ICC standard and various other specifications. System wide settings in Oyranos shall enshure consistency in a portable fashion. Oyranos will provide in the future a Colour Matching Module (CMM) framework. Users can then transparently select a desired colour engine.
This package contains static libraries and header files need for development.
%prep
%setup -q
%patch0 -p1
%build
%configure
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
%find_lang %{name}
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files -f %{name}.lang
%defattr(-,root,root)
%{_sysconfdir}/xdg/autostart/oyranos-monitor-setup.desktop
%{_bindir}/oyranos-icc
%{_bindir}/oyranos-monitor-daemon
%{_bindir}/oyranos-profile
%{_bindir}/oyranos-profile-graph
%{_bindir}/oyranos-profile-install
%{_bindir}/oyranos-profiles
%{_bindir}/qcmsevents
#%{_bindir}/oyranos-xforms
#%{_bindir}/oyranos-xforms-fltk
%{_bindir}/oyranos-xforms-modules
%{_libdir}/liboyranos*.so.*
#%{_libdir}/liboyranos_moni.so.*
#%{_libdir}/color/cmms/liboyranos_*_cmm_module.so.%{version}
#%{_datadir}/color/icc/*.ICM
#%{_datadir}/color/icc/*.icc
%{_datadir}/applications/oyranos-profile-install.desktop
%{_datadir}/applications/qcmsevents-applet.desktop
%{_datadir}/color/settings/*.xml
#%{_datadir}/color/target/*.ti3
#%{_datadir}/mime/packages/*.xml
%{_datadir}/pixmaps/*.png
%{_datadir}/pixmaps/qcmsevents.svg
%{_libdir}/colour/modules/liboyranos*
%{_libdir}/oyranos/liboyranos*
#%{_mandir}/man1/oyranos-config.1.gz
%doc %{_docdir}/oyranos
%{_mandir}/man1/oyranos-*.1*
%{_mandir}/man1/qcmsevents.1*
%{_mandir}/man3/oyranos.3.gz
%{_mandir}/man3/oyranos-config.3.gz
%doc AUTHORS COPYING
%files devel
%defattr(-,root,root)
%{_bindir}/oyranos-config
%{_bindir}/oyranos-config-fltk
%{_bindir}/oyranos-monitor
#%{_bindir}/oyranos-monitor-nvidia
%{_bindir}/oyranos-policy
%dir %{_includedir}/oyranos
%{_includedir}/oyranos/*.h
%dir %{_includedir}/oyranos/alpha
%{_includedir}/oyranos/alpha/*.h
%{_libdir}/liboyranos*.a
%{_libdir}/liboyranos*.so
#%{_libdir}/liboyforms_fltk.a
%{_libdir}/oyranos/cmake/OyranosConfig.cmake
%{_libdir}/pkgconfig/oyranos.pc
%doc ChangeLog README
%changelog
* Thu Dec 26 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.4-2mamba
- rebuilt with libraw 0.15.4
- added Mesa 10 build patch
* Sun Apr 14 2013 Automatic Build System <autodist@mambasoft.it> 0.9.4-1mamba
- automatic version update by autodist
* Tue Nov 13 2012 Automatic Build System <autodist@mambasoft.it> 0.9.0-1mamba
- update to 0.9.0
* Fri Jul 06 2012 Automatic Build System <autodist@mambasoft.it> 0.4.0-1mamba
- update to 0.4.0
* Mon Oct 24 2011 Automatic Build System <autodist@mambasoft.it> 0.3.2-1mamba
- update to 0.3.2
* Thu Sep 16 2010 Automatic Build System <autodist@mambasoft.it> 0.1.10-1mamba
- update to 0.1.10
* Mon May 18 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.1.9-1mamba
- package created by autospec