221 lines
8.0 KiB
RPMSpec
221 lines
8.0 KiB
RPMSpec
%define majver %(echo %version | cut -d. -f1-2)
|
|
|
|
Name: oxygen-icons
|
|
Version: 5.115.0
|
|
Release: 1mamba
|
|
Summary: KDE Frameworks 5 Oxygen icons theme
|
|
Group: Graphical Desktop/Look 'n' feel
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://kde.org/
|
|
Source: https://download.kde.org/stable/frameworks/%{majver}/oxygen-icons-%{version}.tar.xz
|
|
Source1: openmamba.svgz
|
|
License: LGPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: cmake
|
|
BuildRequires: rpm-macros-kde5
|
|
BuildRequires: extra-cmake-modules
|
|
BuildRequires: ImageMagick
|
|
Provides: oxygen-icons5
|
|
Obsoletes: oxygen-icons5 < 5.113.0
|
|
Provides: oxygen-icons-svg
|
|
Obsoletes: oxygen-icons-svg < 5.83.0
|
|
|
|
%description
|
|
KDE Frameworks 5 Oxygen icons theme.
|
|
|
|
%prep
|
|
%setup -q
|
|
|
|
%build
|
|
%cmake_kde5 -d build
|
|
%make
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall -C build
|
|
|
|
# install openmamba icons
|
|
for s in 16x16 22x22 32x32 48x48 64x64 128x128 256x256; do
|
|
convert -background none -resize $s %{SOURCE1} \
|
|
%{buildroot}%{_datadir}/icons/oxygen/base/$s/apps/openmamba.png
|
|
rm %{buildroot}%{_datadir}/icons/oxygen/base/$s/places/start-here-kde.png
|
|
rm %{buildroot}%{_datadir}/icons/oxygen/base/$s/places/start-here.png
|
|
ln -s ../apps/openmamba.png %{buildroot}%{_datadir}/icons/oxygen/base/$s/places/start-here-kde.png
|
|
ln -s ../apps/openmamba.png %{buildroot}%{_datadir}/icons/oxygen/base/$s/places/start-here.png
|
|
done
|
|
|
|
#install -m0644 %{S:1} %{buildroot}%{_datadir}/icons/oxygen/scalable/places/start-here-kde.svgz
|
|
#install -m0644 %{S:1} %{buildroot}%{_datadir}/icons/oxygen/scalable/apps/openmamba.svgz
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%posttrans
|
|
gtk-update-icon-cache %{_datadir}/icons/oxygen/base &>/dev/null || :
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%dir %{_datadir}/icons/oxygen/base
|
|
%{_datadir}/icons/oxygen/index.theme
|
|
%dir %{_datadir}/icons/oxygen/base
|
|
%dir %{_datadir}/icons/oxygen/base/*/*
|
|
%{_datadir}/icons/oxygen/base/*/*/*.png
|
|
%doc AUTHORS COPYING COPYING.LIB
|
|
|
|
%changelog
|
|
* Mon Feb 12 2024 Automatic Build System <autodist@openmamba.org> 5.115.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Jan 13 2024 Automatic Build System <autodist@openmamba.org> 5.114.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Dec 17 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 5.113.0-1mamba
|
|
- update to 5.113.0
|
|
|
|
* Thu Nov 16 2023 Automatic Build System <autodist@mambasoft.it> 5.112.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Oct 19 2023 Automatic Build System <autodist@mambasoft.it> 5.111.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Sep 10 2023 Automatic Build System <autodist@mambasoft.it> 5.110.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Aug 18 2023 Automatic Build System <autodist@mambasoft.it> 5.109.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Jul 09 2023 Automatic Build System <autodist@mambasoft.it> 5.108.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Jun 12 2023 Automatic Build System <autodist@mambasoft.it> 5.107.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun May 14 2023 Automatic Build System <autodist@mambasoft.it> 5.106.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Apr 09 2023 Automatic Build System <autodist@mambasoft.it> 5.105.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Mar 11 2023 Automatic Build System <autodist@mambasoft.it> 5.104.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Feb 13 2023 Automatic Build System <autodist@mambasoft.it> 5.103.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Jan 16 2023 Automatic Build System <autodist@mambasoft.it> 5.102.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Dec 11 2022 Automatic Build System <autodist@mambasoft.it> 5.101.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Nov 15 2022 Automatic Build System <autodist@mambasoft.it> 5.100.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Oct 11 2022 Automatic Build System <autodist@mambasoft.it> 5.99.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Sep 11 2022 Automatic Build System <autodist@mambasoft.it> 5.98.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Aug 16 2022 Automatic Build System <autodist@mambasoft.it> 5.97.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Jul 10 2022 Automatic Build System <autodist@mambasoft.it> 5.96.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Jun 13 2022 Automatic Build System <autodist@mambasoft.it> 5.95.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun May 15 2022 Automatic Build System <autodist@mambasoft.it> 5.94.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Apr 10 2022 Automatic Build System <autodist@mambasoft.it> 5.93.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Mar 13 2022 Automatic Build System <autodist@mambasoft.it> 5.92.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Feb 14 2022 Automatic Build System <autodist@mambasoft.it> 5.91.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Jan 08 2022 Automatic Build System <autodist@mambasoft.it> 5.90.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Dec 14 2021 Automatic Build System <autodist@mambasoft.it> 5.89.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Nov 13 2021 Automatic Build System <autodist@mambasoft.it> 5.88.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Oct 11 2021 Automatic Build System <autodist@mambasoft.it> 5.87.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Sep 12 2021 Automatic Build System <autodist@mambasoft.it> 5.86.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Aug 16 2021 Automatic Build System <autodist@mambasoft.it> 5.85.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Jul 11 2021 Automatic Build System <autodist@mambasoft.it> 5.84.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Jun 15 2021 Automatic Build System <autodist@mambasoft.it> 5.83.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun May 09 2021 Automatic Build System <autodist@mambasoft.it> 5.82.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Apr 10 2021 Automatic Build System <autodist@mambasoft.it> 5.81.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Mar 14 2021 Automatic Build System <autodist@mambasoft.it> 5.80.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Feb 13 2021 Automatic Build System <autodist@mambasoft.it> 5.79.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Jan 14 2021 Automatic Build System <autodist@mambasoft.it> 5.78.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Dec 24 2020 Automatic Build System <autodist@mambasoft.it> 5.77.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Nov 16 2020 Automatic Build System <autodist@mambasoft.it> 5.76.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Oct 14 2020 Automatic Build System <autodist@mambasoft.it> 5.75.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Sep 15 2020 Automatic Build System <autodist@mambasoft.it> 5.74.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Aug 10 2020 Automatic Build System <autodist@mambasoft.it> 5.73.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Jul 14 2020 Automatic Build System <autodist@mambasoft.it> 5.72.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Jun 16 2020 Automatic Build System <autodist@mambasoft.it> 5.71.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon May 11 2020 Automatic Build System <autodist@mambasoft.it> 5.70.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Apr 14 2020 Automatic Build System <autodist@mambasoft.it> 5.69.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Mar 17 2020 Automatic Build System <autodist@mambasoft.it> 5.68.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Feb 11 2020 Automatic Build System <autodist@mambasoft.it> 5.67.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Jan 14 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 5.66.0-1mamba
|
|
- update to 5.66.0
|
|
|
|
* Wed Jan 01 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 5.65.0-1mamba
|
|
- package created using the webbuild interface
|