automatic update by autodist [release 1.63-1mamba;Mon Aug 26 2013]
This commit is contained in:
parent
64e7ba894b
commit
b98e85a831
@ -1,2 +1,4 @@
|
|||||||
# os-prober
|
# os-prober
|
||||||
|
|
||||||
|
This package detects other OSes available on a system and outputs the results in a generic machine-readable format.
|
||||||
|
|
||||||
|
33
os-prober-1.61-openmamba-EFI-32_64_bit_mismatch.patch
Normal file
33
os-prober-1.61-openmamba-EFI-32_64_bit_mismatch.patch
Normal file
@ -0,0 +1,33 @@
|
|||||||
|
diff -Nru os-prober-1.61.orig/common.sh os-prober-1.61/common.sh
|
||||||
|
--- os-prober-1.61.orig/common.sh 2012-03-27 16:40:21.000000000 +0200
|
||||||
|
+++ os-prober-1.61/common.sh 2013-06-11 17:50:55.462903518 +0200
|
||||||
|
@@ -1,3 +1,5 @@
|
||||||
|
+. /etc/sysconfig/grub
|
||||||
|
+
|
||||||
|
newns () {
|
||||||
|
[ "$OS_PROBER_NEWNS" ] || exec /usr/lib/os-prober/newns "$0" "$@"
|
||||||
|
}
|
||||||
|
diff -Nru os-prober-1.61.orig/os-probes/mounted/x86/05efi os-prober-1.61/os-probes/mounted/x86/05efi
|
||||||
|
--- os-prober-1.61.orig/os-probes/mounted/x86/05efi 2013-05-17 14:01:45.000000000 +0200
|
||||||
|
+++ os-prober-1.61/os-probes/mounted/x86/05efi 2013-06-11 17:51:09.340827559 +0200
|
||||||
|
@@ -8,7 +8,7 @@
|
||||||
|
type="$3"
|
||||||
|
|
||||||
|
# This file is for UEFI platform only
|
||||||
|
-if [ ! -d /sys/firmware/efi ]; then
|
||||||
|
+if [ ! -d /sys/firmware/efi -a ! "$GRUB_INSTALL_DEVICE_EFI" ]; then
|
||||||
|
debug "Not on UEFI platform"
|
||||||
|
exit 1
|
||||||
|
fi
|
||||||
|
diff -Nru os-prober-1.61.orig/os-probes/mounted/x86/20microsoft os-prober-1.61/os-probes/mounted/x86/20microsoft
|
||||||
|
--- os-prober-1.61.orig/os-probes/mounted/x86/20microsoft 2013-05-14 22:05:55.000000000 +0200
|
||||||
|
+++ os-prober-1.61/os-probes/mounted/x86/20microsoft 2013-06-11 17:51:13.914802216 +0200
|
||||||
|
@@ -8,7 +8,7 @@
|
||||||
|
type="$3"
|
||||||
|
|
||||||
|
# This script looks for legacy BIOS bootloaders only. Skip if running UEFI
|
||||||
|
-if [ -d /sys/firmware/efi ]; then
|
||||||
|
+if [ -d /sys/firmware/efi -o "$GRUB_INSTALL_DEVICE_EFI" ]; then
|
||||||
|
debug "Skipping legacy bootloaders on UEFI system"
|
||||||
|
exit 1
|
||||||
|
fi
|
111
os-prober.spec
Normal file
111
os-prober.spec
Normal file
@ -0,0 +1,111 @@
|
|||||||
|
Name: os-prober
|
||||||
|
Version: 1.63
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: Utility to detect other OSes on a set of drives
|
||||||
|
Group: System/Tools
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://joeyh.name/code/os-prober/
|
||||||
|
Source: http://ftp.de.debian.org/debian/pool/main/o/os-prober/os-prober_%{version}.tar.gz
|
||||||
|
Patch0: os-prober-1.61-openmamba-EFI-32_64_bit_mismatch.patch
|
||||||
|
License: GPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
This package detects other OSes available on a system and outputs the results in a generic machine-readable format.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
%make
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
for f in os-prober linux-boot-prober; do
|
||||||
|
install -D -m0755 $f %{buildroot}%{_sbindir}/$f
|
||||||
|
done
|
||||||
|
|
||||||
|
install -D -m0755 common.sh %{buildroot}%{_datadir}/os-prober/common.sh
|
||||||
|
install -D -m0755 newns %{buildroot}%{_prefix}/lib/os-prober/newns
|
||||||
|
|
||||||
|
install -D -m0755 ./os-probes/common/50mounted-tests \
|
||||||
|
%{buildroot}%{_prefix}/lib/os-probes/50mounted-tests
|
||||||
|
|
||||||
|
install -D -m0755 ./os-probes/init/common/10filesystems \
|
||||||
|
%{buildroot}%{_prefix}/lib/os-probes/init/10filesystems
|
||||||
|
|
||||||
|
install -D -m0755 ./linux-boot-probes/common/50mounted-tests \
|
||||||
|
%{buildroot}%{_prefix}/lib/linux-boot-probes/50mounted-tests
|
||||||
|
|
||||||
|
install -d -m0755 %{buildroot}%{_prefix}/lib/os-probes/mounted
|
||||||
|
install -d -m0755 %{buildroot}%{_prefix}/lib/linux-boot-probes/mounted/
|
||||||
|
|
||||||
|
cp -a ./linux-boot-probes/mounted/common/* \
|
||||||
|
%{buildroot}%{_prefix}/lib/linux-boot-probes/mounted/
|
||||||
|
|
||||||
|
cp -a ./os-probes/mounted/common/* \
|
||||||
|
%{buildroot}%{_prefix}/lib/os-probes/mounted/
|
||||||
|
|
||||||
|
%ifarch %{ix86} x86_64
|
||||||
|
cp -a ./os-probes/mounted/x86/* %{buildroot}%{_prefix}/lib/os-probes/mounted/
|
||||||
|
cp -a ./linux-boot-probes/mounted/x86/* %{buildroot}%{_prefix}/lib/linux-boot-probes/mounted/
|
||||||
|
%else
|
||||||
|
echo "Arch not supported; aborting."
|
||||||
|
exit 1
|
||||||
|
%endif
|
||||||
|
|
||||||
|
install -d -m0755 %{buildroot}%{_localstatedir}/lib/os-prober
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_sbindir}/linux-boot-prober
|
||||||
|
%{_sbindir}/os-prober
|
||||||
|
%dir %{_prefix}/lib/linux-boot-probes
|
||||||
|
%{_prefix}/lib/linux-boot-probes/50mounted-tests
|
||||||
|
%dir %{_prefix}/lib/linux-boot-probes/mounted
|
||||||
|
%{_prefix}/lib/linux-boot-probes/mounted/*
|
||||||
|
%dir %{_prefix}/lib/os-prober
|
||||||
|
%{_prefix}/lib/os-prober/newns
|
||||||
|
%{_prefix}/lib/os-probes/50mounted-tests
|
||||||
|
%dir %{_prefix}/lib/os-probes/init
|
||||||
|
%{_prefix}/lib/os-probes/init/10filesystems
|
||||||
|
%dir %{_prefix}/lib/os-probes/mounted
|
||||||
|
%{_prefix}/lib/os-probes/mounted/*
|
||||||
|
%dir %{_datadir}/os-prober
|
||||||
|
%{_datadir}/os-prober/common.sh
|
||||||
|
%dir %{_localstatedir}/lib/os-prober
|
||||||
|
%doc debian/copyright
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Aug 26 2013 Automatic Build System <autodist@mambasoft.it> 1.63-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Mon Aug 05 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.62-2mamba
|
||||||
|
- also install missing common files to fix other linuxes detection
|
||||||
|
|
||||||
|
* Sat Jul 20 2013 Automatic Build System <autodist@mambasoft.it> 1.62-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Tue Jun 11 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.61-3mamba
|
||||||
|
- patch0: check in /etc/sysconfg/grub if bootloader is EFI to support when efivars are not available in 32/64 bits mixed mode
|
||||||
|
|
||||||
|
* Mon Jun 10 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.61-2mamba
|
||||||
|
- fixed installation path of files to make it work (more)
|
||||||
|
|
||||||
|
* Sun Jun 09 2013 Automatic Build System <autodist@mambasoft.it> 1.61-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Fri May 17 2013 Automatic Build System <autodist@mambasoft.it> 1.59-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Tue Mar 05 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.57-1mamba
|
||||||
|
- package created by silvan using the webbuild interface
|
Loading…
Reference in New Issue
Block a user