automatic rebuild by autodist [release 0.4.2-3mamba;Thu Sep 05 2013]
This commit is contained in:
parent
80336ec39c
commit
3c326168b4
@ -1,2 +1,4 @@
|
|||||||
# openwince-devel
|
# openwince-devel
|
||||||
|
|
||||||
|
This is a collection of the useful independent include files for C/Assembler developers. Released under BSD-style license.
|
||||||
|
|
||||||
|
12
openwince-0.4.2-detectflash.patch
Normal file
12
openwince-0.4.2-detectflash.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -Nru include-0.4.2.orig/brux/flash.h include-0.4.2/brux/flash.h
|
||||||
|
--- include-0.4.2.orig/brux/flash.h 2003-11-02 22:30:46.000000000 +0100
|
||||||
|
+++ include-0.4.2/brux/flash.h 2006-08-23 17:28:29.000000000 +0200
|
||||||
|
@@ -58,7 +58,7 @@
|
||||||
|
#define FLASH_ERROR_BLOCK_LOCKED 3
|
||||||
|
#define FLASH_ERROR_UNKNOWN 99
|
||||||
|
|
||||||
|
-void detectflash( bus_t *bus, uint32_t adr );
|
||||||
|
+void detectflash( bus_t *bus );
|
||||||
|
|
||||||
|
void flashmem( bus_t *bus, FILE *f, uint32_t addr );
|
||||||
|
void flashmsbin( bus_t *bus, FILE *f );
|
19
openwince-0.4.2-pxabuswidth_header.patch
Normal file
19
openwince-0.4.2-pxabuswidth_header.patch
Normal file
@ -0,0 +1,19 @@
|
|||||||
|
diff -ruN include/brux/bus.h includeMatej/brux/bus.h
|
||||||
|
--- include/brux/bus.h Fri Sep 5 16:42:22 2003
|
||||||
|
+++ includeMatej/brux/bus.h Thu Dec 18 11:20:25 2003
|
||||||
|
@@ -59,6 +59,7 @@
|
||||||
|
uint32_t (*read_end)( bus_t *bus );
|
||||||
|
uint32_t (*read)( bus_t *bus, uint32_t adr );
|
||||||
|
void (*write)( bus_t *bus, uint32_t adr, uint32_t data );
|
||||||
|
+ int (*init) (bus_t *bus);
|
||||||
|
} bus_driver_t;
|
||||||
|
|
||||||
|
struct bus {
|
||||||
|
@@ -77,5 +78,6 @@
|
||||||
|
#define bus_read(bus,adr) bus->driver->read(bus,adr)
|
||||||
|
#define bus_write(bus,adr,data) bus->driver->write(bus,adr,data)
|
||||||
|
#define bus_free(bus) bus->driver->free_bus(bus)
|
||||||
|
+#define bus_init(bus) bus->driver->init(bus)
|
||||||
|
|
||||||
|
#endif /* BRUX_BUS_H */
|
||||||
|
|
48
openwince-devel.spec
Normal file
48
openwince-devel.spec
Normal file
@ -0,0 +1,48 @@
|
|||||||
|
Name: openwince-devel
|
||||||
|
Version: 0.4.2
|
||||||
|
Release: 3mamba
|
||||||
|
Summary: a collection of the useful independent include files for C/Assembler developers
|
||||||
|
Group: Development/Libraries
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://openwince.sourceforge.net/include/
|
||||||
|
Source: http://downloads.sourceforge.net/sourceforge/openwince/include-%{version}.tar.bz2
|
||||||
|
Patch0: openwince-0.4.2-detectflash.patch
|
||||||
|
Patch1: openwince-0.4.2-pxabuswidth_header.patch
|
||||||
|
License: BSD
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
This is a collection of the useful independent include files for C/Assembler developers. Released under BSD-style license.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -n include-%{version} -q
|
||||||
|
%patch1 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
%configure
|
||||||
|
%make
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_includedir}/openwince
|
||||||
|
%{_includedir}/openwince/*
|
||||||
|
%doc AUTHORS COPYING ChangeLog NEWS README
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Thu Sep 05 2013 Automatic Build System <autodist@mambasoft.it> 0.4.2-3mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Tue Jan 16 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 0.4.2-2qilnx
|
||||||
|
- rebuilt
|
||||||
|
|
||||||
|
* Wed Aug 23 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 0.4.2-1qilnx
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user