update to 22.7.9 [release 22.7.9-1mamba;Fri Feb 16 2024]
This commit is contained in:
parent
4a7e92ab14
commit
703c7e6216
@ -1,12 +0,0 @@
|
||||
diff -Nru openvas-scanner-4.0.7.orig/CMakeLists.txt openvas-scanner-4.0.7/CMakeLists.txt
|
||||
--- openvas-scanner-4.0.7.orig/CMakeLists.txt 2015-03-04 11:49:44.000000000 +0100
|
||||
+++ openvas-scanner-4.0.7/CMakeLists.txt 2016-02-06 00:04:50.872602833 +0100
|
||||
@@ -242,7 +242,7 @@
|
||||
set (HARDENING_FLAGS "-Wformat -Wformat-security -O2 -D_FORTIFY_SOURCE=2 -fstack-protector -Wl,-z,relro -Wl,-z,now")
|
||||
|
||||
set (CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -Werror")
|
||||
-set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${HARDENING_FLAGS} -Wall -D_BSD_SOURCE -D_ISOC99_SOURCE -D_SVID_SOURCE")
|
||||
+set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${HARDENING_FLAGS} -Wall -D_DEFAULT_SOURCE -D_ISOC99_SOURCE")
|
||||
|
||||
add_subdirectory (src)
|
||||
|
@ -1,66 +1,64 @@
|
||||
Name: openvas-scanner
|
||||
Version: 4.0.7
|
||||
Version: 22.7.9
|
||||
Release: 1mamba
|
||||
Summary: Server files for OpenVAS, an Open Vulnerability Assessment System
|
||||
Group: Network/Monitoring
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.nessus.org
|
||||
Source0: http://wald.intevation.org/frs/download.php/2101/openvas-scanner-%{version}.tar.gz
|
||||
Source1: openvasd-initscript
|
||||
Patch0: openvas-scanner-4.0.7-glibc-2.22.patch
|
||||
URL: https://www.tenable.com/
|
||||
Source0: https://github.com/greenbone/openvas-scanner.git/v%{version}/openvas-scanner-%{version}.tar.bz2
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libassuan-devel
|
||||
BuildRequires: libbsd-devel
|
||||
BuildRequires: libgcrypt-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libgnutls-devel
|
||||
BuildRequires: libgpg-error-devel
|
||||
BuildRequires: libgpgme-devel
|
||||
BuildRequires: openvas-libraries-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libgvm-devel
|
||||
BuildRequires: libjson-glib-devel
|
||||
BuildRequires: libksba-devel
|
||||
BuildRequires: libnetsnmp-devel
|
||||
BuildRequires: libopenssl-devel
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-build
|
||||
Obsoletes: nessus
|
||||
BuildRequires: libpcap-devel
|
||||
BuildRequires: libssh-devel
|
||||
## AUTOBUILDREQ-END
|
||||
Requires: libopenvas = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Provides: nessus
|
||||
Obsoletes: nessus < 22.7.9
|
||||
Provides: openvas-server
|
||||
Obsoletes: openvas-server
|
||||
Obsoletes: openvas-server < 22.7.9
|
||||
Provides: libnasl
|
||||
Obsoletes: libnasl
|
||||
Obsoletes: libnasl < 22.7.9
|
||||
Provides: openvas-plugins
|
||||
Obsoletes: openvas-plugins
|
||||
Requires(pre): openssl
|
||||
# FIXME:
|
||||
# file /usr/include/nessus/includes.h from install of
|
||||
# nessus-devel-2.0.10-1qilnx conflicts with file from package
|
||||
# nessus-libraries-devel-2.0.9-1qilnx
|
||||
Obsoletes: openvas-plugins < 22.7.9
|
||||
|
||||
%description
|
||||
OpenVAS stands for Open Vulnerability Assessment System and is a network security scanner with associated tools like a graphical user fontend. The core is a server component with a set of network vulnerability tests (NVTs) to detect security problems in remote systems and applications.
|
||||
This project is a fork of the latest GPL release of Nessus.
|
||||
This package contains the server related files.
|
||||
|
||||
%package devel
|
||||
Summary: Devel package for openvas-server
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{version}
|
||||
Obsoletes: nessus-devel
|
||||
%package -n libopenvas
|
||||
Group: System/Libraries
|
||||
Summary: Shared libraries provided with %{name}
|
||||
Provides: nessus-devel
|
||||
Obsoletes: nessus-devel < 22.7.9
|
||||
Provides: openvas-server-devel
|
||||
Obsoletes: openvas-server-devel
|
||||
Obsoletes: openvas-server-devel < 22.7.9
|
||||
Obsoletes: openvas-libraries <= 7.0.10-1mamba
|
||||
Obsoletes: openvas-libraries-devel <= 7.0.10-1mamba
|
||||
Provides: libnasl-devel
|
||||
Obsoletes: libnasl-devel
|
||||
Obsoletes: libnasl-devel < 22.7.9
|
||||
|
||||
%description devel
|
||||
OpenVAS stands for Open Vulnerability Assessment System and is a network security scanner with associated tools like a graphical user fontend. The core is a server component with a set of network vulnerability tests (NVTs) to detect security problems in remote systems and applications.
|
||||
This project is a fork of the latest GPL release of Nessus.
|
||||
This is the development package for the server related package.
|
||||
%description -n libopenvas
|
||||
This package contains shared libraries provides with %{name}.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
%cmake -d build
|
||||
@ -68,61 +66,43 @@ This is the development package for the server related package.
|
||||
%make
|
||||
|
||||
%install
|
||||
test x"%buildroot" != x/ && rm -rf "%buildroot"
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall -C build
|
||||
#% makeoldinstall OPENVASD_LOGDIR=%{buildroot}/var/log/openvas OPENVASD_CACHEDIR=%{buildroot}/var/cache/openvas
|
||||
|
||||
#install -D -m0755 %{SOURCE1} %{buildroot}%{_initrddir}/openvasd
|
||||
#install -D -m0644 packaging/debian/openvasd.conf %{buildroot}%{_sysconfdir}/openvas/openvasd.conf
|
||||
|
||||
#install -d -m0755 \
|
||||
# %{buildroot}%{_sysconfdir}/openvas/CA \
|
||||
# %{buildroot}/var/lib/openvas/plugins \
|
||||
# %{buildroot}/var/cache/openvas
|
||||
|
||||
%clean
|
||||
test x"%buildroot" != x/ && rm -rf "%buildroot"
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
#%post
|
||||
#if [ ! -e /var/lib/openvas/private/CA/cakey.pem ]; then
|
||||
# %{_sbindir}/openvas-mkcert -q
|
||||
# # chkconfig --add nessusd
|
||||
# # %{_initrddir}/nessusd start
|
||||
#fi
|
||||
#exit 0
|
||||
|
||||
#%preun
|
||||
#if [ $1 -eq 0 ]; then
|
||||
# chkconfig --del openvasd 2>/dev/null
|
||||
# service openvasd stop 2>/dev/null
|
||||
#fi
|
||||
#exit 0
|
||||
|
||||
#%postun
|
||||
#if [ $1 -eq 1 ]; then
|
||||
# test -e /var/lock/subsys/openvasd && \
|
||||
# service openvasd restart
|
||||
#fi
|
||||
#exit 0
|
||||
|
||||
%files
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_sbindir}/openvas-mkcert-client
|
||||
%{_sbindir}/greenbone-nvt-sync
|
||||
%{_sbindir}/openvas-mkcert
|
||||
%{_sbindir}/openvas-nvt-sync
|
||||
%{_sbindir}/openvassd
|
||||
%config(noreplace) %{_sysconfdir}/openvas/openvas_log.conf
|
||||
%{_bindir}/greenbone-nvt-sync
|
||||
%{_bindir}/openvas-nasl
|
||||
%{_bindir}/openvas-nasl-lint
|
||||
%{_sbindir}/openvas
|
||||
%{_mandir}/man1/openvas-nasl-lint.1*
|
||||
%{_mandir}/man1/openvas-nasl.1*
|
||||
%{_mandir}/man8/greenbone-nvt-sync.8*
|
||||
%{_mandir}/man8/openvas*.8*
|
||||
|
||||
%files -n libopenvas
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libopenvas_misc.so
|
||||
%{_libdir}/libopenvas_misc.so.*
|
||||
%{_libdir}/libopenvas_nasl.so
|
||||
%{_libdir}/libopenvas_nasl.so.*
|
||||
%doc COPYING
|
||||
|
||||
%changelog
|
||||
* Fri Feb 16 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 22.7.9-1mamba
|
||||
- update to 22.7.9
|
||||
|
||||
* Sat Feb 06 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 4.0.7-1mamba
|
||||
- update to 4.0.7
|
||||
|
||||
* Fri Nov 14 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 4.0.4-1mamba
|
||||
* Sat Nov 15 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 4.0.4-1mamba
|
||||
- update to 4.0.4
|
||||
|
||||
* Sat Nov 15 2014 Automatic Build System <autodist@mambasoft.it> 4.0.3-1mamba
|
||||
* Fri Nov 14 2014 Automatic Build System <autodist@mambasoft.it> 4.0.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Aug 10 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 3.1.0-1mamba
|
||||
|
@ -1,49 +0,0 @@
|
||||
#!/bin/sh
|
||||
#
|
||||
# Startup script for OpenVAS
|
||||
#
|
||||
# chkconfig: 345 85 15
|
||||
# description: OpenVas is a security auditing tool
|
||||
# processname: openvasd
|
||||
# config: /etc/nessus/openvasd.conf
|
||||
|
||||
|
||||
# Source function library.
|
||||
. /etc/rc.d/init.d/functions
|
||||
|
||||
# -a 127.0.0.1 : restricted to localhost, add it for restricted access
|
||||
#OPTIONS="-a 127.0.0.1"
|
||||
OPTIONS=""
|
||||
|
||||
# See how we were called.
|
||||
case "$1" in
|
||||
start)
|
||||
gprintf "Starting openvasd: "
|
||||
if [ -f /var/lock/subsys/openvasd ] ; then
|
||||
echo
|
||||
exit 1
|
||||
fi
|
||||
|
||||
daemon /usr/sbin/openvasd $OPTIONS -D
|
||||
echo
|
||||
touch /var/lock/subsys/openvasd
|
||||
;;
|
||||
stop)
|
||||
gprintf "Shutting down openvasd: "
|
||||
killproc openvasd
|
||||
echo
|
||||
rm -f /var/lock/subsys/openvasd
|
||||
;;
|
||||
status)
|
||||
status openvasd
|
||||
;;
|
||||
reload|restart)
|
||||
$0 stop
|
||||
$0 start
|
||||
;;
|
||||
*)
|
||||
gprintf "Usage: %s {start|stop|restart|reload|status}\n" "$0"
|
||||
exit 1
|
||||
esac
|
||||
|
||||
exit 0
|
Loading…
Reference in New Issue
Block a user