update to 4.0.7 [release 4.0.7-1mamba;Sat Feb 06 2016]
This commit is contained in:
parent
c0b5f2434a
commit
4a7e92ab14
12
openvas-scanner-4.0.7-glibc-2.22.patch
Normal file
12
openvas-scanner-4.0.7-glibc-2.22.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -Nru openvas-scanner-4.0.7.orig/CMakeLists.txt openvas-scanner-4.0.7/CMakeLists.txt
|
||||||
|
--- openvas-scanner-4.0.7.orig/CMakeLists.txt 2015-03-04 11:49:44.000000000 +0100
|
||||||
|
+++ openvas-scanner-4.0.7/CMakeLists.txt 2016-02-06 00:04:50.872602833 +0100
|
||||||
|
@@ -242,7 +242,7 @@
|
||||||
|
set (HARDENING_FLAGS "-Wformat -Wformat-security -O2 -D_FORTIFY_SOURCE=2 -fstack-protector -Wl,-z,relro -Wl,-z,now")
|
||||||
|
|
||||||
|
set (CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -Werror")
|
||||||
|
-set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${HARDENING_FLAGS} -Wall -D_BSD_SOURCE -D_ISOC99_SOURCE -D_SVID_SOURCE")
|
||||||
|
+set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${HARDENING_FLAGS} -Wall -D_DEFAULT_SOURCE -D_ISOC99_SOURCE")
|
||||||
|
|
||||||
|
add_subdirectory (src)
|
||||||
|
|
@ -1,5 +1,5 @@
|
|||||||
Name: openvas-scanner
|
Name: openvas-scanner
|
||||||
Version: 3.1.0
|
Version: 4.0.7
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: Server files for OpenVAS, an Open Vulnerability Assessment System
|
Summary: Server files for OpenVAS, an Open Vulnerability Assessment System
|
||||||
Group: Network/Monitoring
|
Group: Network/Monitoring
|
||||||
@ -7,8 +7,9 @@ Vendor: openmamba
|
|||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://www.nessus.org
|
URL: http://www.nessus.org
|
||||||
Source0: http://wald.intevation.org/frs/download.php/754/openvas-scanner-%{version}.tar.gz
|
Source0: http://wald.intevation.org/frs/download.php/2101/openvas-scanner-%{version}.tar.gz
|
||||||
Source1: openvasd-initscript
|
Source1: openvasd-initscript
|
||||||
|
Patch0: openvas-scanner-4.0.7-glibc-2.22.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -18,9 +19,6 @@ BuildRequires: libglib-devel
|
|||||||
BuildRequires: libgnutls-devel
|
BuildRequires: libgnutls-devel
|
||||||
BuildRequires: libgpg-error-devel
|
BuildRequires: libgpg-error-devel
|
||||||
BuildRequires: libgpgme-devel
|
BuildRequires: libgpgme-devel
|
||||||
BuildRequires: libpcap-devel
|
|
||||||
BuildRequires: libuuid-devel
|
|
||||||
BuildRequires: openssl
|
|
||||||
BuildRequires: openvas-libraries-devel
|
BuildRequires: openvas-libraries-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: libopenssl-devel
|
BuildRequires: libopenssl-devel
|
||||||
@ -33,7 +31,7 @@ Provides: libnasl
|
|||||||
Obsoletes: libnasl
|
Obsoletes: libnasl
|
||||||
Provides: openvas-plugins
|
Provides: openvas-plugins
|
||||||
Obsoletes: openvas-plugins
|
Obsoletes: openvas-plugins
|
||||||
PreReq: openssl
|
Requires(pre): openssl
|
||||||
# FIXME:
|
# FIXME:
|
||||||
# file /usr/include/nessus/includes.h from install of
|
# file /usr/include/nessus/includes.h from install of
|
||||||
# nessus-devel-2.0.10-1qilnx conflicts with file from package
|
# nessus-devel-2.0.10-1qilnx conflicts with file from package
|
||||||
@ -62,99 +60,71 @@ This is the development package for the server related package.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure
|
%cmake -d build
|
||||||
# \
|
|
||||||
# --prefix=%{_prefix} \
|
|
||||||
# --localstatedir=/var \
|
|
||||||
# --sharedstatedir=%{_sysconfdir} \
|
|
||||||
# --sysconfdir=%{_sysconfdir} \
|
|
||||||
# --mandir=%{_mandir}
|
|
||||||
|
|
||||||
%make
|
%make
|
||||||
# %{_smp_mflags}
|
|
||||||
#\
|
|
||||||
# OPENVASD_LOGDIR=/var/log/openvas \
|
|
||||||
# OPENVASD_CACHEDIR=/var/cache/openvas
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
test x"%buildroot" != x/ && rm -rf "%buildroot"
|
test x"%buildroot" != x/ && rm -rf "%buildroot"
|
||||||
%makeinstall
|
%makeinstall -C build
|
||||||
#% makeoldinstall OPENVASD_LOGDIR=%{buildroot}/var/log/openvas OPENVASD_CACHEDIR=%{buildroot}/var/cache/openvas
|
#% makeoldinstall OPENVASD_LOGDIR=%{buildroot}/var/log/openvas OPENVASD_CACHEDIR=%{buildroot}/var/cache/openvas
|
||||||
|
|
||||||
install -D -m0755 %{SOURCE1} %{buildroot}%{_initrddir}/openvasd
|
#install -D -m0755 %{SOURCE1} %{buildroot}%{_initrddir}/openvasd
|
||||||
#install -D -m0644 packaging/debian/openvasd.conf %{buildroot}%{_sysconfdir}/openvas/openvasd.conf
|
#install -D -m0644 packaging/debian/openvasd.conf %{buildroot}%{_sysconfdir}/openvas/openvasd.conf
|
||||||
|
|
||||||
install -d -m0755 \
|
#install -d -m0755 \
|
||||||
%{buildroot}%{_sysconfdir}/openvas/CA \
|
# %{buildroot}%{_sysconfdir}/openvas/CA \
|
||||||
%{buildroot}/var/lib/openvas/plugins \
|
# %{buildroot}/var/lib/openvas/plugins \
|
||||||
%{buildroot}/var/cache/openvas
|
# %{buildroot}/var/cache/openvas
|
||||||
#mkdir -p %{buildroot}/var/cache/openvas/{CA,logs,users,jobs,}
|
|
||||||
#mkdir -p %{buildroot}/var/log/openvas
|
|
||||||
|
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
test x"%buildroot" != x/ && rm -rf "%buildroot"
|
test x"%buildroot" != x/ && rm -rf "%buildroot"
|
||||||
|
|
||||||
|
#%post
|
||||||
|
#if [ ! -e /var/lib/openvas/private/CA/cakey.pem ]; then
|
||||||
|
# %{_sbindir}/openvas-mkcert -q
|
||||||
|
# # chkconfig --add nessusd
|
||||||
|
# # %{_initrddir}/nessusd start
|
||||||
|
#fi
|
||||||
|
#exit 0
|
||||||
|
|
||||||
|
#%preun
|
||||||
|
#if [ $1 -eq 0 ]; then
|
||||||
|
# chkconfig --del openvasd 2>/dev/null
|
||||||
|
# service openvasd stop 2>/dev/null
|
||||||
|
#fi
|
||||||
|
#exit 0
|
||||||
|
|
||||||
|
#%postun
|
||||||
|
#if [ $1 -eq 1 ]; then
|
||||||
|
# test -e /var/lock/subsys/openvasd && \
|
||||||
|
# service openvasd restart
|
||||||
|
#fi
|
||||||
|
#exit 0
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
#%config %{_sysconfdir}/openvas/openvasd.conf
|
%{_sbindir}/openvas-mkcert-client
|
||||||
%{_bindir}/openvas-mkcert-client
|
|
||||||
%{_bindir}/openvas-mkrand
|
|
||||||
%{_sbindir}/greenbone-nvt-sync
|
%{_sbindir}/greenbone-nvt-sync
|
||||||
%{_sbindir}/openvas-adduser
|
|
||||||
#%{_sbindir}/openvas-check-signature
|
|
||||||
%{_sbindir}/openvas-mkcert
|
%{_sbindir}/openvas-mkcert
|
||||||
%{_sbindir}/openvas-nvt-sync
|
%{_sbindir}/openvas-nvt-sync
|
||||||
%{_sbindir}/openvas-rmuser
|
|
||||||
%{_sbindir}/openvassd
|
%{_sbindir}/openvassd
|
||||||
%dir %{_libdir}/openvas
|
%{_mandir}/man8/greenbone-nvt-sync.8*
|
||||||
%dir %{_libdir}/openvas/plugins
|
%{_mandir}/man8/openvas*.8*
|
||||||
%{_libdir}/openvas/plugins/*.nes
|
|
||||||
%{_mandir}/man1/openvas*.1.gz
|
|
||||||
%{_mandir}/man8/openvas*.8.gz
|
|
||||||
%{_initrddir}/openvasd
|
|
||||||
%dir %{_sysconfdir}/openvas
|
|
||||||
%dir %{_sysconfdir}/openvas/CA
|
|
||||||
%dir /var/lib/openvas
|
|
||||||
%dir /var/lib/openvas/plugins
|
|
||||||
%dir /var/lib/openvas/CA
|
|
||||||
%dir /var/lib/openvas/logs
|
|
||||||
%dir /var/lib/openvas/users
|
|
||||||
%dir /var/lib/openvas/jobs
|
|
||||||
%dir /var/lib/openvas/openvas-services
|
|
||||||
%dir /var/cache/openvas
|
|
||||||
%dir /var/log/openvas
|
|
||||||
|
|
||||||
%files devel
|
|
||||||
%defattr(-,root,root)
|
|
||||||
#%{_bindir}/openvasd-config
|
|
||||||
#%{_includedir}/openvas/*
|
|
||||||
|
|
||||||
%post
|
|
||||||
if [ ! -e /var/lib/openvas/private/CA/cakey.pem ]; then
|
|
||||||
%{_sbindir}/openvas-mkcert -q
|
|
||||||
# chkconfig --add nessusd
|
|
||||||
# %{_initrddir}/nessusd start
|
|
||||||
fi
|
|
||||||
exit 0
|
|
||||||
|
|
||||||
%preun
|
|
||||||
if [ $1 -eq 0 ]; then
|
|
||||||
chkconfig --del openvasd 2>/dev/null
|
|
||||||
service openvasd stop 2>/dev/null
|
|
||||||
fi
|
|
||||||
exit 0
|
|
||||||
|
|
||||||
%postun
|
|
||||||
if [ $1 -eq 1 ]; then
|
|
||||||
test -e /var/lock/subsys/openvasd && \
|
|
||||||
service openvasd restart
|
|
||||||
fi
|
|
||||||
exit 0
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Feb 06 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 4.0.7-1mamba
|
||||||
|
- update to 4.0.7
|
||||||
|
|
||||||
|
* Fri Nov 14 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 4.0.4-1mamba
|
||||||
|
- update to 4.0.4
|
||||||
|
|
||||||
|
* Sat Nov 15 2014 Automatic Build System <autodist@mambasoft.it> 4.0.3-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Tue Aug 10 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 3.1.0-1mamba
|
* Tue Aug 10 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 3.1.0-1mamba
|
||||||
- update to 3.1.0
|
- update to 3.1.0
|
||||||
- renamed from openvas-server
|
- renamed from openvas-server
|
||||||
|
Loading…
Reference in New Issue
Block a user