add support for x86_64 target [release 0.9.8x-2mamba;Wed Aug 28 2013]
This commit is contained in:
parent
c8855f3953
commit
ac9e211be4
@ -1,2 +1,7 @@
|
||||
# openssl098
|
||||
|
||||
The openssl certificate management tool and the shared libraries that provide various encryption and decription algorithms and protocols, including DES, RC4, RSA and SSL.
|
||||
This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit (http://www.openssl.org/).
|
||||
This product includes cryptographic software written by Eric Young (eay@cryptsoft.com).
|
||||
This product includes software written by Tim Hudson (tjh@cryptsoft.com).
|
||||
|
||||
|
40
openssl-0.9.8l-symbolVersioning.patch
Normal file
40
openssl-0.9.8l-symbolVersioning.patch
Normal file
@ -0,0 +1,40 @@
|
||||
--- openssl-0.9.8l.orig/Configure 2009-11-05 07:07:06.000000000 -0500
|
||||
+++ openssl-0.9.8l/Configure 2010-03-14 18:18:14.000000000 -0400
|
||||
@@ -1434,6 +1434,8 @@
|
||||
$shlib_minor=$2;
|
||||
}
|
||||
|
||||
+$shared_ldflag .= " -Wl,--version-script=openssl.ld";
|
||||
+
|
||||
open(IN,'<Makefile.org') || die "unable to read Makefile.org:$!\n";
|
||||
unlink("$Makefile.new") || die "unable to remove old $Makefile.new:$!\n" if -e "$Makefile.new";
|
||||
open(OUT,">$Makefile.new") || die "unable to create $Makefile.new:$!\n";
|
||||
--- openssl-0.9.8l.orig/Makefile 2009-11-05 11:15:53.000000000 -0500
|
||||
+++ openssl-0.9.8l/Makefile 2010-03-14 18:19:12.000000000 -0400
|
||||
@@ -168,9 +168,9 @@
|
||||
SHARED_CRYPTO=libcrypto$(SHLIB_EXT)
|
||||
SHARED_SSL=libssl$(SHLIB_EXT)
|
||||
SHARED_FIPS=
|
||||
-SHARED_LIBS=
|
||||
-SHARED_LIBS_LINK_EXTS=
|
||||
-SHARED_LDFLAGS=
|
||||
+SHARED_LIBS=$(SHARED_FIPS) $(SHARED_CRYPTO) $(SHARED_SSL)
|
||||
+SHARED_LIBS_LINK_EXTS=.so.$(SHLIB_MAJOR) .so
|
||||
+SHARED_LDFLAGS=-m64 -Wl,--version-script=openssl.ld
|
||||
|
||||
GENERAL= Makefile
|
||||
BASENAME= openssl
|
||||
--- openssl-0.9.8l.orig/engines/openssl.ld 1969-12-31 19:00:00.000000000 -0500
|
||||
+++ openssl-0.9.8l/engines/openssl.ld 2010-03-14 18:18:55.000000000 -0400
|
||||
@@ -0,0 +1,4 @@
|
||||
+OPENSSL_0.9.8 {
|
||||
+ global:
|
||||
+ *;
|
||||
+};
|
||||
--- openssl-0.9.8l.orig/openssl.ld 1969-12-31 19:00:00.000000000 -0500
|
||||
+++ openssl-0.9.8l/openssl.ld 2010-03-14 18:18:15.000000000 -0400
|
||||
@@ -0,0 +1,4 @@
|
||||
+OPENSSL_0.9.8 {
|
||||
+ global:
|
||||
+ *;
|
||||
+};
|
46
openssl-0.9.8m-legacy_ENGINESDIR.patch
Normal file
46
openssl-0.9.8m-legacy_ENGINESDIR.patch
Normal file
@ -0,0 +1,46 @@
|
||||
diff -Nru openssl-0.9.8m.orig//Configure openssl-0.9.8m/Configure
|
||||
--- openssl-0.9.8m.orig//Configure 2009-11-09 15:14:26.000000000 +0100
|
||||
+++ openssl-0.9.8m/Configure 2010-06-29 17:51:46.744016760 +0200
|
||||
@@ -1693,10 +1693,10 @@
|
||||
}
|
||||
elsif (/^#define\s+ENGINESDIR/)
|
||||
{
|
||||
- # $foo is to become "$prefix/lib$multilib/engines";
|
||||
+ # $foo is to become "$prefix/lib$multilib/engines098";
|
||||
# as Makefile.org and engines/Makefile are adapted for
|
||||
# $multilib suffix.
|
||||
- my $foo = "$prefix/lib/engines";
|
||||
+ my $foo = "$prefix/lib/engines098";
|
||||
$foo =~ s/\\/\\\\/g;
|
||||
print OUT "#define ENGINESDIR \"$foo\"\n";
|
||||
}
|
||||
diff -Nru openssl-0.9.8m.orig//engines/Makefile openssl-0.9.8m/engines/Makefile
|
||||
--- openssl-0.9.8m.orig//engines/Makefile 2009-11-10 02:53:02.000000000 +0100
|
||||
+++ openssl-0.9.8m/engines/Makefile 2010-06-29 17:53:54.473891832 +0200
|
||||
@@ -92,7 +92,7 @@
|
||||
@[ -n "$(INSTALLTOP)" ] # should be set by top Makefile...
|
||||
@if [ -n "$(SHARED_LIBS)" ]; then \
|
||||
set -e; \
|
||||
- $(PERL) $(TOP)/util/mkdir-p.pl $(INSTALL_PREFIX)$(INSTALLTOP)/lib/engines; \
|
||||
+ $(PERL) $(TOP)/util/mkdir-p.pl $(INSTALL_PREFIX)$(INSTALLTOP)/lib/engines098; \
|
||||
for l in $(LIBNAMES); do \
|
||||
( echo installing $$l; \
|
||||
if [ "$(PLATFORM)" != "Cygwin" ]; then \
|
||||
@@ -101,13 +101,13 @@
|
||||
*DSO_DL*) sfx="sl";; \
|
||||
*) sfx="bad";; \
|
||||
esac; \
|
||||
- cp lib$$l.$$sfx $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/engines/lib$$l.$$sfx.new; \
|
||||
+ cp lib$$l.$$sfx $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/engines098/lib$$l.$$sfx.new; \
|
||||
else \
|
||||
sfx="so"; \
|
||||
- cp cyg$$l.dll $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/engines/lib$$l.$$sfx.new; \
|
||||
+ cp cyg$$l.dll $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/engines098/lib$$l.$$sfx.new; \
|
||||
fi; \
|
||||
- chmod 555 $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/engines/lib$$l.$$sfx.new; \
|
||||
- mv -f $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/engines/lib$$l.$$sfx.new $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/engines/lib$$l.$$sfx ); \
|
||||
+ chmod 555 $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/engines098/lib$$l.$$sfx.new; \
|
||||
+ mv -f $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/engines098/lib$$l.$$sfx.new $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/engines098/lib$$l.$$sfx ); \
|
||||
done; \
|
||||
fi
|
||||
|
160
openssl-makecerts
Normal file
160
openssl-makecerts
Normal file
@ -0,0 +1,160 @@
|
||||
#!/bin/bash
|
||||
#
|
||||
# Creates self-signed ssl certificates
|
||||
# Copyright (c) 2003-2008 by Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
# Copyright (c) 2003-2005 by Davide Madrisan <davide.madrisan@qilinux.it>
|
||||
#
|
||||
# Create server side certificates
|
||||
# documentation taken from openssl howtos http://www.openssl.org/docs/HOWTO/
|
||||
|
||||
SSLDIR=/var/ssl
|
||||
[ "$CADAYS" ] || CADAYS=3650
|
||||
[ "$CERTDAYS" ] || CERTDAYS=1825
|
||||
mksslc_tempfile=`tempfile 2>/dev/null`
|
||||
# 1. Creating a certificate request (optional)
|
||||
# To create a certificate, you need to start with a certificate request
|
||||
# or, as some certificate authorities like to put it,
|
||||
# "certificate signing request", since that's exactly what they do,
|
||||
# they sign it and give you the result back, thus making it authentic
|
||||
# according to their policies. A certificate request can then be sent
|
||||
# to a certificate authority to get it signed into a certificate, or if
|
||||
# you have your own certificate authority, you may sign it yourself, or
|
||||
# if you need a self-signed certificate. Because you just want a test
|
||||
# certificate or because you are setting up your own CA.
|
||||
|
||||
#openssl req -new -key privkey.perm -out cert.csr
|
||||
|
||||
# 2. Creating a self-signed root Certification Authority certificate
|
||||
# If you don't want to deal with another certificate authority, or just
|
||||
# want to create a test certificate for yourself. This is similar to
|
||||
# creating a certificate request, but creates a certificate instead of
|
||||
# a certificate request. This is NOT the recommended way to create a
|
||||
# CA certificate, see ca.txt.
|
||||
|
||||
if [ ! -e $SSLDIR/cacert.pem ]; then
|
||||
echo
|
||||
echo "Creating a new Certification Authority"
|
||||
[ "$CAPASS" -a "$CACOUNTRY" -a "$CASTATE" -a "$CACITY" -a \
|
||||
"$CAORGANIZATION" -a "$CAOU" -a "$CACOMMONNAME" -a "$CAEMAIL" ] ||
|
||||
echo "Please enter information about the Certification Authority"
|
||||
while [ ! "$CACOUNTRY" -o ${#CACOUNTRY} -ne 2 ]; do
|
||||
read -p "Two-letters country code (e.g. IT): " CACOUNTRY;
|
||||
done
|
||||
while [ ! "$CASTATE" ]; do read -p "State: " CASTATE; done
|
||||
while [ ! "$CACITY" ]; do read -p "City: " CACITY; done
|
||||
while [ ! "$CAORGANIZATION" ]; do read -p "Organization: " CAORGANIZATION; done
|
||||
while [ ! "$CAOU" ]; do read -p "Operational unit: " CAOU; done
|
||||
while [ ! "$CACOMMONNAME" ]; do read -p "Common name: " CACOMMONNAME; done
|
||||
while [ ! "$CAEMAIL" ]; do read -p "Email: " CAEMAIL; done
|
||||
while [ ! "$CAPASS" -o "$CAPASS" != "$CONFIRMPASS" ]; do
|
||||
unset CAPASS
|
||||
while [ ! "$CAPASS" ]; do read -s -p "Please enter a passphrase: " CAPASS; echo; done
|
||||
read -s -p "Please confirm the passphrase: " CONFIRMPASS
|
||||
echo
|
||||
done
|
||||
|
||||
echo "Generating a self-signed root Certification Authority certificate"
|
||||
cat << _EOF > $mksslc_tempfile
|
||||
$CAPASS
|
||||
$CACOUNTRY
|
||||
$CASTATE
|
||||
$CACITY
|
||||
$CAORGANIZATION
|
||||
$CAOU
|
||||
$CACOMMONNAME
|
||||
$CAEMAIL
|
||||
_EOF
|
||||
|
||||
openssl req -passout stdin -new -x509 -keyout $SSLDIR/private/cakey.pem \
|
||||
-out $SSLDIR/cacert.pem -days 3650 < $mksslc_tempfile 2>&1 || exit 1
|
||||
|
||||
fi
|
||||
|
||||
rm -f $mksslc_tempfile # remove sensible data
|
||||
|
||||
[ "$CERTPASS" -a "$CERTCOUNTRY" -a "$CERTSTATE" -a "$CERTCITY" -a \
|
||||
"$CERTORGANIZATION" -a "$CERTOU" -a "$CERTCOMMONNAME" -a "$CERTEMAIL" ] || {
|
||||
echo
|
||||
echo "Please enter information about the self-signed server certificate"
|
||||
}
|
||||
|
||||
while [ ! "$CERTCOUNTRY" -o ${#CERTCOUNTRY} -ne 2 ]; do
|
||||
read -p "Two-letters country code (e.g. IT) [$CACOUNTRY]: " CERTCOUNTRY
|
||||
[ "$CERTCOUNTRY" ] || CERTCOUNTRY=$CACOUNTRY
|
||||
done
|
||||
while [ ! "$CERTSTATE" ]; do
|
||||
read -p "State [$CASTATE]: " CERTSTATE
|
||||
[ "$CERTSTATE" ] || CERTSTATE=$CASTATE
|
||||
done
|
||||
while [ ! "$CERTCITY" ]; do
|
||||
read -p "City [$CACITY]: " CERTCITY
|
||||
[ "$CERTCITY" ] || CERTCITY=$CACITY
|
||||
done
|
||||
while [ ! "$CERTORGANIZATION" ]; do
|
||||
read -p "Organization [$CAORGANIZATION]: " CERTORGANIZATION
|
||||
[ "$CERTORGANIZATION" ] || CERTORGANIZATION="$CAORGANIZATION"
|
||||
done
|
||||
while [ ! "$CERTOU" ]; do
|
||||
read -p "Operational unit [$CAOU]: " CERTOU
|
||||
[ "$CERTOU" ] || CERTOU=$CAOU
|
||||
done
|
||||
while [ ! "$CERTCOMMONNAME" ]; do
|
||||
read -p "Common name [$CACOMMONNAME]: " CERTCOMMONNAME
|
||||
[ "$CERTCOMMONNAME" ] || CERTCOMMONNAME=$CACOMMONNAME
|
||||
done
|
||||
while [ ! "$CERTEMAIL" ]; do
|
||||
read -p "Email [$CAEMAIL]: " CERTEMAIL
|
||||
[ "$CERTEMAIL" ] || CERTEMAIL=$CAEMAIL
|
||||
done
|
||||
while [ ! "$CERTPASS" -o "$CERTPASS" != "$CONFIRMPASS" ]; do
|
||||
unset CERTPASS
|
||||
while [ ! "$CERTPASS" ]; do read -s -p "Please enter a passphrase: " CERTPASS; echo; done
|
||||
read -s -p "Please confirm the passphrase: " CONFIRMPASS
|
||||
echo
|
||||
done
|
||||
while [ ! "$CAPASS" ]; do
|
||||
read -s -p "Please, enter the CA passphrase for signing the certificate: " CAPASS
|
||||
done
|
||||
|
||||
[ -e $SSLDIR/certs/localhost.crt ] && {
|
||||
read -p "A certificate called $SSLDIR/certs/localhost.crt already exists; overwrite [y/N]?" OVERWRITE
|
||||
echo
|
||||
[ "$OVERWRITE" != "y" -a "$OVERWRITE" != "Y" ] && exit 0
|
||||
}
|
||||
|
||||
# 3. Generate a key without password
|
||||
openssl genrsa -out $SSLDIR/private/localhost.key >/dev/null || exit 1
|
||||
|
||||
# 4. Create a server certificate signing request (CSR)
|
||||
echo "Creating a server certificate request (CSR)"
|
||||
cat << _EOF > $mksslc_tempfile
|
||||
$CERTPASS
|
||||
$CERTCOUNTRY
|
||||
$CERTSTATE
|
||||
$CERTCITY
|
||||
$CERTORGANIZATION
|
||||
$CERTOU
|
||||
$CERTCOMMONNAME
|
||||
$CERTEMAIL
|
||||
_EOF
|
||||
echo "" >> $mksslc_tempfile # A challenge password
|
||||
echo "" >> $mksslc_tempfile # An optional company name
|
||||
|
||||
openssl req -passout stdin -new -key $SSLDIR/private/localhost.key \
|
||||
-out $SSLDIR/localhost.csr -days $CERTDAYS < $mksslc_tempfile >/dev/null || exit 1
|
||||
|
||||
rm -f $mksslc_tempfile
|
||||
|
||||
# 4. Sign a server certificate request
|
||||
echo "Signing the certificate request"
|
||||
|
||||
echo "$CAPASS" > $mksslc_tempfile
|
||||
echo "y" >> $mksslc_tempfile # Sign the certificate? [y/n]
|
||||
echo "y" >> $mksslc_tempfile # 1 out of 1 certificate requests certified, commit?
|
||||
|
||||
openssl ca -days $CERTDAYS -passin stdin -policy policy_anything -out $SSLDIR/certs/localhost.crt \
|
||||
-infiles $SSLDIR/localhost.csr < $mksslc_tempfile >/dev/null || exit 1
|
||||
|
||||
rm -f $mksslc_tempfile
|
||||
|
||||
exit 0
|
254
openssl098.spec
Normal file
254
openssl098.spec
Normal file
@ -0,0 +1,254 @@
|
||||
Name: openssl098
|
||||
Version: 0.9.8x
|
||||
Release: 2mamba
|
||||
Summary: Secure Sockets Layer communications libs and utils
|
||||
Group: Network/Security
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.openssl.org
|
||||
Source: http://www.openssl.org/source/openssl-%{version}.tar.gz
|
||||
Source1: openssl-makecerts
|
||||
Patch0: openssl-0.9.8m-legacy_ENGINESDIR.patch
|
||||
Patch1: openssl-0.9.8l-symbolVersioning.patch
|
||||
License: BSD
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
## AUTOBUILDREQ-END
|
||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
The openssl certificate management tool and the shared libraries that provide various encryption and decription algorithms and protocols, including DES, RC4, RSA and SSL.
|
||||
This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit (http://www.openssl.org/).
|
||||
This product includes cryptographic software written by Eric Young (eay@cryptsoft.com).
|
||||
This product includes software written by Tim Hudson (tjh@cryptsoft.com).
|
||||
|
||||
%package -n lib%{name}
|
||||
Summary: Library for OpenSSL
|
||||
Group: System/Libraries
|
||||
|
||||
%description -n lib%{name}
|
||||
The libraries files are needed for various cryptographic algorithms and protocols, including DES, RC4, RSA and SSL.
|
||||
This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit (http://www.openssl.org/).
|
||||
This product includes cryptographic software written by Eric Young (eay@cryptsoft.com).
|
||||
This product includes software written by Tim Hudson (tjh@cryptsoft.com).
|
||||
|
||||
%package -n lib%{name}-devel
|
||||
Summary: Library Devel for OpenSSL
|
||||
Group: Development/Libraries
|
||||
Requires: lib%{name} = %{version}-%{release}
|
||||
Obsoletes: libopenssl097-devel
|
||||
|
||||
%description -n lib%{name}-devel
|
||||
Static libraries and include files needed to compile apps with support for various cryptographic algorithms and protocols, including DES, RC4, RSA and SSL.
|
||||
This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit (http://www.openssl.org/).
|
||||
This product includes cryptographic software written by Eric Young (eay@cryptsoft.com).
|
||||
This product includes software written by Tim Hudson (tjh@cryptsoft.com).
|
||||
|
||||
%prep
|
||||
%setup -q -n openssl-%{version}
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
# FIXME: --openssldir=%{_libdir}/ssl
|
||||
# (FHS: no executable files should be installed in /etc)
|
||||
./Configure \
|
||||
%ifarch ppc
|
||||
linux-ppc \
|
||||
%endif
|
||||
%ifarch i586
|
||||
linux-elf \
|
||||
%endif
|
||||
%ifarch x86_64
|
||||
linux-x86_64 \
|
||||
%endif
|
||||
%ifarch arm
|
||||
linux-generic32 \
|
||||
%endif
|
||||
shared \
|
||||
--prefix=%{_prefix} \
|
||||
--openssldir=%{_sysconfdir}/ssl
|
||||
|
||||
%ifarch ppc
|
||||
sed -i "s/-m486/-march=%{_target_cpu}/g" Makefile
|
||||
%endif
|
||||
|
||||
sed -i 's|\(.*\)chmod 644\(.*/lib/pkgconfig\)|\1chmod 755\2|' Makefile
|
||||
|
||||
%make -j1 CC=%{_host}-gcc MANDIR=%{_mandir}
|
||||
%make -j1 CC=%{_host}-gcc rehash
|
||||
|
||||
#export LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
|
||||
%if "%{_host}" == "%{_build}"
|
||||
make test
|
||||
%endif
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
make install \
|
||||
CC=%{_host}-gcc \
|
||||
INSTALL_PREFIX=%{buildroot} \
|
||||
MANDIR=%{_mandir}
|
||||
|
||||
%ifarch x86_64
|
||||
mv %{buildroot}{%{_prefix}/lib,%{_libdir}}
|
||||
%endif
|
||||
|
||||
chmod 755 %{buildroot}%{_libdir}/pkgconfig
|
||||
chmod 644 %{buildroot}%{_libdir}/pkgconfig/*.pc
|
||||
|
||||
mv %{buildroot}%{_mandir}/man1/passwd.* \
|
||||
%{buildroot}%{_mandir}/man1/openssl-passwd.*
|
||||
mv %{buildroot}%{_mandir}/man3/err.* \
|
||||
%{buildroot}%{_mandir}/man3/openssl-err.*
|
||||
mv %{buildroot}%{_mandir}/man3/rand.* \
|
||||
%{buildroot}%{_mandir}/man3/openssl-rand.*
|
||||
# rpmbuild can't correctly handle spaces in symlink names
|
||||
rm -f %{buildroot}%{_mandir}/man7/Modes\ of\ DES.7
|
||||
|
||||
mkdir -p %{buildroot}/var/ssl/{certs,newcerts,private,crl}
|
||||
touch %{buildroot}/var/ssl/index.txt
|
||||
echo "01" > %{buildroot}/var/ssl/serial
|
||||
|
||||
sed -i "s|./demoCA|/var/ssl|" %{buildroot}%{_sysconfdir}/ssl/openssl.cnf
|
||||
|
||||
rm -f %{buildroot}%{_libdir}/fips_premain.c
|
||||
rm -f %{buildroot}%{_libdir}/fips_premain.c.sha1
|
||||
|
||||
install -m 0755 -D %{SOURCE1} %{buildroot}%{_sbindir}/openssl-makecerts
|
||||
|
||||
rm -rf %{buildroot}%{_sysconfdir}/ssl/openssl.cnf
|
||||
rm -rf %{buildroot}%{_mandir}
|
||||
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_sysconfdir}/ssl/misc
|
||||
%{_bindir}/c_rehash
|
||||
#%{_bindir}/fipsld
|
||||
%{_bindir}/openssl
|
||||
%{_sbindir}/openssl-makecerts
|
||||
#%{_bindir}/openssl_fips_fingerprint
|
||||
%doc CHANGES* FAQ LICENSE NEWS PROBLEMS README*
|
||||
|
||||
%files -n lib%{name}
|
||||
%defattr(-,root,root)
|
||||
%dir %{_sysconfdir}/ssl/private
|
||||
%{_libdir}/libcrypto.so.*
|
||||
%{_libdir}/libssl.so.*
|
||||
%{_libdir}/engines098/lib*.so
|
||||
%dir /var/ssl
|
||||
%dir /var/ssl/certs
|
||||
%dir /var/ssl/crl
|
||||
%dir /var/ssl/newcerts
|
||||
%dir %attr(0700,root,root) /var/ssl/private
|
||||
%config(noreplace) /var/ssl/index.txt
|
||||
%config(noreplace) /var/ssl/serial
|
||||
|
||||
%files -n lib%{name}-devel
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/*.a
|
||||
%{_libdir}/*.so
|
||||
%{_libdir}/pkgconfig/libcrypto.pc
|
||||
%{_libdir}/pkgconfig/libssl.pc
|
||||
%{_libdir}/pkgconfig/openssl.pc
|
||||
%{_includedir}/openssl/*
|
||||
|
||||
%changelog
|
||||
* Wed Aug 28 2013 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 0.9.8x-2mamba
|
||||
- add support for x86_64 target
|
||||
|
||||
* Mon Jul 02 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.8x-1mamba
|
||||
- update to 0.9.8x
|
||||
- addded symbol versioning patch (needed for binary compatibility of Guitar Pro 6 build for Debian)
|
||||
|
||||
* Thu Jul 01 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.8m-4mamba
|
||||
- removed man pages to avoid conflicts
|
||||
|
||||
* Wed Apr 07 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.8m-3mamba
|
||||
- rebuilt as openssl098 legacy package
|
||||
|
||||
* Tue Mar 23 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.8m-2mamba
|
||||
- move /etc/ssl/misc to openssl package
|
||||
- removed build requirement for perl
|
||||
- add support for arm target
|
||||
|
||||
* Fri Feb 26 2010 Automatic Build System <autodist@mambasoft.it> 0.9.8m-1mamba
|
||||
- automatic update to 0.9.8m by autodist
|
||||
|
||||
* Wed Nov 18 2009 Automatic Build System <autodist@mambasoft.it> 0.9.8l-1mamba
|
||||
- automatic update to 0.9.8l by autodist
|
||||
|
||||
* Fri Mar 27 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.8k-1mamba
|
||||
- automatic update to 0.9.8k by autodist
|
||||
|
||||
* Wed Jan 07 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.8j-1mamba
|
||||
- automatic update to 0.9.8j by autodist
|
||||
|
||||
* Sat Oct 04 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.8i-2mamba
|
||||
- libopenssl-devel: obsolete libopenssl097-devel
|
||||
- set 700 permission to /var/ssl/private directory
|
||||
|
||||
* Tue Sep 16 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.8i-1mamba
|
||||
- automatic update to 0.9.8i by autodist
|
||||
|
||||
* Tue Jun 17 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.8h-1mamba
|
||||
- update to 0.9.8h
|
||||
|
||||
* Fri Mar 14 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.8g-3mamba
|
||||
- added openssl-makecerts script for creating a CA and a self-signed certificate
|
||||
|
||||
* Mon Dec 31 2007 Aleph0 <aleph0@openmamba.org> 0.9.8g-2mamba
|
||||
- fix permissions of .pc files
|
||||
|
||||
* Sun Nov 18 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.8g-1mamba
|
||||
- update to 0.9.8g
|
||||
|
||||
* Wed Sep 06 2006 Davide Madrisan <davide.madrisan@qilinux.it> 0.9.7k-1qilnx
|
||||
- update to version 0.9.7k by autospec
|
||||
- also fixes CAN-2006-4339 (bugzilla#230)
|
||||
|
||||
* Fri Oct 14 2005 Davide Madrisan <davide.madrisan@qilinux.it> 0.9.7h-1qilnx
|
||||
- update to version 0.9.7h by autospec
|
||||
- also fixes the security issue QSA-2005-119 (CAN-2005-2969)
|
||||
- patches removed (merget upstream)
|
||||
|
||||
* Wed Jul 27 2005 Davide Madrisan <davide.madrisan@qilinux.it> 0.9.7e-2qilnx
|
||||
- fix security issue QSA-2005-083 (CAN-2005-0109)
|
||||
- do not create a broken link to the libfips library (p0)
|
||||
see http://www.mail-archive.com/openssl-dev%40openssl.org/msg18268.html
|
||||
|
||||
* Tue Dec 14 2004 Davide Madrisan <davide.madrisan@qilinux.it> 0.9.7e-1qilnx
|
||||
- update to version 0.9.7e by autospec
|
||||
- fix security issue QSA-2004-062 (CAN-2004-0975)
|
||||
- added documentation
|
||||
|
||||
* Thu Mar 18 2004 Davide Madrisan <davide.madrisan@qilinux.it> 0.9.7d-1qilnx
|
||||
- security fix release (CAN-2004-0079, CAN-2004-0112)
|
||||
|
||||
* Mon Jan 19 2004 Davide Madrisan <davide.madrisan@qilinux.it> 0.9.7c-2qilnx
|
||||
- specfile fixes
|
||||
|
||||
* Wed Oct 01 2003 Davide Madrisan <davide.madrisan@qilinux.it> 0.9.7c-1qilnx
|
||||
- rebuilt with new version (important security bugfixes)
|
||||
|
||||
* Fri Jul 25 2003 Silvan Calarco <silvan.calarco@qinet.it> 0.9.7b-4qilnx
|
||||
- configured so that certificates are by default under /var/ssl
|
||||
|
||||
* Wed Jun 18 2003 Silvan Calarco <silvan.calarco@qinet.it> 0.9.7b-3qilnx
|
||||
- rebuilt against gcc 3.2.3
|
||||
- files correctly redistributed beetwen main and devel package
|
||||
|
||||
* Wed Apr 30 2003 Silvan Calarco <silvan.calarco@qinet.it>
|
||||
- err, rand and passwd manpages renamed to openssl-* to avoid conflicts with other versions
|
||||
|
||||
* Tue Apr 16 2003 Luca Tinelli <luca.tinelli@qinet.it>
|
||||
- first build
|
Loading…
Reference in New Issue
Block a user