/etc and /var files moved from libopenssl to openssl [release 1.0.2g-3mamba;Sat Apr 30 2016]

This commit is contained in:
Silvan Calarco 2024-01-06 08:16:19 +01:00
parent 0163c47b67
commit a4a06f6ae1
3 changed files with 301 additions and 66 deletions

View File

@ -1,53 +0,0 @@
diff -up openssl-1.0.1/Makefile.shared.version openssl-1.0.1/Makefile.shared
--- openssl-1.0.1/Makefile.shared.version 2012-03-14 20:58:20.553350959 +0100
+++ openssl-1.0.1/Makefile.shared 2012-03-14 20:58:20.631352556 +0100
@@ -151,7 +151,7 @@ DO_GNU_SO=$(CALC_VERSIONS); \
SHLIB_SUFFIX=; \
ALLSYMSFLAGS='-Wl,--whole-archive'; \
NOALLSYMSFLAGS='-Wl,--no-whole-archive'; \
- SHAREDFLAGS="$(CFLAGS) $(SHARED_LDFLAGS) -shared -Wl,-Bsymbolic -Wl,-soname=$$SHLIB$$SHLIB_SOVER$$SHLIB_SUFFIX"
+ SHAREDFLAGS="$(CFLAGS) $(SHARED_LDFLAGS) -shared -Wl,-Bsymbolic -Wl,--default-symver,--version-script=version.map -Wl,-soname=$$SHLIB$$SHLIB_SOVER$$SHLIB_SUFFIX"
DO_GNU_APP=LDFLAGS="$(CFLAGS)"
diff -up openssl-1.0.1/version.map.version openssl-1.0.1/version.map
--- openssl-1.0.1/version.map.version 2012-03-14 20:58:20.631352556 +0100
+++ openssl-1.0.1/version.map 2012-03-14 20:58:20.631352556 +0100
@@ -0,0 +1,7 @@
+OPENSSL_1.0.1 {
+ global:
+ SSLeay;
+ local:
+ _original*;
+ _current*;
+};
--- openssl-1.0.1p/crypto/cversion.c.orig 2015-08-16 15:44:39.732602452 +0200
+++ openssl-1.0.1p/crypto/cversion.c 2015-08-16 15:45:16.262509801 +0200
@@ -97,7 +97,14 @@
return ("not available");
}
-unsigned long SSLeay(void)
+unsigned long _original_SSLeay(void)
{
- return (SSLEAY_VERSION_NUMBER);
+ return(0x10000003);
}
+
+unsigned long _current_SSLeay(void)
+{
+ return(SSLEAY_VERSION_NUMBER);
+}
+__asm__(".symver _original_SSLeay,SSLeay@");
+__asm__(".symver _current_SSLeay,SSLeay@@OPENSSL_1.0.1");
--- openssl-1.0.1p/crypto/opensslv.h.orig 2015-08-16 15:44:39.733602449 +0200
+++ openssl-1.0.1p/crypto/opensslv.h 2015-08-16 15:47:04.895305120 +0200
@@ -88,7 +88,7 @@
* should only keep the versions that are binary compatible with the current.
*/
# define SHLIB_VERSION_HISTORY ""
-# define SHLIB_VERSION_NUMBER "1.0.0"
+# define SHLIB_VERSION_NUMBER "1.0.1"
#ifdef __cplusplus

View File

@ -0,0 +1,245 @@
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns='http://www.w3.org/1999/xhtml' xml:lang='en' lang='en'>
<head>
<title>rpms/openssl.git - openssl</title>
<meta name='generator' content='cgit v0.12'/>
<meta name='robots' content='index, nofollow'/>
<link rel='stylesheet' type='text/css' href='/cgit-data/cgit.css'/>
<link rel='shortcut icon' href='/favicon.ico'/>
<link rel='alternate' title='Atom feed' href='http://pkgs.fedoraproject.org/cgit/rpms/openssl.git/atom/openssl-1.0.2a-version.patch?h=master' type='application/atom+xml'/>
<link rel='vcs-git' href='git://pkgs.fedoraproject.org/rpms/openssl.git' title='rpms/openssl.git Git repository'/>
<link rel='vcs-git' href='ssh://pkgs.fedoraproject.org/rpms/openssl.git' title='rpms/openssl.git Git repository'/>
<link rel='vcs-git' href='http://pkgs.fedoraproject.org/git/rpms/openssl.git' title='rpms/openssl.git Git repository'/>
</head>
<body>
<script src="https://apps.fedoraproject.org/fedmenu/js/jquery-1.11.2.min.js"></script>
<script src="https://apps.fedoraproject.org/fedmenu/js/fedmenu.js"></script>
<script>
var base = 'https://apps.fedoraproject.org/';
var tokens = window.location.href.split('/');
var repo = null;
if (tokens.length > 4 && tokens[4] != '') {
repo = tokens[4].split('.')[0];
}
fedmenu({
'url': base + 'js/data.js',
'mimeType': 'application/javascript',
'position': 'bottom-right',
'package': repo,
});
</script>
<div id='cgit'><table id='header'>
<tr>
<td class='logo' rowspan='2'><a href='/cgit/'><img src='/cgit-data/cgit.png' alt='cgit logo'/></a></td>
<td class='main'><a href='/cgit/'>index</a> : <a title='rpms/openssl.git' href='/cgit/rpms/openssl.git/'>rpms/openssl.git</a></td><td class='form'><form method='get' action=''>
<select name='h' onchange='this.form.submit();'>
<option value='f10'>f10</option>
<option value='f11'>f11</option>
<option value='f12'>f12</option>
<option value='f13'>f13</option>
<option value='f14'>f14</option>
<option value='f15'>f15</option>
<option value='f16'>f16</option>
<option value='f17'>f17</option>
<option value='f18'>f18</option>
<option value='f19'>f19</option>
<option value='f20'>f20</option>
<option value='f21'>f21</option>
<option value='f22'>f22</option>
<option value='f23'>f23</option>
<option value='f24'>f24</option>
<option value='f7'>f7</option>
<option value='f8'>f8</option>
<option value='f9'>f9</option>
<option value='master' selected='selected'>master</option>
</select> <input type='submit' name='' value='switch'/></form></td></tr>
<tr><td class='sub'>openssl</td><td class='sub right'>Jesse Keating</td></tr></table>
<table class='tabs'><tr><td>
<a href='/cgit/rpms/openssl.git/'>summary</a><a href='/cgit/rpms/openssl.git/refs/'>refs</a><a href='/cgit/rpms/openssl.git/log/openssl-1.0.2a-version.patch'>log</a><a class='active' href='/cgit/rpms/openssl.git/tree/openssl-1.0.2a-version.patch'>tree</a><a href='/cgit/rpms/openssl.git/commit/openssl-1.0.2a-version.patch'>commit</a><a href='/cgit/rpms/openssl.git/diff/openssl-1.0.2a-version.patch'>diff</a><a href='/cgit/rpms/openssl.git/stats/openssl-1.0.2a-version.patch'>stats</a></td><td class='form'><form class='right' method='get' action='/cgit/rpms/openssl.git/log/openssl-1.0.2a-version.patch'>
<select name='qt'>
<option value='grep'>log msg</option>
<option value='author'>author</option>
<option value='committer'>committer</option>
<option value='range'>range</option>
</select>
<input class='txt' type='text' size='10' name='q' value=''/>
<input type='submit' value='search'/>
</form>
</td></tr></table>
<div class='path'>path: <a href='/cgit/rpms/openssl.git/tree/'>root</a>/<a href='/cgit/rpms/openssl.git/tree/openssl-1.0.2a-version.patch'>openssl-1.0.2a-version.patch</a></div><div class='content'>blob: 25dfff51b067efd41d92d3b67c9c8fad820efff5 (<a href='/cgit/rpms/openssl.git/plain/openssl-1.0.2a-version.patch'>plain</a>)
<table summary='blob content' class='blob'>
<tr><td class='linenumbers'><pre><a id='n1' href='#n1'>1</a>
<a id='n2' href='#n2'>2</a>
<a id='n3' href='#n3'>3</a>
<a id='n4' href='#n4'>4</a>
<a id='n5' href='#n5'>5</a>
<a id='n6' href='#n6'>6</a>
<a id='n7' href='#n7'>7</a>
<a id='n8' href='#n8'>8</a>
<a id='n9' href='#n9'>9</a>
<a id='n10' href='#n10'>10</a>
<a id='n11' href='#n11'>11</a>
<a id='n12' href='#n12'>12</a>
<a id='n13' href='#n13'>13</a>
<a id='n14' href='#n14'>14</a>
<a id='n15' href='#n15'>15</a>
<a id='n16' href='#n16'>16</a>
<a id='n17' href='#n17'>17</a>
<a id='n18' href='#n18'>18</a>
<a id='n19' href='#n19'>19</a>
<a id='n20' href='#n20'>20</a>
<a id='n21' href='#n21'>21</a>
<a id='n22' href='#n22'>22</a>
<a id='n23' href='#n23'>23</a>
<a id='n24' href='#n24'>24</a>
<a id='n25' href='#n25'>25</a>
<a id='n26' href='#n26'>26</a>
<a id='n27' href='#n27'>27</a>
<a id='n28' href='#n28'>28</a>
<a id='n29' href='#n29'>29</a>
<a id='n30' href='#n30'>30</a>
<a id='n31' href='#n31'>31</a>
<a id='n32' href='#n32'>32</a>
<a id='n33' href='#n33'>33</a>
<a id='n34' href='#n34'>34</a>
<a id='n35' href='#n35'>35</a>
<a id='n36' href='#n36'>36</a>
<a id='n37' href='#n37'>37</a>
<a id='n38' href='#n38'>38</a>
<a id='n39' href='#n39'>39</a>
<a id='n40' href='#n40'>40</a>
<a id='n41' href='#n41'>41</a>
<a id='n42' href='#n42'>42</a>
<a id='n43' href='#n43'>43</a>
<a id='n44' href='#n44'>44</a>
<a id='n45' href='#n45'>45</a>
<a id='n46' href='#n46'>46</a>
<a id='n47' href='#n47'>47</a>
<a id='n48' href='#n48'>48</a>
<a id='n49' href='#n49'>49</a>
<a id='n50' href='#n50'>50</a>
<a id='n51' href='#n51'>51</a>
<a id='n52' href='#n52'>52</a>
<a id='n53' href='#n53'>53</a>
<a id='n54' href='#n54'>54</a>
<a id='n55' href='#n55'>55</a>
<a id='n56' href='#n56'>56</a>
<a id='n57' href='#n57'>57</a>
<a id='n58' href='#n58'>58</a>
<a id='n59' href='#n59'>59</a>
<a id='n60' href='#n60'>60</a>
<a id='n61' href='#n61'>61</a>
<a id='n62' href='#n62'>62</a>
<a id='n63' href='#n63'>63</a>
<a id='n64' href='#n64'>64</a>
<a id='n65' href='#n65'>65</a>
<a id='n66' href='#n66'>66</a>
<a id='n67' href='#n67'>67</a>
<a id='n68' href='#n68'>68</a>
<a id='n69' href='#n69'>69</a>
<a id='n70' href='#n70'>70</a>
<a id='n71' href='#n71'>71</a>
<a id='n72' href='#n72'>72</a>
<a id='n73' href='#n73'>73</a>
<a id='n74' href='#n74'>74</a>
<a id='n75' href='#n75'>75</a>
<a id='n76' href='#n76'>76</a>
<a id='n77' href='#n77'>77</a>
<a id='n78' href='#n78'>78</a>
<a id='n79' href='#n79'>79</a>
<a id='n80' href='#n80'>80</a>
<a id='n81' href='#n81'>81</a>
<a id='n82' href='#n82'>82</a>
<a id='n83' href='#n83'>83</a>
</pre></td>
<td class='lines'><pre><code>diff -up openssl-1.0.2a/crypto/cversion.c.version openssl-1.0.2a/crypto/cversion.c
--- openssl-1.0.2a/crypto/cversion.c.version 2015-03-19 14:30:36.000000000 +0100
+++ openssl-1.0.2a/crypto/cversion.c 2015-04-21 16:48:56.285535316 +0200
@@ -62,7 +62,7 @@
# include "buildinf.h"
#endif
-const char *SSLeay_version(int t)
+const char *_current_SSLeay_version(int t)
{
if (t == SSLEAY_VERSION)
return OPENSSL_VERSION_TEXT;
@@ -101,7 +101,40 @@ const char *SSLeay_version(int t)
return ("not available");
}
-unsigned long SSLeay(void)
+const char *_original_SSLeay_version(int t)
+{
+ if (t == SSLEAY_VERSION)
+ return "OpenSSL 1.0.0-fips 29 Mar 2010";
+ else
+ return _current_SSLeay_version(t);
+}
+
+const char *_original101_SSLeay_version(int t)
+{
+ if (t == SSLEAY_VERSION)
+ return "OpenSSL 1.0.1e-fips 11 Feb 2013";
+ else
+ return _current_SSLeay_version(t);
+}
+
+unsigned long _original_SSLeay(void)
+{
+ return (0x10000003L);
+}
+
+unsigned long _original101_SSLeay(void)
+{
+ return (0x1000105fL);
+}
+
+unsigned long _current_SSLeay(void)
{
return (SSLEAY_VERSION_NUMBER);
}
+
+__asm__(".symver _original_SSLeay,SSLeay@");
+__asm__(".symver _original_SSLeay_version,SSLeay_version@");
+__asm__(".symver _original101_SSLeay,SSLeay@OPENSSL_1.0.1");
+__asm__(".symver _original101_SSLeay_version,SSLeay_version@OPENSSL_1.0.1");
+__asm__(".symver _current_SSLeay,SSLeay@@OPENSSL_1.0.2");
+__asm__(".symver _current_SSLeay_version,SSLeay_version@@OPENSSL_1.0.2");
diff -up openssl-1.0.2a/Makefile.shared.version openssl-1.0.2a/Makefile.shared
--- openssl-1.0.2a/Makefile.shared.version 2015-04-21 16:43:02.624170648 +0200
+++ openssl-1.0.2a/Makefile.shared 2015-04-21 16:43:02.676171879 +0200
@@ -151,7 +151,7 @@ DO_GNU_SO=$(CALC_VERSIONS); \
SHLIB_SUFFIX=; \
ALLSYMSFLAGS='-Wl,--whole-archive'; \
NOALLSYMSFLAGS='-Wl,--no-whole-archive'; \
- SHAREDFLAGS="$(CFLAGS) $(SHARED_LDFLAGS) -shared -Wl,-Bsymbolic -Wl,-soname=$$SHLIB$$SHLIB_SOVER$$SHLIB_SUFFIX"
+ SHAREDFLAGS="$(CFLAGS) $(SHARED_LDFLAGS) -shared -Wl,-Bsymbolic -Wl,--default-symver,--version-script=version.map -Wl,-soname=$$SHLIB$$SHLIB_SOVER$$SHLIB_SUFFIX"
DO_GNU_APP=LDFLAGS="$(CFLAGS)"
diff -up openssl-1.0.2a/version.map.version openssl-1.0.2a/version.map
--- openssl-1.0.2a/version.map.version 2015-04-21 16:43:02.676171879 +0200
+++ openssl-1.0.2a/version.map 2015-04-21 16:51:49.621630589 +0200
@@ -0,0 +1,13 @@
+OPENSSL_1.0.1 {
+ global:
+ SSLeay;
+ SSLeay_version;
+ local:
+ _original*;
+ _current*;
+};
+OPENSSL_1.0.2 {
+ global:
+ SSLeay;
+ SSLeay_version;
+} OPENSSL_1.0.1;
</code></pre></td></tr></table>
</div> <!-- class=content -->
<div class='footer'>generated by <a href='http://git.zx2c4.com/cgit/about/'>cgit v0.12</a> at 2016-04-30 09:59:51 (GMT)</div>
</div> <!-- id=cgit -->
</body>
</html>

View File

@ -1,6 +1,6 @@
Name: openssl
Version: 1.0.1p
Release: 1mamba
Version: 1.0.2g
Release: 3mamba
Summary: Secure Sockets Layer communications libs and utils
Group: Network/Security
Vendor: openmamba
@ -10,10 +10,13 @@ URL: http://www.openssl.org
Source: http://www.openssl.org/source/openssl-%{version}.tar.gz
Source1: openssl-makecerts
Patch0: %{name}-1.0.1a-fix_non_ia32.patch
Patch1: %{name}-1.0.1p-symbol_versioning.patch
Patch1: openssl-1.0.2a-version.patch
License: BSD
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libperl
BuildRequires: perl-WWW-Curl
BuildRequires: perl-devel
## AUTOBUILDREQ-END
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
BuildRoot: %{_tmppath}/%{name}-%{version}-root
@ -60,7 +63,10 @@ Static libraries needed to compile apps with support for various cryptographic a
%prep
%setup -q -n openssl-%{version}
#%patch0 -p1
# Using Fedora versioning patch
%patch1 -p1
sed -i 's/SHLIB_VERSION_NUMBER "1.0.0"/SHLIB_VERSION_NUMBER "%{version}"/' crypto/opensslv.h
%build
# FIXME: --openssldir=%{_libdir}/ssl
@ -122,6 +128,7 @@ sed -i "s|./demoCA|/var/ssl|" %{buildroot}/etc/ssl/openssl.cnf
rm -f %{buildroot}%{_libdir}/fips_premain.c
rm -f %{buildroot}%{_libdir}/fips_premain.c.sha1
rm -f %{buildroot}%{_mandir}/man3/.3*
install -m 0755 -D %{SOURCE1} %{buildroot}%{_sbindir}/openssl-makecerts
@ -133,6 +140,8 @@ install -m 0755 -D %{SOURCE1} %{buildroot}%{_sbindir}/openssl-makecerts
%files
%defattr(-,root,root)
%config(noreplace) %{_sysconfdir}/ssl/openssl.cnf
%dir %{_sysconfdir}/ssl/private
%{_sysconfdir}/ssl/misc
%{_bindir}/c_rehash
#%{_bindir}/fipsld
@ -142,14 +151,6 @@ install -m 0755 -D %{SOURCE1} %{buildroot}%{_sbindir}/openssl-makecerts
%{_mandir}/man1/*
%{_mandir}/man5/*
%{_mandir}/man7/*
%files -n lib%{name}
%defattr(-,root,root)
%config(noreplace) %{_sysconfdir}/ssl/openssl.cnf
%dir %{_sysconfdir}/ssl/private
%{_libdir}/libcrypto.so.*
%{_libdir}/libssl.so.*
%{_libdir}/engines/lib*.so
%dir /var/ssl
%dir /var/ssl/certs
%dir /var/ssl/crl
@ -157,6 +158,12 @@ install -m 0755 -D %{SOURCE1} %{buildroot}%{_sbindir}/openssl-makecerts
%dir %attr(0700,root,root) /var/ssl/private
%config(noreplace) /var/ssl/index.txt
%config(noreplace) /var/ssl/serial
%files -n lib%{name}
%defattr(-,root,root)
%{_libdir}/libcrypto.so.*
%{_libdir}/libssl.so.*
%{_libdir}/engines/lib*.so
%doc LICENSE
%files -n lib%{name}-devel
@ -175,8 +182,44 @@ install -m 0755 -D %{SOURCE1} %{buildroot}%{_sbindir}/openssl-makecerts
%{_libdir}/*.a
%changelog
* Sun Aug 16 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.1p-1mamba
- update to 1.0.1p
* Sat Apr 30 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.2g-3mamba
- /etc and /var files moved from libopenssl to openssl
* Sat Apr 30 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.2g-2mamba
- rebuilt after updating versioning patch (from Fedora)
* Tue Mar 01 2016 Automatic Build System <autodist@mambasoft.it> 1.0.2g-1mamba
- automatic version update by autodist
* Thu Jan 28 2016 Automatic Build System <autodist@mambasoft.it> 1.0.2f-1mamba
- automatic version update by autodist
* Fri Dec 04 2015 Automatic Build System <autodist@mambasoft.it> 1.0.2e-2mamba
- automatic version update by autodist
* Fri Dec 04 2015 Automatic Build System <autodist@mambasoft.it> 1.0.2e-1mamba
- automatic version update by autodist
* Thu Jul 09 2015 Automatic Build System <autodist@mambasoft.it> 1.0.2d-1mamba
- automatic version update by autodist
* Sat Jun 13 2015 Automatic Build System <autodist@mambasoft.it> 1.0.2c-1mamba
- automatic version update by autodist
* Fri Jun 12 2015 Automatic Build System <autodist@mambasoft.it> 1.0.2b-2mamba
- automatic version update by autodist
* Fri Jun 12 2015 Automatic Build System <autodist@mambasoft.it> 1.0.2b-1mamba
- automatic version update by autodist
* Mon Apr 27 2015 Automatic Build System <autodist@mambasoft.it> 1.0.2a-2mamba
- automatic version update by autodist
* Mon Apr 27 2015 Automatic Build System <autodist@mambasoft.it> 1.0.2a-1mamba
- automatic version update by autodist
* Tue Mar 10 2015 Automatic Build System <autodist@mambasoft.it> 1.0.2-1mamba
- automatic version update by autodist
* Fri Jan 16 2015 Automatic Build System <autodist@mambasoft.it> 1.0.1l-1mamba
- automatic version update by autodist