update to 1.0.1p [release 1.0.1p-1mamba;Sun Aug 16 2015]
This commit is contained in:
parent
2cb977565d
commit
0163c47b67
@ -1,35 +1,3 @@
|
||||
diff -up openssl-1.0.1/crypto/cversion.c.version openssl-1.0.1/crypto/cversion.c
|
||||
--- openssl-1.0.1/crypto/cversion.c.version 2004-04-19 20:09:22.000000000 +0200
|
||||
+++ openssl-1.0.1/crypto/cversion.c 2012-03-14 20:58:20.630352536 +0100
|
||||
@@ -110,8 +110,15 @@ const char *SSLeay_version(int t)
|
||||
return("not available");
|
||||
}
|
||||
|
||||
-unsigned long SSLeay(void)
|
||||
+unsigned long _original_SSLeay(void)
|
||||
+ {
|
||||
+ return(0x10000003);
|
||||
+ }
|
||||
+
|
||||
+unsigned long _current_SSLeay(void)
|
||||
{
|
||||
return(SSLEAY_VERSION_NUMBER);
|
||||
}
|
||||
|
||||
+__asm__(".symver _original_SSLeay,SSLeay@");
|
||||
+__asm__(".symver _current_SSLeay,SSLeay@@OPENSSL_1.0.1");
|
||||
diff -up openssl-1.0.1/crypto/opensslv.h.version openssl-1.0.1/crypto/opensslv.h
|
||||
--- openssl-1.0.1/crypto/opensslv.h.version 2012-03-14 20:58:19.914337879 +0100
|
||||
+++ openssl-1.0.1/crypto/opensslv.h 2012-03-14 20:58:20.630352536 +0100
|
||||
@@ -83,7 +83,7 @@
|
||||
* should only keep the versions that are binary compatible with the current.
|
||||
*/
|
||||
#define SHLIB_VERSION_HISTORY ""
|
||||
-#define SHLIB_VERSION_NUMBER "1.0.0"
|
||||
+#define SHLIB_VERSION_NUMBER "1.0.1c"
|
||||
|
||||
|
||||
#endif /* HEADER_OPENSSLV_H */
|
||||
diff -up openssl-1.0.1/Makefile.shared.version openssl-1.0.1/Makefile.shared
|
||||
--- openssl-1.0.1/Makefile.shared.version 2012-03-14 20:58:20.553350959 +0100
|
||||
+++ openssl-1.0.1/Makefile.shared 2012-03-14 20:58:20.631352556 +0100
|
||||
@ -53,3 +21,33 @@ diff -up openssl-1.0.1/version.map.version openssl-1.0.1/version.map
|
||||
+ _original*;
|
||||
+ _current*;
|
||||
+};
|
||||
--- openssl-1.0.1p/crypto/cversion.c.orig 2015-08-16 15:44:39.732602452 +0200
|
||||
+++ openssl-1.0.1p/crypto/cversion.c 2015-08-16 15:45:16.262509801 +0200
|
||||
@@ -97,7 +97,14 @@
|
||||
return ("not available");
|
||||
}
|
||||
|
||||
-unsigned long SSLeay(void)
|
||||
+unsigned long _original_SSLeay(void)
|
||||
{
|
||||
- return (SSLEAY_VERSION_NUMBER);
|
||||
+ return(0x10000003);
|
||||
}
|
||||
+
|
||||
+unsigned long _current_SSLeay(void)
|
||||
+{
|
||||
+ return(SSLEAY_VERSION_NUMBER);
|
||||
+}
|
||||
+__asm__(".symver _original_SSLeay,SSLeay@");
|
||||
+__asm__(".symver _current_SSLeay,SSLeay@@OPENSSL_1.0.1");
|
||||
--- openssl-1.0.1p/crypto/opensslv.h.orig 2015-08-16 15:44:39.733602449 +0200
|
||||
+++ openssl-1.0.1p/crypto/opensslv.h 2015-08-16 15:47:04.895305120 +0200
|
||||
@@ -88,7 +88,7 @@
|
||||
* should only keep the versions that are binary compatible with the current.
|
||||
*/
|
||||
# define SHLIB_VERSION_HISTORY ""
|
||||
-# define SHLIB_VERSION_NUMBER "1.0.0"
|
||||
+# define SHLIB_VERSION_NUMBER "1.0.1"
|
||||
|
||||
|
||||
#ifdef __cplusplus
|
@ -1,5 +1,5 @@
|
||||
Name: openssl
|
||||
Version: 1.0.1l
|
||||
Version: 1.0.1p
|
||||
Release: 1mamba
|
||||
Summary: Secure Sockets Layer communications libs and utils
|
||||
Group: Network/Security
|
||||
@ -10,7 +10,7 @@ URL: http://www.openssl.org
|
||||
Source: http://www.openssl.org/source/openssl-%{version}.tar.gz
|
||||
Source1: openssl-makecerts
|
||||
Patch0: %{name}-1.0.1a-fix_non_ia32.patch
|
||||
Patch1: %{name}-1.0.1c-symbol_versioning.patch
|
||||
Patch1: %{name}-1.0.1p-symbol_versioning.patch
|
||||
License: BSD
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -175,6 +175,9 @@ install -m 0755 -D %{SOURCE1} %{buildroot}%{_sbindir}/openssl-makecerts
|
||||
%{_libdir}/*.a
|
||||
|
||||
%changelog
|
||||
* Sun Aug 16 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.1p-1mamba
|
||||
- update to 1.0.1p
|
||||
|
||||
* Fri Jan 16 2015 Automatic Build System <autodist@mambasoft.it> 1.0.1l-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user