automatic version update by autodist [release 9.8p1-1mamba;Sat Jul 06 2024]
This commit is contained in:
parent
ddabded1d6
commit
c6a4266b7a
@ -1,10 +0,0 @@
|
|||||||
--- openssh-8.2p1/sandbox-seccomp-filter.c.orig 2020-04-03 21:22:35.404943267 +0200
|
|
||||||
+++ openssh-8.2p1/sandbox-seccomp-filter.c 2020-04-03 21:22:48.674099772 +0200
|
|
||||||
@@ -251,6 +251,7 @@
|
|
||||||
#ifdef __NR_clock_nanosleep
|
|
||||||
SC_ALLOW(__NR_clock_nanosleep),
|
|
||||||
#endif
|
|
||||||
+#define __NR_clock_nanosleep_time64 407
|
|
||||||
#ifdef __NR_clock_nanosleep_time64
|
|
||||||
SC_ALLOW(__NR_clock_nanosleep_time64),
|
|
||||||
#endif
|
|
@ -1,14 +0,0 @@
|
|||||||
diff --git a/sandbox-seccomp-filter.c b/sandbox-seccomp-filter.c
|
|
||||||
index e0768c06..5065ae7e 100644
|
|
||||||
--- a/sandbox-seccomp-filter.c
|
|
||||||
+++ b/sandbox-seccomp-filter.c
|
|
||||||
@@ -267,6 +267,9 @@ static const struct sock_filter preauth_insns[] = {
|
|
||||||
#ifdef __NR_pselect6
|
|
||||||
SC_ALLOW(__NR_pselect6),
|
|
||||||
#endif
|
|
||||||
+#ifdef __NR_pselect6_time64
|
|
||||||
+ SC_ALLOW(__NR_pselect6_time64),
|
|
||||||
+#endif
|
|
||||||
#ifdef __NR_read
|
|
||||||
SC_ALLOW(__NR_read),
|
|
||||||
#endif
|
|
31
openssh.spec
31
openssh.spec
@ -6,7 +6,7 @@
|
|||||||
%define with_selinux 0
|
%define with_selinux 0
|
||||||
|
|
||||||
Name: openssh
|
Name: openssh
|
||||||
Version: 9.7p1
|
Version: 9.8p1
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: OpenSSH free Secure Shell (SSH) implementation
|
Summary: OpenSSH free Secure Shell (SSH) implementation
|
||||||
Group: Network/Security
|
Group: Network/Security
|
||||||
@ -22,8 +22,6 @@ Source4: openssh-sshd@.service
|
|||||||
Source5: openssh-sshd.socket
|
Source5: openssh-sshd.socket
|
||||||
Source6: openssh-sshd.conf
|
Source6: openssh-sshd.conf
|
||||||
Patch0: openssh-8.4p1-ssh_config.patch
|
Patch0: openssh-8.4p1-ssh_config.patch
|
||||||
Patch1: openssh-8.2p1-arm-glibc-2.31.patch
|
|
||||||
Patch2: openssh-8.4p1-sandbox-seccomp.patch
|
|
||||||
License: BSD
|
License: BSD
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -43,6 +41,7 @@ BuildRequires: libpam-devel
|
|||||||
BuildRequires: libpango-devel
|
BuildRequires: libpango-devel
|
||||||
BuildRequires: libxcrypt-devel
|
BuildRequires: libxcrypt-devel
|
||||||
BuildRequires: libz-devel
|
BuildRequires: libz-devel
|
||||||
|
BuildRequires: setup
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
%if "%{stage1}" != "1"
|
%if "%{stage1}" != "1"
|
||||||
BuildRequires: %{_bindir}/xauth
|
BuildRequires: %{_bindir}/xauth
|
||||||
@ -127,10 +126,6 @@ A Gtk2 SSH passphrase requester.
|
|||||||
#-D -T
|
#-D -T
|
||||||
#:<< _EOF
|
#:<< _EOF
|
||||||
%patch 0 -p1
|
%patch 0 -p1
|
||||||
%ifarch arm
|
|
||||||
%patch 1 -p1
|
|
||||||
%endif
|
|
||||||
#%patch2 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# note: --with-rand-helper unneeded for Linux
|
# note: --with-rand-helper unneeded for Linux
|
||||||
@ -174,10 +169,10 @@ install -d %{buildroot}%{_sysconfdir}/{ssh,pam.d}
|
|||||||
|
|
||||||
install -D -m 600 %{S:1} %{buildroot}%{_sysconfdir}/pam.d/sshd
|
install -D -m 600 %{S:1} %{buildroot}%{_sysconfdir}/pam.d/sshd
|
||||||
install -D -m 755 %{SOURCE2} %{buildroot}%{_bindir}/ssh-makecerts
|
install -D -m 755 %{SOURCE2} %{buildroot}%{_bindir}/ssh-makecerts
|
||||||
install -D -m 644 %{SOURCE3} %{buildroot}/lib/systemd/system/sshd.service
|
install -D -m 644 %{SOURCE3} %{buildroot}%{_unitdir}/sshd.service
|
||||||
install -D -m 644 %{SOURCE4} %{buildroot}/lib/systemd/system/sshd@.service
|
install -D -m 644 %{SOURCE4} %{buildroot}%{_unitdir}/sshd@.service
|
||||||
install -D -m 644 %{SOURCE5} %{buildroot}/lib/systemd/system/sshd.socket
|
install -D -m 644 %{SOURCE5} %{buildroot}%{_unitdir}/sshd.socket
|
||||||
install -D -m 644 %{SOURCE6} %{buildroot}%{_prefix}/lib/tmpfiles.d/sshd.conf
|
install -D -m 644 %{SOURCE6} %{buildroot}%{_tmpfilesdir}/sshd.conf
|
||||||
|
|
||||||
rm -f %{buildroot}%{_datadir}/Ssh.bin
|
rm -f %{buildroot}%{_datadir}/Ssh.bin
|
||||||
|
|
||||||
@ -268,7 +263,6 @@ exit 0
|
|||||||
%config(noreplace) %{_sysconfdir}/ssh/ssh_config
|
%config(noreplace) %{_sysconfdir}/ssh/ssh_config
|
||||||
%{_bindir}/scp
|
%{_bindir}/scp
|
||||||
%{_bindir}/sftp
|
%{_bindir}/sftp
|
||||||
#%{_bindir}/slogin
|
|
||||||
%{_bindir}/ssh
|
%{_bindir}/ssh
|
||||||
%{_bindir}/ssh-add
|
%{_bindir}/ssh-add
|
||||||
%{_bindir}/ssh-agent
|
%{_bindir}/ssh-agent
|
||||||
@ -277,7 +271,6 @@ exit 0
|
|||||||
%{_mandir}/man1/ssh-add.*
|
%{_mandir}/man1/ssh-add.*
|
||||||
%{_mandir}/man1/ssh-agent.*
|
%{_mandir}/man1/ssh-agent.*
|
||||||
%{_mandir}/man1/ssh.*
|
%{_mandir}/man1/ssh.*
|
||||||
#%{_mandir}/man1/slogin.*
|
|
||||||
%{_mandir}/man5/ssh_config.*
|
%{_mandir}/man5/ssh_config.*
|
||||||
|
|
||||||
%files server
|
%files server
|
||||||
@ -286,11 +279,12 @@ exit 0
|
|||||||
%config(noreplace) %{_sysconfdir}/ssh/moduli
|
%config(noreplace) %{_sysconfdir}/ssh/moduli
|
||||||
%config(noreplace) %attr(0600,root,root) %{_sysconfdir}/ssh/sshd_config
|
%config(noreplace) %attr(0600,root,root) %{_sysconfdir}/ssh/sshd_config
|
||||||
%{_sbindir}/sshd
|
%{_sbindir}/sshd
|
||||||
/lib/systemd/system/sshd.service
|
%{_unitdir}/sshd.service
|
||||||
/lib/systemd/system/sshd.socket
|
%{_unitdir}/sshd.socket
|
||||||
/lib/systemd/system/sshd@.service
|
%{_unitdir}/sshd@.service
|
||||||
%{_prefix}/lib/tmpfiles.d/sshd.conf
|
%{_tmpfilesdir}/sshd.conf
|
||||||
%{_libexecdir}/openssh/sftp-server
|
%{_libexecdir}/openssh/sftp-server
|
||||||
|
%{_libexecdir}/openssh/sshd-session
|
||||||
%attr(0755,root,sys) %dir /var/empty
|
%attr(0755,root,sys) %dir /var/empty
|
||||||
%{_mandir}/man5/sshd_config.*
|
%{_mandir}/man5/sshd_config.*
|
||||||
%{_mandir}/man8/sftp-server.*
|
%{_mandir}/man8/sftp-server.*
|
||||||
@ -302,6 +296,9 @@ exit 0
|
|||||||
%{_libexecdir}/openssh/ssh-askpass
|
%{_libexecdir}/openssh/ssh-askpass
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Jul 06 2024 Automatic Build System <autodist@openmamba.org> 9.8p1-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Mon Mar 11 2024 Automatic Build System <autodist@openmamba.org> 9.7p1-1mamba
|
* Mon Mar 11 2024 Automatic Build System <autodist@openmamba.org> 9.7p1-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user