automatic version update by autodist [release 2.0.0-1mamba;Thu Jun 13 2013]

This commit is contained in:
Automatic Build System 2024-01-06 08:15:47 +01:00
parent d91f217a75
commit 6e8afaaefb
4 changed files with 214 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# openslp # openslp
Service Location Protocol is an IETF standards track protocol that provides a framework to allow networking applications to discover the existence, location, and configuration of networked services in enterprise networks.

View File

@ -0,0 +1,57 @@
diff -ru openslp-1.2.1/common/Makefile.in openslp-1.2.1-fix/common/Makefile.in
--- openslp-1.2.1/common/Makefile.in 2005-03-02 19:00:23.000000000 +0100
+++ openslp-1.2.1-fix/common/Makefile.in 2007-03-21 14:33:47.000000000 +0100
@@ -56,27 +56,27 @@
slp_message.c slp_property.c slp_linkedlist.c slp_xid.c \
slp_network.c slp_database.c slp_xmalloc.c slp_xcast.c \
slp_iface.c slp_parse.c slp_pid.c slp_dhcp.c slp_v1message.c \
- slp_utf8.c slp_auth.c slp_crypto.c slp_spi.c
+ slp_utf8.c slp_auth.c slp_crypto.c slp_spi.c slp_net.c
@ENABLE_SLPv1_TRUE@am__objects_1 = slp_v1message.lo slp_utf8.lo
@ENABLE_SLPv2_SECURITY_TRUE@am__objects_2 = slp_auth.lo slp_crypto.lo \
@ENABLE_SLPv2_SECURITY_TRUE@ slp_spi.lo
am_libcommonlibslp_la_OBJECTS = slp_compare.lo slp_buffer.lo \
slp_message.lo slp_property.lo slp_linkedlist.lo slp_xid.lo \
slp_network.lo slp_database.lo slp_xmalloc.lo slp_xcast.lo \
- slp_iface.lo slp_parse.lo slp_pid.lo slp_dhcp.lo \
+ slp_iface.lo slp_parse.lo slp_pid.lo slp_dhcp.lo slp_net.lo \
$(am__objects_1) $(am__objects_2)
libcommonlibslp_la_OBJECTS = $(am_libcommonlibslp_la_OBJECTS)
libcommonslpd_la_LIBADD =
am__libcommonslpd_la_SOURCES_DIST = slp_compare.c slp_buffer.c \
slp_message.c slp_property.c slp_linkedlist.c slp_xid.c \
- slp_database.c slp_xmalloc.c slp_parse.c slp_iface.c slp_net.c \
+ slp_database.c slp_xmalloc.c slp_parse.c slp_iface.c \
slp_pid.c slp_attr_y.y slp_attr_l.l slp_filter_y.y \
slp_filter_l.l slp_predicate.c slp_dhcp.c slp_v1message.c \
slp_utf8.c slp_auth.c slp_crypto.c slp_spi.c
am_libcommonslpd_la_OBJECTS = slp_compare.lo slp_buffer.lo \
slp_message.lo slp_property.lo slp_linkedlist.lo slp_xid.lo \
slp_database.lo slp_xmalloc.lo slp_parse.lo slp_iface.lo \
- slp_net.lo slp_pid.lo slp_attr_y.lo slp_attr_l.lo \
+ slp_pid.lo slp_attr_y.lo slp_attr_l.lo \
slp_filter_y.lo slp_filter_l.lo slp_predicate.lo slp_dhcp.lo \
$(am__objects_1) $(am__objects_2)
libcommonslpd_la_OBJECTS = $(am_libcommonslpd_la_OBJECTS)
diff -ru openslp-1.2.1/slpd/Makefile.in openslp-1.2.1-fix/slpd/Makefile.in
--- openslp-1.2.1/slpd/Makefile.in 2005-03-02 19:00:24.000000000 +0100
+++ openslp-1.2.1-fix/slpd/Makefile.in 2007-03-21 14:36:30.000000000 +0100
@@ -78,7 +78,7 @@
slpd_outgoing.$(OBJEXT)
slpd_OBJECTS = $(am_slpd_OBJECTS)
slpd_DEPENDENCIES = ../common/libcommonslpd.la \
- ../libslpattr/libslpattr.la
+ ../libslpattr/libslpattr.la ../common/libcommonlibslp.la
DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)
depcomp = $(SHELL) $(top_srcdir)/depcomp
am__depfiles_maybe = depfiles
@@ -252,7 +252,8 @@
#if you're building on Irix, exchange commented and uncommented lines
#slpd_LDADD = ../common/libcommonslpd.a ../libslpattr/libslpattr.a
-slpd_LDADD = ../common/libcommonslpd.la ../libslpattr/libslpattr.la
+slpd_LDADD = ../common/libcommonslpd.la ../libslpattr/libslpattr.la \
+ ../common/libcommonlibslp.la
all: all-am
.SUFFIXES:

View File

@ -0,0 +1,22 @@
--- openslp-1.2.1/configure.in.optflags 2005-02-15 14:06:02.000000000 -0600
+++ openslp-1.2.1/configure.in 2005-03-04 06:53:02.000000000 -0600
@@ -130,7 +130,7 @@
CFLAGS="$CFLAGS -Werror"
fi
if test X"$debug" = X"no"; then
- OPTFLAGS="-O3"
+ OPTFLAGS="-O3 $RPM_OPT_FLAGS"
fi
elif $CC -V 2>&1 | grep "WorkShop Compilers"; then
--- openslp-1.2.1/configure.optflags 2005-03-02 12:00:28.000000000 -0600
+++ openslp-1.2.1/configure 2005-03-04 06:53:04.000000000 -0600
@@ -20596,7 +20596,7 @@
CFLAGS="$CFLAGS -Werror"
fi
if test X"$debug" = X"no"; then
- OPTFLAGS="-O3"
+ OPTFLAGS="-O3 $RPM_OPT_FLAGS"
fi
elif $CC -V 2>&1 | grep "WorkShop Compilers"; then

133
openslp.spec Normal file
View File

@ -0,0 +1,133 @@
Name: openslp
Version: 2.0.0
Release: 1mamba
Summary: An open-source implementation of Service Location Protocol
Group: System/Servers
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.openslp.org
Source: http://downloads.sourceforge.net/sourceforge/openslp/%{name}-%{version}.tar.gz
Patch0: %{name}-1.2.1-optflags.patch
Patch1: %{name}-1.2.1-export_slp_net_symbols
License: BSD
BuildRequires: flex
BuildRequires: bison
BuildRequires: libtool
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libopenssl-devel
## AUTOBUILDREQ-END
Requires: libopenslp = %{?epoch:%epoch:}%{version}-%{release}
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
Service Location Protocol is an IETF standards track protocol that provides a framework to allow networking applications to discover the existence, location, and configuration of networked services in enterprise networks.
%package -n libopenslp
Summary: Shared libraries for openslp
Group: System/Libraries
%description -n libopenslp
Service Location Protocol is an IETF standards track protocol that provides a framework to allow networking applications to discover the existence, location, and configuration of networked services in enterprise networks.
This is the openslp library.
%package -n libopenslp-devel
Summary: Static libraries and headers for openslp
Group: Development/Libraries
Requires: libopenslp = %{?epoch:%epoch:}%{version}-%{release}
%description -n libopenslp-devel
Service Location Protocol is an IETF standards track protocol that provides a framework to allow networking applications to discover the existence, location, and configuration of networked services in enterprise networks.
This package contains static libraries and header files need for development.
%prep
%setup -q
#%patch0 -p1 -b .optflags
#%patch1 -p1 -b .export_slp_net_symbols
%build
%configure \
--enable-slpv2-security \
--sysconfdir=%{_sysconfdir}/slp
%make \
%if "%{_build}" != "%{_host}"
LDFLAGS="-lssl -lcrypto -ldl -pie" \
%else
LDFLAGS="-pie" \
%endif
CFLAGS="%{optflags} \
-fPIC" \
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
install -D -m 755 etc/slpd.all_init \
%{buildroot}%{_initrddir}/slpd
#rm -rf rpmdoc
#mv %{buildroot}%{_prefix}/doc/%{name}-%{version} rpmdoc
#find rpmdoc -name CVS | xargs rm -rf
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post -n libopenslp -p /sbin/ldconfig
%postun -n libopenslp -p /sbin/ldconfig
%files
%defattr(-,root,root)
%{_bindir}/slptool
%{_sbindir}/slpd
%config(noreplace) %{_initrddir}/slpd
%dir %{_sysconfdir}/slp
%config(noreplace) %{_sysconfdir}/slp/slp.conf
%config(noreplace) %{_sysconfdir}/slp/slp.reg
%config(noreplace) %{_sysconfdir}/slp/slp.spi
%files -n libopenslp
%defattr(-,root,root)
%{_libdir}/*.so
%{_libdir}/*.so.*
%doc AUTHORS COPYING
%files -n libopenslp-devel
%defattr(-,root,root)
%{_libdir}/*.a
%{_libdir}/*.la
%{_includedir}/*.h
%doc ChangeLog FAQ NEWS README THANKS
#%doc rpmdoc/*
%changelog
* Thu Jun 13 2013 Automatic Build System <autodist@mambasoft.it> 2.0.0-1mamba
- automatic version update by autodist
* Sat Sep 18 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.1-4mamba
- rebuilt with openssl 1.0
* Mon Jun 29 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.1-3mamba
- specfile updated and rebuilt
* Wed Mar 21 2007 Davide Madrisan <davide.madrisan@qilinux.it> 1.2.1-2qilnx
- export the SLPNetGetThisHostname symbol needed by kdenetwork3
* Fri Nov 18 2005 Stefano Cotta Ramusino <stefano.cotta@qilinux.it> 1.2.1-1qilnx
- update to version 1.2.1 by autospec
- added optflags patch
- added missing requirements
* Tue Mar 22 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.0.11-3qilnx
- security fix based on SUSE's audit: QSA-2005-030
- specfile fixes
- own /etc/slp/
* Tue Oct 28 2003 Davide Madrisan <davide.madrisan@qilinux.it> 1.0.11-2qilnx
- added missing scripts
* Thu Jul 31 2003 Silvan Calarco <silvan.calarco@qinet.it> 1.0.11-1qilnux
- first build for openslp (initscript missing, built for kdenetwork)