added debug package, openssl 1.1 patch [release 2.0.0-2mamba;Sun Dec 06 2020]
This commit is contained in:
parent
6e8afaaefb
commit
6ac29f65c2
25
openslp-2.0.0-openssl-1.1.patch
Normal file
25
openslp-2.0.0-openssl-1.1.patch
Normal file
@ -0,0 +1,25 @@
|
||||
diff -up openslp-2.0.0/common/slp_crypto.c.orig openslp-2.0.0/common/slp_crypto.c
|
||||
--- openslp-2.0.0/common/slp_crypto.c.orig 2012-12-07 21:13:28.000000000 +0100
|
||||
+++ openslp-2.0.0/common/slp_crypto.c 2017-02-22 11:16:11.620835724 +0100
|
||||
@@ -88,11 +88,16 @@ SLPCryptoDSAKey * SLPCryptoDSAKeyDup(SLP
|
||||
result = DSA_new();
|
||||
if (result)
|
||||
{
|
||||
- result->p = BN_dup(dsa->p);
|
||||
- result->q = BN_dup(dsa->q);
|
||||
- result->g = BN_dup(dsa->g);
|
||||
- result->priv_key = BN_dup(dsa->priv_key);
|
||||
- result->pub_key = BN_dup(dsa->pub_key);
|
||||
+ const BIGNUM *p, *q, *g;
|
||||
+ const BIGNUM *priv_key, *pub_key;
|
||||
+
|
||||
+ DSA_get0_pqg(dsa, &p, &q, &g);
|
||||
+ DSA_get0_key(dsa, &pub_key, &priv_key);
|
||||
+
|
||||
+ /* would be nice to check return values,
|
||||
+ * but original code didn't do that either... */
|
||||
+ DSA_set0_pqg(result, BN_dup(p), BN_dup(q), BN_dup(g));
|
||||
+ DSA_set0_key(result, BN_dup(pub_key), BN_dup(priv_key));
|
||||
}
|
||||
return result;
|
||||
}
|
38
openslp.spec
38
openslp.spec
@ -1,6 +1,6 @@
|
||||
Name: openslp
|
||||
Version: 2.0.0
|
||||
Release: 1mamba
|
||||
Release: 2mamba
|
||||
Summary: An open-source implementation of Service Location Protocol
|
||||
Group: System/Servers
|
||||
Vendor: openmamba
|
||||
@ -10,14 +10,21 @@ URL: http://www.openslp.org
|
||||
Source: http://downloads.sourceforge.net/sourceforge/openslp/%{name}-%{version}.tar.gz
|
||||
Patch0: %{name}-1.2.1-optflags.patch
|
||||
Patch1: %{name}-1.2.1-export_slp_net_symbols
|
||||
Patch2: openslp-2.0.0-openssl-1.1.patch
|
||||
License: BSD
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: ldconfig
|
||||
BuildRequires: libe2fs-devel
|
||||
BuildRequires: libkrb5-devel
|
||||
BuildRequires: libnsl-devel
|
||||
BuildRequires: libopenssl-devel
|
||||
BuildRequires: libtirpc-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: flex
|
||||
BuildRequires: bison
|
||||
BuildRequires: libtool
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libopenssl-devel
|
||||
## AUTOBUILDREQ-END
|
||||
Requires: libopenslp = %{?epoch:%epoch:}%{version}-%{release}
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
@ -40,13 +47,13 @@ Requires: libopenslp = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description -n libopenslp-devel
|
||||
Service Location Protocol is an IETF standards track protocol that provides a framework to allow networking applications to discover the existence, location, and configuration of networked services in enterprise networks.
|
||||
This package contains static libraries and header files needed for development.
|
||||
|
||||
This package contains static libraries and header files need for development.
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch0 -p1 -b .optflags
|
||||
#%patch1 -p1 -b .export_slp_net_symbols
|
||||
%patch2 -p1
|
||||
|
||||
%build
|
||||
%configure \
|
||||
@ -81,29 +88,32 @@ install -D -m 755 etc/slpd.all_init \
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/slptool
|
||||
%{_sbindir}/slpd
|
||||
%config(noreplace) %{_initrddir}/slpd
|
||||
%dir %{_sysconfdir}/slp
|
||||
%config(noreplace) %{_sysconfdir}/slp/slp.conf
|
||||
%config(noreplace) %{_sysconfdir}/slp/slp.reg
|
||||
%config(noreplace) %{_sysconfdir}/slp/slp.spi
|
||||
%{_bindir}/slptool
|
||||
%{_sbindir}/slpd
|
||||
|
||||
%files -n libopenslp
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/*.so
|
||||
%{_libdir}/*.so.*
|
||||
%{_libdir}/libslp.so.*
|
||||
%doc AUTHORS COPYING
|
||||
|
||||
%files -n libopenslp-devel
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/*.a
|
||||
%{_libdir}/*.la
|
||||
%{_libdir}/libslp.a
|
||||
%{_libdir}/libslp.la
|
||||
%{_libdir}/libslp.so
|
||||
%{_includedir}/*.h
|
||||
%doc ChangeLog FAQ NEWS README THANKS
|
||||
#%doc rpmdoc/*
|
||||
|
||||
%changelog
|
||||
* Sun Dec 06 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.0-2mamba
|
||||
- added debug package, openssl 1.1 patch
|
||||
|
||||
* Thu Jun 13 2013 Automatic Build System <autodist@mambasoft.it> 2.0.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user