move conflicting files from libmpi1 to openmpi1 [release 1.8.8-3mamba;Tue Sep 04 2018]

This commit is contained in:
Silvan Calarco 2024-01-06 08:14:54 +01:00
parent 242a6a92f7
commit ff4dfff8a8
3 changed files with 528 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# openmpi1 # openmpi1
The Open MPI Project is an open source MPI-2 implementation that is developed and maintained by a consortium of academic, research, and industry partners. Open MPI is therefore able to combine the expertise, technologies, and resources from all across the High Performance Computing community in order to build the best MPI library available. Open MPI offers advantages for system and software vendors, application developers and computer science researchers.

View File

@ -0,0 +1,265 @@
From cab1379dfbd63079defc26110b004e6c00e397d3 Mon Sep 17 00:00:00 2001
From: Jeff Squyres <jsquyres@cisco.com>
Date: Tue, 6 Jan 2015 09:42:57 -0800
Subject: [PATCH] Fortran: only emit real16 and complex32 if supported
This is the master version of @ggouaillardet's patch from
open-mpi/ompi-release#148 (there was a minor conflict to fix and
several fuzzings of line numbers).
---
ompi/include/Makefile.am | 6 ++++--
ompi/mpi/fortran/base/gen-mpi-sizeof.pl | 18 +++++++++++++++---
ompi/mpi/fortran/mpif-h/Makefile.am | 6 +++++-
ompi/mpi/fortran/mpif-h/profile/Makefile.am | 6 +++++-
ompi/mpi/fortran/use-mpi-f08/Makefile.am | 14 +++++++++++---
ompi/mpi/fortran/use-mpi-ignore-tkr/Makefile.am | 10 ++++++++--
ompi/mpi/fortran/use-mpi-tkr/Makefile.am | 10 +++++++---
7 files changed, 55 insertions(+), 15 deletions(-)
diff --git a/ompi/include/Makefile.am b/ompi/include/Makefile.am
index 9b72094..b0ce9dd 100644
--- a/ompi/include/Makefile.am
+++ b/ompi/include/Makefile.am
@@ -11,7 +11,7 @@
# All rights reserved.
# Copyright (c) 2006-2014 Cisco Systems, Inc. All rights reserved.
# Copyright (c) 2009-2011 Oak Ridge National Labs. All rights reserved.
-# Copyright (c) 2014 Research Organization for Information Science
+# Copyright (c) 2014-2015 Research Organization for Information Science
# and Technology (RIST). All rights reserved.
# $COPYRIGHT$
#
@@ -84,7 +84,9 @@ mpif-sizeof.h:
$(OMPI_V_GEN) $(sizeof_pl) \
--header=$@ --ierror=mandatory \
--maxrank=$(OMPI_FORTRAN_MAX_ARRAY_RANK) \
- --generate=$(OMPI_FORTRAN_BUILD_SIZEOF)
+ --generate=$(OMPI_FORTRAN_BUILD_SIZEOF) \
+ --real16=$(OMPI_HAVE_FORTRAN_REAL16) \
+ --complex32=$(OMPI_HAVE_FORTRAN_COMPLEX32)
if WANT_INSTALL_HEADERS
ompidir = $(ompiincludedir)
diff --git a/ompi/mpi/fortran/base/gen-mpi-sizeof.pl b/ompi/mpi/fortran/base/gen-mpi-sizeof.pl
index 797c42b..a422c9a 100755
--- a/ompi/mpi/fortran/base/gen-mpi-sizeof.pl
+++ b/ompi/mpi/fortran/base/gen-mpi-sizeof.pl
@@ -1,6 +1,8 @@
#!/usr/bin/env perl
#
# Copyright (c) 2014 Cisco Systems, Inc. All rights reserved.
+# Copyright (c) 2015 Research Organization for Information Science
+# and Technology (RIST). All rights reserved.
# $COPYRIGHT$
#
# Script to generate the overloaded MPI_SIZEOF interfaces and
@@ -30,17 +32,21 @@
my $maxrank_arg;
my $generate_arg;
my $mpi_arg;
+my $mpi_real16;
+my $mpi_complex32;
my $pmpi_arg;
my $help_arg = 0;
&Getopt::Long::Configure("bundling");
-my $ok = Getopt::Long::GetOptions("header=s" => \$header_arg,
+my $ok = Getopt::Long::GetOptions("complex32=i" => \$mpi_complex32,
+ "header=s" => \$header_arg,
"impl=s" => \$impl_arg,
"ierror=s" => \$ierror_arg,
"maxrank=s" => \$maxrank_arg,
"generate=i" => \$generate_arg,
"mpi" => \$mpi_arg,
"pmpi" => \$pmpi_arg,
+ "real16=i" => \$mpi_real16,
"help|h" => \$help_arg);
die "Must specify header and/or impl filenames to output"
@@ -54,6 +60,8 @@
die "Must specify --pmpi and/or --mpi if --impl is specified"
if (defined($generate_arg) && $generate_arg &&
(defined($impl_arg) && !defined($mpi_arg) && !defined($pmpi_arg)));
+die "Must specify real16 and complex32"
+ if (!defined($mpi_real16) || !defined($mpi_complex32));
#############################################################################
@@ -141,8 +149,12 @@ sub generate {
queue_sub("integer(int${size})", "int${size}", "int${size}");
}
for my $size (qw/32 64 128/) {
- queue_sub("real(real${size})", "real${size}", "real${size}");
- queue_sub("complex(real${size})", "complex${size}", "real${size}");
+ if ($size != 128 || $mpi_real16 == 1) {
+ queue_sub("real(real${size})", "real${size}", "real${size}");
+ }
+ if ($size != 128 || $mpi_complex32 == 1) {
+ queue_sub("complex(real${size})", "complex${size}", "real${size}");
+ }
}
#######################################################
diff --git a/ompi/mpi/fortran/mpif-h/Makefile.am b/ompi/mpi/fortran/mpif-h/Makefile.am
--- openmpi-1.8.4/ompi/mpi/fortran/mpif-h/Makefile.am.orig 2014-12-20 03:11:06.000000000 +0100
+++ openmpi-1.8.4/ompi/mpi/fortran/mpif-h/Makefile.am 2015-03-24 21:42:17.572541432 +0100
@@ -14,6 +14,8 @@
# Copyright (c) 2011-2013 Universite Bordeaux 1
# Copyright (c) 2013-2014 Los Alamos National Security, LLC. All rights
# reserved.
+# Copyright (c) 2015 Research Organization for Information Science
+# and Technology (RIST). All rights reserved.
# $COPYRIGHT$
#
# Additional copyrights may follow
@@ -135,7 +137,9 @@
$(OMPI_V_GEN) $(sizeof_pl) \
--impl=$@ --ierror=mandatory --mpi \
--maxrank=$(OMPI_FORTRAN_MAX_ARRAY_RANK) \
- --generate=$(OMPI_FORTRAN_BUILD_SIZEOF)
+ --generate=$(OMPI_FORTRAN_BUILD_SIZEOF) \
+ --real16=$(OMPI_HAVE_FORTRAN_REAL16) \
+ --complex32=$(OMPI_HAVE_FORTRAN_COMPLEX32)
endif OMPI_BUILD_FORTRAN_MPIFH_BINDINGS
if BUILD_MPI_FORTRAN_MPIFH_BINDINGS_LAYER
diff --git a/ompi/mpi/fortran/mpif-h/profile/Makefile.am b/ompi/mpi/fortran/mpif-h/profile/Makefile.am
index 66712df..1352ab5 100644
--- a/ompi/mpi/fortran/mpif-h/profile/Makefile.am
+++ b/ompi/mpi/fortran/mpif-h/profile/Makefile.am
@@ -15,6 +15,8 @@
# Copyright (c) 2011-2013 Universite Bordeaux 1
# Copyright (c) 2013-2014 Los Alamos National Security, LLC. All rights
# reserved.
+# Copyright (c) 2015 Research Organization for Information Science
+# and Technology (RIST). All rights reserved.
# $COPYRIGHT$
#
# Additional copyrights may follow
@@ -426,7 +428,9 @@ psizeof_f.f90:
$(OMPI_V_GEN) $(sizeof_pl) \
--impl=$@ --ierror=mandatory --pmpi \
--maxrank=$(OMPI_FORTRAN_MAX_ARRAY_RANK) \
- --generate=$(OMPI_FORTRAN_BUILD_SIZEOF)
+ --generate=$(OMPI_FORTRAN_BUILD_SIZEOF) \
+ --real16=$(OMPI_HAVE_FORTRAN_REAL16) \
+ --complex32=$(OMPI_HAVE_FORTRAN_COMPLEX32)
#
# The library itself
diff --git a/ompi/mpi/fortran/use-mpi-f08/Makefile.am b/ompi/mpi/fortran/use-mpi-f08/Makefile.am
index c73882f..a8e323b 100644
--- a/ompi/mpi/fortran/use-mpi-f08/Makefile.am
+++ b/ompi/mpi/fortran/use-mpi-f08/Makefile.am
@@ -7,6 +7,8 @@
# Copyright (c) 2012-2013 Inria. All rights reserved.
# Copyright (c) 2013 Los Alamos National Security, LLC. All rights
# reserved.
+# Copyright (c) 2015 Research Organization for Information Science
+# and Technology (RIST). All rights reserved.
#
# $COPYRIGHT$
#
@@ -58,7 +60,9 @@ sizeof_f08.h:
$(OMPI_V_GEN) $(sizeof_pl) \
--header=$@ --ierror=optional \
--maxrank=$(OMPI_FORTRAN_MAX_ARRAY_RANK) \
- --generate=$(OMPI_FORTRAN_BUILD_SIZEOF)
+ --generate=$(OMPI_FORTRAN_BUILD_SIZEOF) \
+ --real16=$(OMPI_HAVE_FORTRAN_REAL16) \
+ --complex32=$(OMPI_HAVE_FORTRAN_COMPLEX32)
sizeof_f08.f90: $(top_builddir)/config.status
sizeof_f08.f90: $(sizeof_pl)
@@ -66,7 +70,9 @@ sizeof_f08.f90:
$(OMPI_V_GEN) $(sizeof_pl) \
--impl=$@ --ierror=optional --mpi \
--maxrank=$(OMPI_FORTRAN_MAX_ARRAY_RANK) \
- --generate=$(OMPI_FORTRAN_BUILD_SIZEOF)
+ --generate=$(OMPI_FORTRAN_BUILD_SIZEOF) \
+ --real16=$(OMPI_HAVE_FORTRAN_REAL16) \
+ --complex32=$(OMPI_HAVE_FORTRAN_COMPLEX32)
profile/psizeof_f08.f90: $(top_builddir)/config.status
profile/psizeof_f08.f90: $(sizeof_pl)
@@ -74,7 +80,9 @@ profile/psizeof_f08.f90:
$(OMPI_V_GEN) $(sizeof_pl) \
--impl=$@ --ierror=optional --pmpi \
--maxrank=$(OMPI_FORTRAN_MAX_ARRAY_RANK) \
- --generate=$(OMPI_FORTRAN_BUILD_SIZEOF)
+ --generate=$(OMPI_FORTRAN_BUILD_SIZEOF) \
+ --real16=$(OMPI_HAVE_FORTRAN_REAL16) \
+ --complex32=$(OMPI_HAVE_FORTRAN_COMPLEX32)
CLEANFILES += sizeof_f08.h sizeof_f08.f90 profile/psizeof_f08.f90
diff --git a/ompi/mpi/fortran/use-mpi-ignore-tkr/Makefile.am b/ompi/mpi/fortran/use-mpi-ignore-tkr/Makefile.am
index 2826660..7f65652 100644
--- a/ompi/mpi/fortran/use-mpi-ignore-tkr/Makefile.am
+++ b/ompi/mpi/fortran/use-mpi-ignore-tkr/Makefile.am
@@ -1,6 +1,8 @@
# -*- makefile -*-
#
# Copyright (c) 2006-2014 Cisco Systems, Inc. All rights reserved.
+# Copyright (c) 2015 Research Organization for Information Science
+# and Technology (RIST). All rights reserved.
#
# $COPYRIGHT$
#
@@ -63,7 +65,9 @@ mpi-ignore-tkr-sizeof.h:
$(OMPI_V_GEN) $(sizeof_pl) \
--header=$@ --ierror=mandatory \
--maxrank=$(OMPI_FORTRAN_MAX_ARRAY_RANK) \
- --generate=$(OMPI_FORTRAN_BUILD_SIZEOF)
+ --generate=$(OMPI_FORTRAN_BUILD_SIZEOF) \
+ --real16=$(OMPI_HAVE_FORTRAN_REAL16) \
+ --complex32=$(OMPI_HAVE_FORTRAN_COMPLEX32)
mpi-ignore-tkr-sizeof.f90: $(top_builddir)/config.status
mpi-ignore-tkr-sizeof.f90: $(sizeof_pl)
@@ -71,7 +75,9 @@ mpi-ignore-tkr-sizeof.f90:
$(OMPI_V_GEN) $(sizeof_pl) \
--impl=$@ --ierror=mandatory --mpi --pmpi \
--maxrank=$(OMPI_FORTRAN_MAX_ARRAY_RANK) \
- --generate=$(OMPI_FORTRAN_BUILD_SIZEOF)
+ --generate=$(OMPI_FORTRAN_BUILD_SIZEOF) \
+ --real16=$(OMPI_HAVE_FORTRAN_REAL16) \
+ --complex32=$(OMPI_HAVE_FORTRAN_COMPLEX32)
#
# Clean up generated and module files
diff --git a/ompi/mpi/fortran/use-mpi-tkr/Makefile.am b/ompi/mpi/fortran/use-mpi-tkr/Makefile.am
index 52cf855..208c73c 100644
--- a/ompi/mpi/fortran/use-mpi-tkr/Makefile.am
+++ b/ompi/mpi/fortran/use-mpi-tkr/Makefile.am
@@ -13,7 +13,7 @@
# Copyright (c) 2006-2014 Cisco Systems, Inc. All rights reserved.
# Copyright (c) 2007 Los Alamos National Security, LLC. All rights
# reserved.
-# Copyright (c) 2014 Research Organization for Information Science
+# Copyright (c) 2014-2015 Research Organization for Information Science
# and Technology (RIST). All rights reserved.
# $COPYRIGHT$
#
@@ -104,7 +104,9 @@ mpi-tkr-sizeof.h:
$(OMPI_V_GEN) $(sizeof_pl) \
--header=$@ --ierror=mandatory \
--maxrank=$(OMPI_FORTRAN_MAX_ARRAY_RANK) \
- --generate=$(OMPI_FORTRAN_BUILD_SIZEOF)
+ --generate=$(OMPI_FORTRAN_BUILD_SIZEOF) \
+ --real16=$(OMPI_HAVE_FORTRAN_REAL16) \
+ --complex32=$(OMPI_HAVE_FORTRAN_COMPLEX32)
mpi-tkr-sizeof.f90: $(top_builddir)/config.status
mpi-tkr-sizeof.f90: $(sizeof_pl)
@@ -112,7 +114,9 @@ mpi-tkr-sizeof.f90:
$(OMPI_V_GEN) $(sizeof_pl) \
--impl=$@ --ierror=mandatory --mpi --pmpi \
--maxrank=$(OMPI_FORTRAN_MAX_ARRAY_RANK) \
- --generate=$(OMPI_FORTRAN_BUILD_SIZEOF)
+ --generate=$(OMPI_FORTRAN_BUILD_SIZEOF) \
+ --real16=$(OMPI_HAVE_FORTRAN_REAL16) \
+ --complex32=$(OMPI_HAVE_FORTRAN_COMPLEX32)
#
# Clean up all F90 module files and all generated files

261
openmpi1.spec Normal file
View File

@ -0,0 +1,261 @@
%define majver %(echo %version | cut -d. -f1-2)
Name: openmpi1
Version: 1.8.8
Release: 3mamba
Summary: A High Performance Message Passing Library
Group: System/Tools
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.open-mpi.org/
Source: http://www.open-mpi.org/software/ompi/v%{majver}/downloads/openmpi-%{version}.tar.bz2
Patch0: openmpi-1.8.4-arm-no-unsupported-types.patch
License: BSD
## AUTOBUILDREQ-BEGIN
BuildRequires: gcc-fortran
BuildRequires: glibc-devel
BuildRequires: libesmtp-devel
BuildRequires: libgcc
BuildRequires: libgomp-devel
BuildRequires: libopenssl-devel
%ifnarch arm
BuildRequires: libquadmath-devel
%endif
BuildRequires: libstdc++6-devel
BuildRequires: libz-devel
BuildRequires: perl-devel
## AUTOBUILDREQ-END
BuildRequires: jpackage-utils
Requires: libmpi1 = %{?epoch:%epoch:}%{version}-%{release}
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
The Open MPI Project is an open source MPI-2 implementation that is developed and maintained by a consortium of academic, research, and industry partners. Open MPI is therefore able to combine the expertise, technologies, and resources from all across the High Performance Computing community in order to build the best MPI library available. Open MPI offers advantages for system and software vendors, application developers and computer science researchers.
%package devel
Summary: Devel package for %{name}
Group: Development/Libraries
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
Requires: libmpi1-devel = %{?epoch:%epoch:}%{version}-%{release}
%description devel
The Open MPI Project is an open source MPI-2 implementation that is developed and maintained by a consortium of academic, research, and industry partners. Open MPI is therefore able to combine the expertise, technologies, and resources from all across the High Performance Computing community in order to build the best MPI library available. Open MPI offers advantages for system and software vendors, application developers and computer science researchers.
This package contains mpi compilers.
%package -n libmpi1
Summary: A High Performance Message Passing Library
Group: System/Libraries
%description -n libmpi1
The Open MPI Project is an open source MPI-2 implementation that is developed and maintained by a consortium of academic, research, and industry partners. Open MPI is therefore able to combine the expertise, technologies, and resources from all across the High Performance Computing community in order to build the best MPI library available. Open MPI offers advantages for system and software vendors, application developers and computer science researchers.
This package contains the project shared libraries.
%package -n libmpi1-devel
Summary: Devel package for %{name}
Group: Development/Libraries
Requires: libmpi1 = %{?epoch:%epoch:}%{version}-%{release}
%description -n libmpi1-devel
The Open MPI Project is an open source MPI-2 implementation that is developed and maintained by a consortium of academic, research, and industry partners. Open MPI is therefore able to combine the expertise, technologies, and resources from all across the High Performance Computing community in order to build the best MPI library available. Open MPI offers advantages for system and software vendors, application developers and computer science researchers.
This package contains static libraries and header files need for development.
%prep
%setup -q -n openmpi-%{version}
%ifarch arm
sed -i "s|armv5\*linux|arm*linux|" configure || exit 1
%endif
#%patch0 -p1
%build
%configure \
--datarootdir=%{_datadir}/openmpi1 \
--datadir=%{_datadir}/openmpi1
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
# not installed as of 1.4.3 but symlink otfdecompress pointing to it it is
install -D -m0755 ./ompi/contrib/vt/vt/extlib/otf/tools/otfcompress/otfcompress %{buildroot}%{_bindir}/otfcompress
# %{_bindir}/otfinfo: conflicts with texlive
mv %{buildroot}%{_bindir}/otfinfo %{buildroot}%{_bindir}/otfinfompi
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files
%defattr(-,root,root)
%config %{_sysconfdir}/openmpi-default-hostfile
%config %{_sysconfdir}/openmpi-mca-params.conf
%config %{_sysconfdir}/openmpi-totalview.tcl
%config %{_sysconfdir}/vt-java-default-filter.spec
%config %{_sysconfdir}/vtsetup-config.dtd
%config %{_sysconfdir}/vtsetup-config.xml
%{_bindir}/*
%{_mandir}/man1/*.1*
%{_mandir}/man7/*.7*
%{_libdir}/mpi.mod
%{_libdir}/mpi_ext.mod
%{_libdir}/mpi_f08.mod
%{_libdir}/mpi_f08_ext.mod
%{_libdir}/mpi_f08_interfaces.mod
%{_libdir}/mpi_f08_interfaces_callbacks.mod
#%{_libdir}/mpi_f08_sizeof.mod
%{_libdir}/mpi_f08_types.mod
%{_libdir}/pmpi_f08_interfaces.mod
%{_libdir}/openmpi/mca_*.la
%{_libdir}/openmpi/mca_*.so
%{_libdir}/openmpi/libompi_*.la
%{_libdir}/openmpi/libompi_*.so
%dir %{_datadir}/openmpi1
%{_datadir}/openmpi1/*
%doc AUTHORS LICENSE
%files -n libmpi1
%defattr(-,root,root)
%{_libdir}/libompitrace.so.*
%{_libdir}/libotfaux.so.*
%{_libdir}/libvt-hyb.so.*
%{_libdir}/libvt-java.so.*
%{_libdir}/libvt-mpi-unify.so.*
%{_libdir}/libvt-mpi.so.*
%{_libdir}/libvt-mt.so.*
%{_libdir}/libvt.so.*
%{_libdir}/libmca*.so.*
%{_libdir}/libmpi*.so.*
%{_libdir}/libopen*.so.*
%{_libdir}/liboshmem.so.*
%files -n libmpi1-devel
%defattr(-,root,root)
%{_includedir}/*.h
%{_includedir}/shmem.fh
%dir %{_includedir}/openmpi
%{_includedir}/openmpi/*
%dir %{_includedir}/vampirtrace
%{_includedir}/vampirtrace/*.inc
%{_includedir}/vampirtrace/*.h
%dir %{_includedir}/vampirtrace/open-trace-format
%dir %{_includedir}/vampirtrace/open-trace-format/*.h
%dir %{_includedir}/mpp
%{_includedir}/mpp/shmem.fh
%{_includedir}/mpp/shmem.h
%{_libdir}/libmca*.la
%{_libdir}/libmca*.so
%{_libdir}/libmpi*.la
%{_libdir}/libmpi*.so
%{_libdir}/libopen*.la
%{_libdir}/libopen*.so
%{_libdir}/libopen-trace-format.a
%{_libdir}/liboshmem.la
%{_libdir}/liboshmem.so
%{_libdir}/libvt.a
%{_libdir}/libompitrace.la
%{_libdir}/libompitrace.so
%{_libdir}/libotfaux.a
%{_libdir}/libotfaux.la
%{_libdir}/libotfaux.so
%{_libdir}/libvt-hyb.a
%{_libdir}/libvt-hyb.la
%{_libdir}/libvt-hyb.so
%{_libdir}/libvt-java.la
%{_libdir}/libvt-java.so
%{_libdir}/libvt-mpi-unify.a
%{_libdir}/libvt-mpi-unify.la
%{_libdir}/libvt-mpi-unify.so
%{_libdir}/libvt-mpi.a
%{_libdir}/libvt-mpi.la
%{_libdir}/libvt-mpi.so
%{_libdir}/libvt-mt.a
%{_libdir}/libvt-mt.la
%{_libdir}/libvt-mt.so
%{_libdir}/libvt-pomp.a
%{_libdir}/libvt-pomp.la
%{_libdir}/libvt.la
%{_libdir}/libvt.so
%{_libdir}/pkgconfig/ompi-c.pc
%{_libdir}/pkgconfig/ompi-cxx.pc
%{_libdir}/pkgconfig/ompi-f77.pc
%{_libdir}/pkgconfig/ompi-f90.pc
%{_libdir}/pkgconfig/ompi-fort.pc
%{_libdir}/pkgconfig/ompi.pc
%{_libdir}/pkgconfig/orte.pc
%{_mandir}/man3/OpenMPI*.3*
%{_mandir}/man3/MPI*.3*
%doc NEWS README
%changelog
* Tue Sep 04 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 1.8.8-3mamba
- move conflicting files from libmpi1 to openmpi1
* Wed Aug 29 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 1.8.8-2mamba
- legacy package
* Fri Aug 07 2015 Automatic Build System <autodist@mambasoft.it> 1.8.8-1mamba
- automatic version update by autodist
* Sat Jul 18 2015 Automatic Build System <autodist@mambasoft.it> 1.8.7-1mamba
- automatic version update by autodist
* Tue Jun 23 2015 Automatic Build System <autodist@mambasoft.it> 1.8.6-1mamba
- automatic version update by autodist
* Sun May 24 2015 Automatic Build System <autodist@mambasoft.it> 1.8.5-1mamba
- automatic version update by autodist
* Sun Dec 28 2014 Automatic Build System <autodist@mambasoft.it> 1.8.4-1mamba
- automatic version update by autodist
* Tue Sep 30 2014 Automatic Build System <autodist@mambasoft.it> 1.8.3-1mamba
- automatic version update by autodist
* Fri Sep 05 2014 Automatic Build System <autodist@mambasoft.it> 1.8.2-1mamba
- automatic version update by autodist
* Fri Apr 25 2014 Automatic Build System <autodist@mambasoft.it> 1.8.1-1mamba
- automatic version update by autodist
* Sun Apr 13 2014 Automatic Build System <autodist@mambasoft.it> 1.8-1mamba
- automatic version update by autodist
* Fri Nov 15 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6.5-4mamba
- rebuild after previous release was built with buggy rpm
* Thu Nov 14 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6.5-3mamba
- move compilers to openmpi-devel new subpackage
* Thu Jul 11 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6.5-2mamba
- rename %{_bindir}/otfinfo to %{_bindir}/otfinfompi to resolve a conflict with texlive
* Sun Jun 30 2013 Automatic Build System <autodist@mambasoft.it> 1.6.5-1mamba
- automatic version update by autodist
* Sat Feb 23 2013 Automatic Build System <autodist@mambasoft.it> 1.6.4-1mamba
- automatic version update by autodist
* Wed Nov 07 2012 Automatic Build System <autodist@mambasoft.it> 1.6.3-1mamba
- automatic version update by autodist
* Mon Oct 08 2012 Automatic Build System <autodist@mambasoft.it> 1.6.2-1mamba
- automatic version update by autodist
* Tue Aug 07 2012 Automatic Build System <autodist@mambasoft.it> 1.6-1mamba
- automatic version update by autodist
* Fri Oct 28 2011 Automatic Build System <autodist@mambasoft.it> 1.4.4-1mamba
- automatic version update by autodist
* Wed Dec 01 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4.3-1mamba
- update to 1.4.3
* Fri Jun 25 2010 Automatic Build System <autodist@mambasoft.it> 1.3.4-1mamba
- automatic update by autodist
* Sat Jun 06 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.2-1mamba
- package created by autospec