rebuilt with openexr 2.1.0 [release 2.4.6.1-4mamba;Tue Apr 01 2014]

This commit is contained in:
Silvan Calarco 2024-01-06 08:10:48 +01:00
parent 083ad49395
commit af6f82a8a4
4 changed files with 226 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# opencv
OpenCV (Open Source Computer Vision) is a library of programming functions for real time computer vision.

View File

@ -0,0 +1,11 @@
--- OpenCV-2.1.0/src/highgui/grfmt_png.cpp 2010-04-06 03:24:44.000000000 +0200
+++ OpenCV-2.1.0/src/highgui/grfmt_png.cpp.libpng14 2010-10-11 19:42:14.000000000 +0200
@@ -223,7 +223,7 @@
png_set_palette_to_rgb( png_ptr );
if( m_color_type == PNG_COLOR_TYPE_GRAY && m_bit_depth < 8 )
- png_set_gray_1_2_4_to_8( png_ptr );
+ png_set_expand_gray_1_2_4_to_8( png_ptr );
if( CV_MAT_CN(m_type) > 1 && color )
png_set_bgr( png_ptr ); // convert RGB to BGR

View File

@ -0,0 +1,13 @@
Index: src/OpenCV-2.3.1/modules/flann/include/opencv2/flann/dist.h
===================================================================
--- src/OpenCV-2.3.1/modules/flann/include/opencv2/flann/dist.h 2011-09-12 20:42:27.000000000 +0200
+++ src/OpenCV-2.3.1/modules/flann/include/opencv2/flann/dist.h 2012-02-05 15:10:28.715982724 +0100
@@ -60,7 +60,7 @@
inline double abs<double>(double x) { return fabs(x); }
template<>
-inline long double abs<long double>(long double x) { return fabsl(x); }
+inline long double abs<long double>(long double x) { return fabs(x); }
template<typename T>

200
opencv.spec Normal file
View File

@ -0,0 +1,200 @@
%define pkgver %(echo %version | sed "s|[a-z]||")
%define javaver %(echo %version | cut -d. -f1-3 | tr -d .)
Name: opencv
Version: 2.4.6.1
Release: 4mamba
Summary: Collection of algorithms for computer vision
Group: Development/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Davide Madrisan <davide.madrisan@gmail.com>
URL: http://opencv.willowgarage.com/wiki/
Source: http://downloads.sourceforge.net/project/opencvlibrary/opencv-unix/%{version}/opencv-%{version}.tar.gz
Patch0: %{name}-2.1.0-libpng14.patch
Patch1: %{name}-2.3.1-arm-build.patch
License: BSD
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libatk-devel
BuildRequires: libavcodec-devel
BuildRequires: libavformat-devel
BuildRequires: libavutil-devel
BuildRequires: libbzip2-devel
BuildRequires: libcairo-devel
BuildRequires: libdc1394-devel
BuildRequires: libfontconfig-devel
BuildRequires: libfreetype-devel
BuildRequires: libgcc
BuildRequires: libglib-devel
BuildRequires: libgst-plugins-base-devel
BuildRequires: libgstreamer-devel
BuildRequires: libgtk-devel
BuildRequires: libjasper-devel
BuildRequires: libjpeg-devel
BuildRequires: libogg-devel
BuildRequires: libpango-devel
BuildRequires: libpng12-devel
BuildRequires: libpng-devel
BuildRequires: libpython-devel
BuildRequires: libstdc++6-devel
BuildRequires: libswscale-devel
BuildRequires: libtheora-devel
BuildRequires: libtiff-devel
BuildRequires: libunicap-devel
BuildRequires: libv4l-devel
BuildRequires: libvorbis-devel
BuildRequires: libxine1-devel
BuildRequires: libxml2-devel
BuildRequires: libz-devel
BuildRequires: python-Imaging
BuildRequires: python-numpy
## AUTOBUILDREQ-END
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
OpenCV (Open Source Computer Vision) is a library of programming functions for real time computer vision.
%package devel
Summary: Devel package for %{name}
Group: Development/Libraries
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description devel
OpenCV (Open Source Computer Vision) is a library of programming functions for real time computer vision.
This package contains static libraries and header files need for development.
%package -n java-opencv
Summary: Java bindings for apps which use OpenCV
Group: Development/Libraries
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description -n java-opencv
This package contains Python bindings for the OpenCV library.
%package python
Summary: Python bindings for apps which use OpenCV
Group: Development/Libraries
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
Requires: python-Imaging
Requires: python-numpy
%description python
This package contains Python bindings for the OpenCV library.
%prep
%setup -q
#% ifarch arm
#% patch1 -p2
#% endif
%build
#-- Interfaces:
# -- Use IPP: NO (Intel Performance Primitive)
# -- Use TBB: NO (Threading Building Blocks library)
# -- Build Documentation 0
#
# append flag -D__STDC_CONSTANT_MACROS to fix build with ffmpeg >= 0.6
PYTHON_PATH=`echo %python27_sitelib | sed "s|%{_prefix}/||"`
%cmake \
-DCMAKE_BUILD_TYPE=Release \
-DWITH_GSTREAMER=1 \
-DWITH_XINE=1 \
-DWITH_UNICAP=1 \
-DWITH_1394=1 \
-DWITH_FFMPEG=1 \
-DWITH_QUICKTIME=0 \
-DBUILD_SWIG_PYTHON_SUPPORT=1 \
-DINSTALL_C_EXAMPLES=0 \
-DCMAKE_CXX_FLAGS:STRING="$RPM_OPT_FLAGS -D__STDC_CONSTANT_MACROS" \
-DPYTHON_PACKAGES_PATH:PATH=$PYTHON_PATH
%make_jobs
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
## Fix permissions
#chmod 0755 %{buildroot}%{python_sitearch}/cv2.so
#chmod 0755 %{buildroot}%{python_sitearch}/cv.py
# Remove unpackaged files
rm -fr %{buildroot}%{_datadir}/opencv/doc
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root)
%{_bindir}/opencv_*
%{_libdir}/libopencv_*.so.*
#%{_libdir}/libcv.so.*
#%{_libdir}/libcvaux.so.*
#%{_libdir}/libcxcore.so.*
#%{_libdir}/libhighgui.so.*
#%{_libdir}/libml.so.*
#%dir %{_datadir}/opencv
%dir %{_datadir}/OpenCV/haarcascades
%{_datadir}/OpenCV/haarcascades/*
%dir %{_datadir}/OpenCV/lbpcascades
%{_datadir}/OpenCV/lbpcascades/*
%doc doc/license.txt
%files devel
%defattr(-,root,root)
%dir %{_includedir}/opencv
%{_includedir}/opencv/*
%dir %{_includedir}/opencv2
%{_includedir}/opencv2/*
%{_libdir}/libopencv_*.so
%{_libdir}/pkgconfig/opencv.pc
%{_datadir}/OpenCV/OpenCVConfig.cmake
%{_datadir}/OpenCV/OpenCVConfig-version.cmake
%files -n java-opencv
%defattr(-,root,root)
%dir %{_datadir}/OpenCV/java
%{_datadir}/OpenCV/java/libopencv_java%{javaver}.so
%{_datadir}/OpenCV/java/opencv-%{javaver}.jar
%files python
%defattr(-,root,root)
%{python_sitearch}/cv.py
%{python_sitearch}/cv2.so
%changelog
* Tue Apr 01 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.6.1-4mamba
- rebuilt with openexr 2.1.0
* Mon Aug 26 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.6.1-3mamba
- rebuilt after upgrading libatlas-3.8.4-2mamba which fixes python-numpy
* Wed Aug 21 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.6.1-2mamba
- rebuilt with libopenexr-2.0.1-3mamba nad python-numpy 1.8
* Sun Jul 14 2013 Automatic Build System <autodist@mambasoft.it> 2.4.6.1-1mamba
- automatic version update by autodist
* Mon Jul 08 2013 Automatic Build System <autodist@mambasoft.it> 2.4.6-1mamba
- automatic version update by autodist
* Thu Apr 25 2013 Automatic Build System <autodist@mambasoft.it> 2.4.5-1mamba
- update to 2.4.5
* Sat Dec 01 2012 Automatic Build System <autodist@mambasoft.it> 2.4.3-1mamba
- automatic version update by autodist
* Thu Aug 09 2012 Automatic Build System <autodist@mambasoft.it> 2.4.2-1mamba
- automatic version update by autodist
* Fri Dec 09 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 2.3.1a-1mamba
- update to 2.3.1a
* Mon Oct 11 2010 Davide Madrisan <davide.madrisan@gmail.com> 2.1.0-1mamba
- update to 2.1.0
* Mon Dec 07 2009 Davide Madrisan <davide.madrisan@gmail.com> 2.0.0-1mamba
- package created by autospec