rebuilt with protobuf 29.3 [release 4.11.0-2mamba;Thu Feb 13 2025]
This commit is contained in:
parent
e623163e42
commit
394db1bcad
@ -1,46 +0,0 @@
|
|||||||
From ea50be0529c248961e1b66293f8a9e4b807294a6 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Samuel Martin <s.martin49@gmail.com>
|
|
||||||
Date: Sun, 12 Oct 2014 10:17:23 +0200
|
|
||||||
Subject: [PATCH] core: fix x86 PIC code compilation
|
|
||||||
|
|
||||||
This bug was triggered by Buildroot autobuilders [1,2], causing this
|
|
||||||
kind of failures [3,4]:
|
|
||||||
|
|
||||||
[ 14%] Building CXX object modules/core/CMakeFiles/opencv_core.dir/src/system.cpp.o
|
|
||||||
/home/test/autobuild/instance-0/output/build/opencv-2.4.10/modules/core/src/system.cpp: In function '(static initializers for /home/test/autobuild/instance-0/output/build/opencv-2.4.10/modules/core/src/system.cpp)':
|
|
||||||
/home/test/autobuild/instance-0/output/build/opencv-2.4.10/modules/core/src/system.cpp:280:10: error: inconsistent operand constraints in an 'asm'
|
|
||||||
make[3]: *** [modules/core/CMakeFiles/opencv_core.dir/src/system.cpp.o] Error 1
|
|
||||||
|
|
||||||
[1] http://buildroot.org/
|
|
||||||
[2] http://autobuild.buildroot.org/
|
|
||||||
[3] http://autobuild.buildroot.org/?reason=opencv-2.4.10
|
|
||||||
[4] http://autobuild.buildroot.org/results/483/4838285b25d6293a5cf0bb9eadd5040a7c75d766/build-end.log
|
|
||||||
|
|
||||||
Signed-off-by: Samuel Martin <s.martin49@gmail.com>
|
|
||||||
---
|
|
||||||
modules/core/src/system.cpp | 5 ++++-
|
|
||||||
1 file changed, 4 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/modules/core/src/system.cpp b/modules/core/src/system.cpp
|
|
||||||
index 5a970d5..e9ffdc7 100644
|
|
||||||
--- a/modules/core/src/system.cpp
|
|
||||||
+++ b/modules/core/src/system.cpp
|
|
||||||
@@ -267,14 +267,17 @@ struct HWFeatures
|
|
||||||
: "cc"
|
|
||||||
);
|
|
||||||
#else
|
|
||||||
+ // We need to preserve ebx since we are compiling PIC code.
|
|
||||||
+ // This means we cannot use "=b" for the 2nd output register.
|
|
||||||
asm volatile
|
|
||||||
(
|
|
||||||
"pushl %%ebx\n\t"
|
|
||||||
"movl $7,%%eax\n\t"
|
|
||||||
"movl $0,%%ecx\n\t"
|
|
||||||
"cpuid\n\t"
|
|
||||||
+ "movl %%ebx,%1\n\t"
|
|
||||||
"popl %%ebx\n\t"
|
|
||||||
- : "=a"(cpuid_data[0]), "=b"(cpuid_data[1]), "=c"(cpuid_data[2]), "=d"(cpuid_data[3])
|
|
||||||
+ : "=a"(cpuid_data[0]), "=r"(cpuid_data[1]), "=c"(cpuid_data[2]), "=d"(cpuid_data[3])
|
|
||||||
:
|
|
||||||
: "cc"
|
|
||||||
);
|
|
49
opencv.spec
49
opencv.spec
@ -2,7 +2,7 @@
|
|||||||
%define javaver %(echo %version | cut -d. -f1-3 | tr -d .)
|
%define javaver %(echo %version | cut -d. -f1-3 | tr -d .)
|
||||||
Name: opencv
|
Name: opencv
|
||||||
Version: 4.11.0
|
Version: 4.11.0
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: Collection of algorithms for computer vision
|
Summary: Collection of algorithms for computer vision
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -11,12 +11,10 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|||||||
URL: https://opencv.org/
|
URL: https://opencv.org/
|
||||||
Source: https://github.com/opencv/opencv.git/%{version}/opencv-%{version}.tar.bz2
|
Source: https://github.com/opencv/opencv.git/%{version}/opencv-%{version}.tar.bz2
|
||||||
Source1: https://github.com/opencv/opencv_contrib.git/%{version}/opencv_contrib-%{version}.tar.bz2
|
Source1: https://github.com/opencv/opencv_contrib.git/%{version}/opencv_contrib-%{version}.tar.bz2
|
||||||
Patch2: opencv-2.4.9-buildfix-x86-asm-constraint.patch
|
Patch1: opencv-2.4.9-buildfix-x86-asm-constraint.patch
|
||||||
Patch3: opencv-2.4.10-i586-inconsistent-constraint-asm.patch
|
Patch2: opencv-4.1.2-cmake-includedir.patch
|
||||||
Patch4: opencv-4.1.2-cmake-includedir.patch
|
Patch3: opencv-4.9.0-contrib-rgbd-glew.patch
|
||||||
Patch5: opencv-4.9.0-contrib-rgbd-glew.patch
|
|
||||||
License: BSD
|
License: BSD
|
||||||
|
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: libQt6Core
|
BuildRequires: libQt6Core
|
||||||
@ -55,8 +53,10 @@ BuildRequires: libwebp-devel
|
|||||||
BuildRequires: libxine-devel
|
BuildRequires: libxine-devel
|
||||||
BuildRequires: libz-devel
|
BuildRequires: libz-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: libprotobuf-devel >= 29.3
|
||||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
Obsoletes: opencv41 < 4.2
|
Obsoletes: opencv41 < 4.2
|
||||||
|
Obsoletes: opencv45 < 4.5
|
||||||
Obsoletes: opencv47 < 4.8
|
Obsoletes: opencv47 < 4.8
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -67,6 +67,7 @@ Summary: Collection of algorithms for computer vision
|
|||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
Obsoletes: libopencv41 < 4.2
|
Obsoletes: libopencv41 < 4.2
|
||||||
|
Obsoletes: libopencv41 < 4.5
|
||||||
Obsoletes: libopencv47 < 4.8
|
Obsoletes: libopencv47 < 4.8
|
||||||
|
|
||||||
%description -n lib%{name}
|
%description -n lib%{name}
|
||||||
@ -81,6 +82,7 @@ Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|||||||
Requires: java-opencv = %{?epoch:%epoch:}%{version}-%{release}
|
Requires: java-opencv = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
%endif
|
%endif
|
||||||
Obsoletes: libopencv41-devel < 4.2
|
Obsoletes: libopencv41-devel < 4.2
|
||||||
|
Obsoletes: libopencv45-devel < 4.5
|
||||||
Obsoletes: libopencv47-devel < 4.8
|
Obsoletes: libopencv47-devel < 4.8
|
||||||
|
|
||||||
%description -n lib%{name}-devel
|
%description -n lib%{name}-devel
|
||||||
@ -92,6 +94,7 @@ Summary: Java bindings for apps which use OpenCV
|
|||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
Obsoletes: java-opencv41 < 4.2
|
Obsoletes: java-opencv41 < 4.2
|
||||||
|
Obsoletes: java-opencv45 < 4.5
|
||||||
Obsoletes: java-opencv47 < 4.8
|
Obsoletes: java-opencv47 < 4.8
|
||||||
|
|
||||||
%description -n java-%{name}
|
%description -n java-%{name}
|
||||||
@ -101,8 +104,6 @@ This package contains Python bindings for the OpenCV library.
|
|||||||
Summary: Python bindings for apps which use OpenCV
|
Summary: Python bindings for apps which use OpenCV
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
#Requires: python-Pillow-py3
|
|
||||||
#Requires: python-numpy-py3
|
|
||||||
Obsoletes: python-cv-py2 < 4.9.0
|
Obsoletes: python-cv-py2 < 4.9.0
|
||||||
Obsoletes: python-cv-py36 <= 4.1.2-4mamba
|
Obsoletes: python-cv-py36 <= 4.1.2-4mamba
|
||||||
Obsoletes: python-cv-py310 < 4.8.1-2mamba
|
Obsoletes: python-cv-py310 < 4.8.1-2mamba
|
||||||
@ -110,20 +111,18 @@ Obsoletes: python-cv-py310 < 4.8.1-2mamba
|
|||||||
%description -n python-cv-py3
|
%description -n python-cv-py3
|
||||||
This package contains Python bindings for the OpenCV library.
|
This package contains Python bindings for the OpenCV library.
|
||||||
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -a1
|
%setup -q -a1
|
||||||
#% setup -q -D -T
|
#% setup -q -D -T
|
||||||
#:<< _EOF
|
#:<< _EOF
|
||||||
|
|
||||||
%ifarch %{ix86}
|
%ifarch %{ix86}
|
||||||
%patch 2 -p1
|
%patch 1 -p1
|
||||||
%endif
|
%endif
|
||||||
#%patch3 -p1
|
%patch 2 -p1
|
||||||
%patch 4 -p1
|
|
||||||
|
|
||||||
cd opencv_contrib-%{version}
|
cd opencv_contrib-%{version}
|
||||||
%patch 5 -p1
|
%patch 3 -p1
|
||||||
cd ..
|
cd ..
|
||||||
|
|
||||||
# FIXME: removing module requiring Ogre
|
# FIXME: removing module requiring Ogre
|
||||||
@ -133,14 +132,7 @@ rm -rf opencv_contrib-%{version}/modules/ovis
|
|||||||
#:<< _EOF
|
#:<< _EOF
|
||||||
export JAVA_HOME=%{_jvmdir}/jdk
|
export JAVA_HOME=%{_jvmdir}/jdk
|
||||||
export JAVACMD=%{_jvmdir}/jdk/bin/java
|
export JAVACMD=%{_jvmdir}/jdk/bin/java
|
||||||
#:<< _EOF
|
|
||||||
#-- Interfaces:
|
|
||||||
# -- Use IPP: NO (Intel Performance Primitive)
|
|
||||||
# -- Use TBB: NO (Threading Building Blocks library)
|
|
||||||
# -- Build Documentation 0
|
|
||||||
#
|
|
||||||
# append flag -D__STDC_CONSTANT_MACROS to fix build with ffmpeg >= 0.6
|
|
||||||
#PYTHON_PATH=`echo %python36_sitelib | sed "s|%{_prefix}/||"`
|
|
||||||
%cmake -d build \
|
%cmake -d build \
|
||||||
-DCMAKE_BUILD_TYPE=Release \
|
-DCMAKE_BUILD_TYPE=Release \
|
||||||
-DWITH_OPENCL=ON \
|
-DWITH_OPENCL=ON \
|
||||||
@ -175,24 +167,12 @@ export JAVACMD=%{_jvmdir}/jdk/bin/java
|
|||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
%makeinstall -C build
|
%makeinstall -C build
|
||||||
|
|
||||||
## Fix permissions
|
|
||||||
#chmod 0755 %{buildroot}%{python_sitearch}/cv2.so
|
|
||||||
#chmod 0755 %{buildroot}%{python_sitearch}/cv.py
|
|
||||||
|
|
||||||
# Remove unpackaged files
|
# Remove unpackaged files
|
||||||
rm -fr %{buildroot}%{_datadir}/opencv/doc
|
rm -fr %{buildroot}%{_datadir}/opencv/doc
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
%post -n lib%{name}
|
|
||||||
/sbin/ldconfig
|
|
||||||
:
|
|
||||||
|
|
||||||
%postun -n lib%{name}
|
|
||||||
/sbin/ldconfig
|
|
||||||
:
|
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_bindir}/opencv_*
|
%{_bindir}/opencv_*
|
||||||
@ -227,6 +207,9 @@ rm -fr %{buildroot}%{_datadir}/opencv/doc
|
|||||||
%{python3_sitelib}/cv2/*
|
%{python3_sitelib}/cv2/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Feb 13 2025 Silvan Calarco <silvan.calarco@mambasoft.it> 4.11.0-2mamba
|
||||||
|
- rebuilt with protobuf 29.3
|
||||||
|
|
||||||
* Thu Jan 09 2025 Automatic Build System <autodist@openmamba.org> 4.11.0-1mamba
|
* Thu Jan 09 2025 Automatic Build System <autodist@openmamba.org> 4.11.0-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
x
Reference in New Issue
Block a user