automatic version update by autodist [release 4.9.0-1mamba;Sun Feb 25 2024]
This commit is contained in:
parent
ce6ce2fa00
commit
10915f5496
24
opencv-4.9.0-contrib-rgbd-glew.patch
Normal file
24
opencv-4.9.0-contrib-rgbd-glew.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
diff -Nru opencv_contrib-4.9.0/modules/rgbd.orig/CMakeLists.txt opencv_contrib-4.9.0/modules/rgbd/CMakeLists.txt
|
||||||
|
--- opencv_contrib-4.9.0/modules/rgbd.orig/CMakeLists.txt 2024-02-22 08:39:24.000000000 +0100
|
||||||
|
+++ opencv_contrib-4.9.0/modules/rgbd/CMakeLists.txt 2024-02-25 17:20:50.303652880 +0100
|
||||||
|
@@ -9,3 +9,8 @@
|
||||||
|
if(HAVE_OPENGL)
|
||||||
|
ocv_target_link_libraries(${the_module} PRIVATE "${OPENGL_LIBRARIES}")
|
||||||
|
endif()
|
||||||
|
+
|
||||||
|
+if(HAVE_GLEW)
|
||||||
|
+ ocv_target_link_libraries(${the_module} PRIVATE "${OPENGL_LIBRARIES} ${GLEW_LIBRARIES}")
|
||||||
|
+endif()
|
||||||
|
+
|
||||||
|
diff -Nru opencv_contrib-4.9.0/modules/rgbd.orig/src/dynafu.cpp opencv_contrib-4.9.0/modules/rgbd/src/dynafu.cpp
|
||||||
|
--- opencv_contrib-4.9.0/modules/rgbd.orig/src/dynafu.cpp 2024-02-22 11:21:30.045231678 +0100
|
||||||
|
+++ opencv_contrib-4.9.0/modules/rgbd/src/dynafu.cpp 2024-02-25 17:15:14.492239769 +0100
|
||||||
|
@@ -153,7 +153,7 @@
|
||||||
|
params.raycast_step_factor)),
|
||||||
|
pyrPoints(), pyrNormals(), warpfield()
|
||||||
|
{
|
||||||
|
-#ifdef HAVE_OPENGL
|
||||||
|
+#ifdef HAVE_GLEW
|
||||||
|
// Bind framebuffer for off-screen rendering
|
||||||
|
unsigned int fbo_depth;
|
||||||
|
glGenRenderbuffersEXT(1, &fbo_depth);
|
51
opencv.spec
51
opencv.spec
@ -1,8 +1,8 @@
|
|||||||
%define pkgver %(echo %version | sed "s|[a-z]||")
|
%define pkgver %(echo %version | sed "s|[a-z]||")
|
||||||
%define javaver %(echo %version | cut -d. -f1-3 | tr -d .)
|
%define javaver %(echo %version | cut -d. -f1-3 | tr -d .)
|
||||||
Name: opencv
|
Name: opencv
|
||||||
Version: 4.8.1
|
Version: 4.9.0
|
||||||
Release: 2mamba
|
Release: 1mamba
|
||||||
Summary: Collection of algorithms for computer vision
|
Summary: Collection of algorithms for computer vision
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -14,9 +14,12 @@ Source1: https://github.com/opencv/opencv_contrib.git/%{version}/opencv_co
|
|||||||
Patch2: opencv-2.4.9-buildfix-x86-asm-constraint.patch
|
Patch2: opencv-2.4.9-buildfix-x86-asm-constraint.patch
|
||||||
Patch3: opencv-2.4.10-i586-inconsistent-constraint-asm.patch
|
Patch3: opencv-2.4.10-i586-inconsistent-constraint-asm.patch
|
||||||
Patch4: opencv-4.1.2-cmake-includedir.patch
|
Patch4: opencv-4.1.2-cmake-includedir.patch
|
||||||
|
Patch5: opencv-4.9.0-contrib-rgbd-glew.patch
|
||||||
License: BSD
|
License: BSD
|
||||||
|
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libabseil-cpp-devel
|
||||||
BuildRequires: libavcodec-ffmpeg-devel
|
BuildRequires: libavcodec-ffmpeg-devel
|
||||||
BuildRequires: libavformat-ffmpeg-devel
|
BuildRequires: libavformat-ffmpeg-devel
|
||||||
BuildRequires: libavutil-ffmpeg-devel
|
BuildRequires: libavutil-ffmpeg-devel
|
||||||
@ -35,14 +38,11 @@ BuildRequires: libopenexr-devel
|
|||||||
BuildRequires: libopenjpeg-devel
|
BuildRequires: libopenjpeg-devel
|
||||||
BuildRequires: libpng-devel
|
BuildRequires: libpng-devel
|
||||||
BuildRequires: libprotobuf-devel
|
BuildRequires: libprotobuf-devel
|
||||||
BuildRequires: libpython27-devel
|
BuildRequires: libpython311-devel
|
||||||
BuildRequires: libpython310-devel
|
|
||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
BuildRequires: libswscale-ffmpeg-devel
|
BuildRequires: libswscale-ffmpeg-devel
|
||||||
BuildRequires: libtbb-devel
|
BuildRequires: libtbb-devel
|
||||||
%ifnarch arm
|
|
||||||
BuildRequires: libtesseract-devel
|
BuildRequires: libtesseract-devel
|
||||||
%endif
|
|
||||||
BuildRequires: libtiff-devel
|
BuildRequires: libtiff-devel
|
||||||
BuildRequires: libvtk-devel
|
BuildRequires: libvtk-devel
|
||||||
BuildRequires: libwebp-devel
|
BuildRequires: libwebp-devel
|
||||||
@ -52,6 +52,7 @@ BuildRequires: qt6-qtbase-devel
|
|||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
Obsoletes: opencv41 < 4.2
|
Obsoletes: opencv41 < 4.2
|
||||||
|
Obsoletes: opencv47 < 4.8
|
||||||
|
|
||||||
%description
|
%description
|
||||||
OpenCV (Open Source Computer Vision) is a library of programming functions for real time computer vision.
|
OpenCV (Open Source Computer Vision) is a library of programming functions for real time computer vision.
|
||||||
@ -61,6 +62,7 @@ Summary: Collection of algorithms for computer vision
|
|||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
Obsoletes: libopencv41 < 4.2
|
Obsoletes: libopencv41 < 4.2
|
||||||
|
Obsoletes: libopencv47 < 4.8
|
||||||
|
|
||||||
%description -n lib%{name}
|
%description -n lib%{name}
|
||||||
OpenCV (Open Source Computer Vision) is a library of programming functions for real time computer vision.
|
OpenCV (Open Source Computer Vision) is a library of programming functions for real time computer vision.
|
||||||
@ -74,6 +76,7 @@ Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|||||||
Requires: java-opencv = %{?epoch:%epoch:}%{version}-%{release}
|
Requires: java-opencv = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
%endif
|
%endif
|
||||||
Obsoletes: libopencv41-devel < 4.2
|
Obsoletes: libopencv41-devel < 4.2
|
||||||
|
Obsoletes: libopencv47-devel < 4.8
|
||||||
|
|
||||||
%description -n lib%{name}-devel
|
%description -n lib%{name}-devel
|
||||||
OpenCV (Open Source Computer Vision) is a library of programming functions for real time computer vision.
|
OpenCV (Open Source Computer Vision) is a library of programming functions for real time computer vision.
|
||||||
@ -84,30 +87,18 @@ Summary: Java bindings for apps which use OpenCV
|
|||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
Obsoletes: java-opencv41 < 4.2
|
Obsoletes: java-opencv41 < 4.2
|
||||||
|
Obsoletes: java-opencv47 < 4.8
|
||||||
|
|
||||||
%description -n java-%{name}
|
%description -n java-%{name}
|
||||||
This package contains Python bindings for the OpenCV library.
|
This package contains Python bindings for the OpenCV library.
|
||||||
|
|
||||||
%package -n python-cv-py2
|
|
||||||
Summary: Python bindings for apps which use OpenCV
|
|
||||||
Group: Development/Libraries
|
|
||||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
||||||
Requires: python-Pillow
|
|
||||||
Requires: python-numpy
|
|
||||||
Provides: opencv-python
|
|
||||||
Obsoletes: opencv-python <= 4.1.2-4mamba
|
|
||||||
Obsoletes: python-cv < 4.7.0-2mamba
|
|
||||||
|
|
||||||
%description -n python-cv-py2
|
|
||||||
This package contains Python bindings for the OpenCV library.
|
|
||||||
|
|
||||||
%package -n python-cv-py3
|
%package -n python-cv-py3
|
||||||
Summary: Python bindings for apps which use OpenCV
|
Summary: Python bindings for apps which use OpenCV
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
Requires: python-Pillow-py310
|
#Requires: python-Pillow-py3
|
||||||
Requires: python-numpy-py310
|
#Requires: python-numpy-py3
|
||||||
Obsoletes: python-cv-py3 < 4.7.0-2mamba
|
Obsoletes: python-cv-py2 < 4.9.0
|
||||||
Obsoletes: python-cv-py36 <= 4.1.2-4mamba
|
Obsoletes: python-cv-py36 <= 4.1.2-4mamba
|
||||||
Obsoletes: python-cv-py310 < 4.8.1-2mamba
|
Obsoletes: python-cv-py310 < 4.8.1-2mamba
|
||||||
|
|
||||||
@ -118,8 +109,7 @@ This package contains Python bindings for the OpenCV library.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -a1
|
%setup -q -a1
|
||||||
#% setup -q
|
#% setup -q -D -T
|
||||||
#-D -T
|
|
||||||
#:<< _EOF
|
#:<< _EOF
|
||||||
|
|
||||||
%ifarch %{ix86}
|
%ifarch %{ix86}
|
||||||
@ -128,6 +118,10 @@ This package contains Python bindings for the OpenCV library.
|
|||||||
#%patch3 -p1
|
#%patch3 -p1
|
||||||
%patch 4 -p1
|
%patch 4 -p1
|
||||||
|
|
||||||
|
cd opencv_contrib-%{version}
|
||||||
|
%patch 5 -p1
|
||||||
|
cd ..
|
||||||
|
|
||||||
# FIXME: removing module requiring Ogre
|
# FIXME: removing module requiring Ogre
|
||||||
rm -rf opencv_contrib-%{version}/modules/ovis
|
rm -rf opencv_contrib-%{version}/modules/ovis
|
||||||
|
|
||||||
@ -148,6 +142,7 @@ export JAVACMD=%{_jvmdir}/jdk/bin/java
|
|||||||
-DWITH_OPENCL=ON \
|
-DWITH_OPENCL=ON \
|
||||||
-DWITH_OPENGL=ON \
|
-DWITH_OPENGL=ON \
|
||||||
-DOpenGL_GL_PREFERENCE=LEGACY \
|
-DOpenGL_GL_PREFERENCE=LEGACY \
|
||||||
|
-DCMAKE_CXX_STANDARD=17 \
|
||||||
-DWITH_TBB=ON \
|
-DWITH_TBB=ON \
|
||||||
-DWITH_VULKAN=ON \
|
-DWITH_VULKAN=ON \
|
||||||
-DWITH_QT=ON \
|
-DWITH_QT=ON \
|
||||||
@ -222,17 +217,15 @@ rm -fr %{buildroot}%{_datadir}/opencv/doc
|
|||||||
%{_datadir}/java/opencv4/libopencv_java*.so
|
%{_datadir}/java/opencv4/libopencv_java*.so
|
||||||
%{_datadir}/java/opencv4/opencv-*.jar
|
%{_datadir}/java/opencv4/opencv-*.jar
|
||||||
|
|
||||||
%files -n python-cv-py2
|
|
||||||
%defattr(-,root,root)
|
|
||||||
%dir %{python27_sitelib}/cv2
|
|
||||||
%{python27_sitelib}/cv2/*
|
|
||||||
|
|
||||||
%files -n python-cv-py3
|
%files -n python-cv-py3
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%dir %{python3_sitelib}/cv2
|
%dir %{python3_sitelib}/cv2
|
||||||
%{python3_sitelib}/cv2/*
|
%{python3_sitelib}/cv2/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Feb 25 2024 Automatic Build System <autodist@openmamba.org> 4.9.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Thu Oct 19 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 4.8.1-2mamba
|
* Thu Oct 19 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 4.8.1-2mamba
|
||||||
- obsolete opencv41
|
- obsolete opencv41
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user