automatic version update by autodist [release 4.6.0-1mamba;Tue Jun 07 2022]
This commit is contained in:
parent
b8aa74dfa2
commit
0d4502d949
@ -1,11 +0,0 @@
|
|||||||
--- OpenCV-2.1.0/src/highgui/grfmt_png.cpp 2010-04-06 03:24:44.000000000 +0200
|
|
||||||
+++ OpenCV-2.1.0/src/highgui/grfmt_png.cpp.libpng14 2010-10-11 19:42:14.000000000 +0200
|
|
||||||
@@ -223,7 +223,7 @@
|
|
||||||
png_set_palette_to_rgb( png_ptr );
|
|
||||||
|
|
||||||
if( m_color_type == PNG_COLOR_TYPE_GRAY && m_bit_depth < 8 )
|
|
||||||
- png_set_gray_1_2_4_to_8( png_ptr );
|
|
||||||
+ png_set_expand_gray_1_2_4_to_8( png_ptr );
|
|
||||||
|
|
||||||
if( CV_MAT_CN(m_type) > 1 && color )
|
|
||||||
png_set_bgr( png_ptr ); // convert RGB to BGR
|
|
@ -1,13 +0,0 @@
|
|||||||
Index: src/OpenCV-2.3.1/modules/flann/include/opencv2/flann/dist.h
|
|
||||||
===================================================================
|
|
||||||
--- src/OpenCV-2.3.1/modules/flann/include/opencv2/flann/dist.h 2011-09-12 20:42:27.000000000 +0200
|
|
||||||
+++ src/OpenCV-2.3.1/modules/flann/include/opencv2/flann/dist.h 2012-02-05 15:10:28.715982724 +0100
|
|
||||||
@@ -60,7 +60,7 @@
|
|
||||||
inline double abs<double>(double x) { return fabs(x); }
|
|
||||||
|
|
||||||
template<>
|
|
||||||
-inline long double abs<long double>(long double x) { return fabsl(x); }
|
|
||||||
+inline long double abs<long double>(long double x) { return fabs(x); }
|
|
||||||
|
|
||||||
|
|
||||||
template<typename T>
|
|
28
opencv.spec
28
opencv.spec
@ -1,7 +1,7 @@
|
|||||||
%define pkgver %(echo %version | sed "s|[a-z]||")
|
%define pkgver %(echo %version | sed "s|[a-z]||")
|
||||||
%define javaver %(echo %version | cut -d. -f1-3 | tr -d .)
|
%define javaver %(echo %version | cut -d. -f1-3 | tr -d .)
|
||||||
Name: opencv
|
Name: opencv
|
||||||
Version: 4.5.5
|
Version: 4.6.0
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: Collection of algorithms for computer vision
|
Summary: Collection of algorithms for computer vision
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
@ -10,10 +10,6 @@ Distribution: openmamba
|
|||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://opencv.org/
|
URL: https://opencv.org/
|
||||||
Source: https://github.com/opencv/opencv.git/%{version}/opencv-%{version}.tar.bz2
|
Source: https://github.com/opencv/opencv.git/%{version}/opencv-%{version}.tar.bz2
|
||||||
#Source: https://sourceforge.net/projects/opencvlibrary/files/%{version}/OpenCV%20%{version}.tar.gz
|
|
||||||
#Source: http://downloads.sourceforge.net/project/opencvlibrary/opencv-unix/%{version}/opencv-%{version}.tar.gz
|
|
||||||
Patch0: %{name}-2.1.0-libpng14.patch
|
|
||||||
Patch1: %{name}-2.3.1-arm-build.patch
|
|
||||||
Patch2: opencv-2.4.9-buildfix-x86-asm-constraint.patch
|
Patch2: opencv-2.4.9-buildfix-x86-asm-constraint.patch
|
||||||
Patch3: opencv-2.4.10-i586-inconsistent-constraint-asm.patch
|
Patch3: opencv-2.4.10-i586-inconsistent-constraint-asm.patch
|
||||||
Patch4: opencv-4.1.2-cmake-includedir.patch
|
Patch4: opencv-4.1.2-cmake-includedir.patch
|
||||||
@ -36,6 +32,8 @@ BuildRequires: libopenblas-devel
|
|||||||
BuildRequires: libopenexr-devel
|
BuildRequires: libopenexr-devel
|
||||||
BuildRequires: libopenjpeg-devel
|
BuildRequires: libopenjpeg-devel
|
||||||
BuildRequires: libpng-devel
|
BuildRequires: libpng-devel
|
||||||
|
BuildRequires: libpython27-devel
|
||||||
|
BuildRequires: libpython3-devel
|
||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
BuildRequires: libswscale-ffmpeg-devel
|
BuildRequires: libswscale-ffmpeg-devel
|
||||||
BuildRequires: libtiff-devel
|
BuildRequires: libtiff-devel
|
||||||
@ -43,9 +41,6 @@ BuildRequires: libwebp-devel
|
|||||||
BuildRequires: libxine-devel
|
BuildRequires: libxine-devel
|
||||||
BuildRequires: libz-devel
|
BuildRequires: libz-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: libxine-devel
|
|
||||||
#BuildRequires: python-Imaging
|
|
||||||
#BuildRequires: python-numpy
|
|
||||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -72,12 +67,12 @@ Requires: java-opencv = %{?epoch:%epoch:}%{version}-%{release}
|
|||||||
OpenCV (Open Source Computer Vision) is a library of programming functions for real time computer vision.
|
OpenCV (Open Source Computer Vision) is a library of programming functions for real time computer vision.
|
||||||
This package contains static libraries and header files need for development.
|
This package contains static libraries and header files need for development.
|
||||||
|
|
||||||
%package -n java-opencv
|
%package -n java-%{name}
|
||||||
Summary: Java bindings for apps which use OpenCV
|
Summary: Java bindings for apps which use OpenCV
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
%description -n java-opencv
|
%description -n java-%{name}
|
||||||
This package contains Python bindings for the OpenCV library.
|
This package contains Python bindings for the OpenCV library.
|
||||||
|
|
||||||
%package -n python-cv
|
%package -n python-cv
|
||||||
@ -175,13 +170,13 @@ rm -fr %{buildroot}%{_datadir}/opencv/doc
|
|||||||
%{_bindir}/opencv_*
|
%{_bindir}/opencv_*
|
||||||
%{_bindir}/setup_vars_opencv4.sh
|
%{_bindir}/setup_vars_opencv4.sh
|
||||||
|
|
||||||
%files -n libopencv
|
%files -n lib%{name}
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_libdir}/libopencv_*.so.*
|
%{_libdir}/libopencv_*.so.*
|
||||||
%dir %{_datadir}/opencv4
|
%dir %{_datadir}/opencv4
|
||||||
%{_datadir}/opencv4/*
|
%{_datadir}/opencv4/*
|
||||||
|
|
||||||
%files -n libopencv-devel
|
%files -n lib%{name}-devel
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%dir %{_includedir}/opencv4
|
%dir %{_includedir}/opencv4
|
||||||
%dir %{_includedir}/opencv4/opencv2
|
%dir %{_includedir}/opencv4/opencv2
|
||||||
@ -194,7 +189,7 @@ rm -fr %{buildroot}%{_datadir}/opencv/doc
|
|||||||
%{_datadir}/licenses/opencv4/*
|
%{_datadir}/licenses/opencv4/*
|
||||||
|
|
||||||
%ifnarch arm
|
%ifnarch arm
|
||||||
%files -n java-opencv
|
%files -n java-%{name}
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_datadir}/java/opencv4/libopencv_java*.so
|
%{_datadir}/java/opencv4/libopencv_java*.so
|
||||||
%{_datadir}/java/opencv4/opencv-*.jar
|
%{_datadir}/java/opencv4/opencv-*.jar
|
||||||
@ -202,8 +197,8 @@ rm -fr %{buildroot}%{_datadir}/opencv/doc
|
|||||||
|
|
||||||
%files -n python-cv
|
%files -n python-cv
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%dir %{python_sitelib}/cv2
|
%dir %{python27_sitelib}/cv2
|
||||||
%{python_sitelib}/cv2/*
|
%{python27_sitelib}/cv2/*
|
||||||
|
|
||||||
%files -n python-cv-py3
|
%files -n python-cv-py3
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
@ -211,6 +206,9 @@ rm -fr %{buildroot}%{_datadir}/opencv/doc
|
|||||||
%{python3_sitelib}/cv2/*
|
%{python3_sitelib}/cv2/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jun 07 2022 Automatic Build System <autodist@mambasoft.it> 4.6.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Mon Dec 27 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 4.5.5-1mamba
|
* Mon Dec 27 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 4.5.5-1mamba
|
||||||
- update to 4.5.5
|
- update to 4.5.5
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user