added library subpackages; fixed cmake and pkgconfig files [release 3.1.1-3mamba;Mon Apr 26 2021]

This commit is contained in:
Silvan Calarco 2024-01-06 08:09:28 +01:00
parent 3cc2c1e277
commit 6760dc8758
2 changed files with 53 additions and 23 deletions

View File

@ -0,0 +1,10 @@
--- openbabel-3.1.1/openbabel-3.pc.cmake.orig 2021-04-26 17:10:39.999202672 +0200
+++ openbabel-3.1.1/openbabel-3.pc.cmake 2021-04-26 17:10:53.296444911 +0200
@@ -1,6 +1,6 @@
prefix=@CMAKE_INSTALL_PREFIX@
exec_prefix=${prefix}
-libdir=${exec_prefix}/@LIB_INSTALL_DIR@
+libdir=${exec_prefix}/@LIB_SUFFIX@
includedir=${prefix}/include
pkgincludedir=${includedir}/openbabel@BABEL_MAJ_VER@

View File

@ -1,22 +1,25 @@
%define apiver 3.0 %define apiver 3.0
%define minver %(echo %version | cut -d. -f 2-) %define minver %(echo %version | cut -d. -f 2-)
%define gitver %(echo %version | tr . -)
Name: openbabel Name: openbabel
Version: 3.1.1 Version: 3.1.1
Release: 1mamba Release: 3mamba
Summary: Chemistry file translation program Summary: Chemistry file translation program
Group: Applications/Educational Group: Applications/Educational
Vendor: openmamba Vendor: openmamba
Distribution: openmamba Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it> Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://downloads.sourceforge.net/sourceforge/openbabel/ URL: http://downloads.sourceforge.net/sourceforge/openbabel/
Source: https://github.com/openbabel/openbabel.git/master/openbabel-%{version}.tar.bz2 Source: https://github.com/openbabel/openbabel.git/openbabel-%{gitver}/openbabel-%{version}.tar.bz2
#http://downloads.sourceforge.net/openbabel/openbabel-%{version}.tar.gz
Patch0: openbabel-2.3.2-gcc-6.1.0.patch Patch0: openbabel-2.3.2-gcc-6.1.0.patch
Patch1: openbabel-3.1.1-fix-libdir-in-pkgconfig.patch
License: GPL License: GPL
## AUTOBUILDREQ-BEGIN ## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel BuildRequires: glibc-devel
BuildRequires: libcairo-devel BuildRequires: libcairo-devel
BuildRequires: libcoordgen-devel
BuildRequires: libgcc BuildRequires: libgcc
BuildRequires: libmaeparser-devel
BuildRequires: libstdc++6-devel BuildRequires: libstdc++6-devel
BuildRequires: libtirpc-devel BuildRequires: libtirpc-devel
BuildRequires: libwxBase-unicode-devel BuildRequires: libwxBase-unicode-devel
@ -26,33 +29,39 @@ BuildRequires: libz-devel
## AUTOBUILDREQ-END ## AUTOBUILDREQ-END
BuildRequires: libmaeparser-devel BuildRequires: libmaeparser-devel
BuildRequires: libcoordgen-devel BuildRequires: libcoordgen-devel
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description %description
OpenBabel is a project designed to pick up where Babel left off, as a cross-platform program and library designed to interconvert between many file formats used in molecular modeling and computational chemistry. OpenBabel is a project designed to pick up where Babel left off, as a cross-platform program and library designed to interconvert between many file formats used in molecular modeling and computational chemistry.
%package devel %package -n lib%{name}
Summary: Shared libraries provided by %{name}
Group: System/Libraries
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description -n lib%{name}
OpenBabel is a project designed to pick up where Babel left off, as a cross-platform program and library designed to interconvert between many file formats used in molecular modeling and computational chemistry.
This package contains static libraries and header files needed for development.
%package -n lib%{name}-devel
Summary: Devel package for %{name} Summary: Devel package for %{name}
Group: Development/Libraries Group: Development/Libraries
Requires: %{name} = %{version} Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
Provides: openbabel-devel
Obsoletes: openbabel-devel <= 3.1.1-2mamba
%description devel %description -n lib%{name}-devel
OpenBabel is a project designed to pick up where Babel left off, as a cross-platform program and library designed to interconvert between many file formats used in molecular modeling and computational chemistry. OpenBabel is a project designed to pick up where Babel left off, as a cross-platform program and library designed to interconvert between many file formats used in molecular modeling and computational chemistry.
This package contains static libraries and header files needed for development.
This package contains static libraries and header files need for development.
%debug_package %debug_package
%prep %prep
%setup -q %setup -q
#-D -T
#%patch0 -p1 #%patch0 -p1
#%ifarch x86_64 %patch1 -p1
#sed -i "s|DESTINATION lib$|DESTINATION lib64|" external/maeparser-1.1/CMakeLists.txt
#%endif
%build %build
%cmake \ %cmake -d build \
-DCMAKE_SHARED_LINKER_FLAGS="-ltirpc" \ -DCMAKE_SHARED_LINKER_FLAGS="-ltirpc" \
-DwxWidgets_CONFIG_EXECUTABLE=%{_bindir}/wx-config-unicode -DwxWidgets_CONFIG_EXECUTABLE=%{_bindir}/wx-config-unicode
@ -60,30 +69,35 @@ This package contains static libraries and header files need for development.
%install %install
[ "%{buildroot}" != / ] && rm -rf %{buildroot} [ "%{buildroot}" != / ] && rm -rf %{buildroot}
%makeinstall %makeinstall -C build
# Unable to fix this before build
sed -i "s|\${OpenBabel3_INSTALL_PREFIX}/include|/usr/include|" %{buildroot}%{_libdir}/cmake/openbabel3/OpenBabel3Config.cmake
sed -i "s|\${OpenBabel3_INSTALL_PREFIX}//usr|/usr|" %{buildroot}%{_libdir}/cmake/openbabel3/OpenBabel3Config.cmake
%clean %clean
[ "%{buildroot}" != / ] && rm -rf %{buildroot} [ "%{buildroot}" != / ] && rm -rf %{buildroot}
%post -p /sbin/ldconfig %post -n lib%{name} -p /sbin/ldconfig
%postun -p /sbin/ldconfig %postun -n lib%{name} -p /sbin/ldconfig
%files %files
%defattr(-,root,root) %defattr(-,root,root)
%{_bindir}/ob* %{_bindir}/ob*
%{_bindir}/roundtrip %{_bindir}/roundtrip
%{_datadir}/openbabel/*
%{_mandir}/man1/ob*.1*
%{_mandir}/man1/roundtrip.1*
%files -n lib%{name}
%defattr(-,root,root)
%{_libdir}/libinchi.so.* %{_libdir}/libinchi.so.*
%{_libdir}/libopenbabel.so.* %{_libdir}/libopenbabel.so.*
%dir %{_libdir}/openbabel %dir %{_libdir}/openbabel
%{_libdir}/openbabel/*/*.so %{_libdir}/openbabel/*/*.so
%{_datadir}/openbabel/*
#%{_mandir}/man1/babel.1*
%{_mandir}/man1/ob*.1*
%{_mandir}/man1/roundtrip.1*
%doc AUTHORS COPYING %doc AUTHORS COPYING
# ChangeLog NEWS README THANKS
%files devel %files -n lib%{name}-devel
%defattr(-,root,root) %defattr(-,root,root)
%dir %{_includedir}/inchi %dir %{_includedir}/inchi
%{_includedir}/inchi/inchi_api.h %{_includedir}/inchi/inchi_api.h
@ -101,6 +115,12 @@ This package contains static libraries and header files need for development.
%{_libdir}/pkgconfig/*.pc %{_libdir}/pkgconfig/*.pc
%changelog %changelog
* Mon Apr 26 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 3.1.1-3mamba
- added library subpackages; fixed cmake and pkgconfig files
* Mon Apr 26 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 3.1.1-2mamba
- fix source: use tag instead of master
* Mon May 11 2020 Automatic Build System <autodist@mambasoft.it> 3.1.1-1mamba * Mon May 11 2020 Automatic Build System <autodist@mambasoft.it> 3.1.1-1mamba
- automatic version update by autodist - automatic version update by autodist