automatic version update by autodist [release 2.1.10-1mamba;Wed Nov 20 2024]
This commit is contained in:
parent
bde7256a7d
commit
c11f803789
@ -1,30 +0,0 @@
|
|||||||
--- open-iscsi-2.0-872.orig/utils/open-isns/configure.ac
|
|
||||||
+++ open-iscsi-2.0-872/utils/open-isns/configure.ac
|
|
||||||
@@ -79,7 +79,7 @@ AC_ARG_WITH(slp,
|
|
||||||
WITH_SLP=$withval
|
|
||||||
else
|
|
||||||
WITH_SLP=yes
|
|
||||||
- CPPFLAGS="$CPPFLAGS -I${withval}"
|
|
||||||
+ CPPFLAGS="$CPPFLAGS -I${withval} -lslp"
|
|
||||||
LDFLAGS="$LDFLAGS -L${withval}"
|
|
||||||
fi
|
|
||||||
]
|
|
||||||
diff -Nru open-iscsi-2.0-873.orig/usr/Makefile open-iscsi-2.0-873/usr/Makefile
|
|
||||||
--- open-iscsi-2.0-873.orig/usr/Makefile 2012-05-21 02:59:24.000000000 +0200
|
|
||||||
+++ open-iscsi-2.0-873/usr/Makefile 2014-06-24 02:32:04.121491125 +0200
|
|
||||||
@@ -54,10 +54,10 @@
|
|
||||||
|
|
||||||
iscsid: $(ISCSI_LIB_SRCS) $(INITIATOR_SRCS) $(DISCOVERY_SRCS) \
|
|
||||||
iscsid.o session_mgmt.o discoveryd.o
|
|
||||||
- $(CC) $(CFLAGS) $^ -o $@ -L../utils/open-isns -lisns
|
|
||||||
+ $(CC) $(CFLAGS) $^ -o $@ -L../utils/open-isns -lisns -lslp
|
|
||||||
|
|
||||||
iscsiadm: $(ISCSI_LIB_SRCS) $(DISCOVERY_SRCS) iscsiadm.o session_mgmt.o
|
|
||||||
- $(CC) $(CFLAGS) $^ -o $@ -L../utils/open-isns -lisns
|
|
||||||
+ $(CC) $(CFLAGS) $^ -o $@ -L../utils/open-isns -lisns -lslp
|
|
||||||
|
|
||||||
iscsistart: $(ISCSI_LIB_SRCS) $(INITIATOR_SRCS) $(FW_BOOT_SRCS) \
|
|
||||||
iscsistart.o statics.o
|
|
||||||
Binary files open-iscsi-2.0-873.orig/utils/iscsi-iname and open-iscsi-2.0-873/utils/iscsi-iname differ
|
|
||||||
Binary files open-iscsi-2.0-873.orig/utils/iscsi-iname.o and open-iscsi-2.0-873/utils/iscsi-iname.o differ
|
|
||||||
Binary files open-iscsi-2.0-873.orig/utils/md5.o and open-iscsi-2.0-873/utils/md5.o differ
|
|
File diff suppressed because it is too large
Load Diff
@ -1,7 +1,7 @@
|
|||||||
%define pkgver %(echo %version | tr _ -)
|
%define pkgver %(echo %version | tr _ -)
|
||||||
Name: open-iscsi
|
Name: open-iscsi
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 2.1.8
|
Version: 2.1.10
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: A high performance, transport independent, multi-platform implementation of RFC3720
|
Summary: A high performance, transport independent, multi-platform implementation of RFC3720
|
||||||
Group: System/Kernel and Hardware
|
Group: System/Kernel and Hardware
|
||||||
@ -10,8 +10,6 @@ Distribution: openmamba
|
|||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://www.open-iscsi.com/
|
URL: https://www.open-iscsi.com/
|
||||||
Source: https://github.com/open-iscsi/open-iscsi.git/%{version}/open-iscsi-%{version}.tar.bz2
|
Source: https://github.com/open-iscsi/open-iscsi.git/%{version}/open-iscsi-%{version}.tar.bz2
|
||||||
Source1: open-iscsi-config.guess
|
|
||||||
Patch0: open-iscsi-2.0_873-slp.patch
|
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -45,27 +43,16 @@ This package contains libraries and header files for developing applications tha
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{pkgver}
|
%setup -q -n %{name}-%{pkgver}
|
||||||
#%patch0 -p1
|
|
||||||
#cp %{SOURCE1} utils/open-isns/aclocal/config.guess
|
|
||||||
#sed -i "s,| arm-\* |,| aarch64-\* | arm-\* |," utils/open-isns/aclocal/config.sub
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%make \
|
%meson \
|
||||||
LIB_DIR=%{_libdir} \
|
-Drulesdir=%{_udevrulesdir}
|
||||||
RULESDIR=%{_udevrulesdir} \
|
|
||||||
SBINDIR=%{_sbindir} \
|
%meson_build
|
||||||
user
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
%makeinstall \
|
%meson_install
|
||||||
LIB_DIR=%{_libdir} \
|
|
||||||
RULESDIR=%{_udevrulesdir} \
|
|
||||||
SBINDIR=%{_sbindir} \
|
|
||||||
install_systemd
|
|
||||||
|
|
||||||
#install -D -m0755 usr/iscsistart %{buildroot}%{_sbindir}/iscsistart
|
|
||||||
#install -D -m0644 doc/iscsistart.8 %{buildroot}%{_mandir}/man8/iscsistart.8
|
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
@ -74,8 +61,6 @@ This package contains libraries and header files for developing applications tha
|
|||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_sysconfdir}/logrotate.d/iscsiuiolog
|
%{_sysconfdir}/logrotate.d/iscsiuiolog
|
||||||
%dir %{_sysconfdir}/iscsi
|
%dir %{_sysconfdir}/iscsi
|
||||||
%dir %{_sysconfdir}/iscsi/ifaces
|
|
||||||
%{_sysconfdir}/iscsi/ifaces/iface.example
|
|
||||||
%{_sysconfdir}/iscsi/initiatorname.iscsi
|
%{_sysconfdir}/iscsi/initiatorname.iscsi
|
||||||
%config(noreplace) %{_sysconfdir}/iscsi/iscsid.conf
|
%config(noreplace) %{_sysconfdir}/iscsi/iscsid.conf
|
||||||
%{_sbindir}/brcm_iscsiuio
|
%{_sbindir}/brcm_iscsiuio
|
||||||
@ -88,6 +73,7 @@ This package contains libraries and header files for developing applications tha
|
|||||||
%{_unitdir}/iscsiuio.socket
|
%{_unitdir}/iscsiuio.socket
|
||||||
%{_systemdgeneratordir}/ibft-rule-generator
|
%{_systemdgeneratordir}/ibft-rule-generator
|
||||||
%{_udevrulesdir}/50-iscsi-firmware-login.rules
|
%{_udevrulesdir}/50-iscsi-firmware-login.rules
|
||||||
|
%{_localstatedir}/lib/iscsi/ifaces/iface.example
|
||||||
%{_mandir}/man8/iscsi*.8*
|
%{_mandir}/man8/iscsi*.8*
|
||||||
|
|
||||||
%files -n lib%{name}
|
%files -n lib%{name}
|
||||||
@ -104,6 +90,9 @@ This package contains libraries and header files for developing applications tha
|
|||||||
%{_libdir}/pkgconfig/libopeniscsiusr.pc
|
%{_libdir}/pkgconfig/libopeniscsiusr.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Nov 20 2024 Automatic Build System <autodist@openmamba.org> 2.1.10-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Mon Oct 24 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.8-1mamba
|
* Mon Oct 24 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.8-1mamba
|
||||||
- update to 2.1.8
|
- update to 2.1.8
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user