155 lines
3.9 KiB
RPMSpec
155 lines
3.9 KiB
RPMSpec
Name: open-fcoe
|
|
Version: 3.11
|
|
Release: 1mamba
|
|
Summary: Fibre Channel over Ethernet implementation for the Linux operating system
|
|
Group: System/Kernel and Hardware
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: http://open-fcoe.org/
|
|
Source: http://ftp-osl.osuosl.org/pub/open-fcoe/open-fcoe-%{version}.tar.gz
|
|
Patch0: open-fcoe-3.11-bootstrap.patch
|
|
Patch1: open-fcoe-3.11-fix-hbaapi-prototypes.patch
|
|
Patch2: open-fcoe-3.11-libHBAAPI-add-ldl.patch
|
|
Patch3: open-fcoe-3.11-add_systemd_service_file.patch
|
|
Patch4: open-fcoe-3.11-systemd_socket_activation.patch
|
|
Patch5: open-fcoe-3.11-properly_use_inttypes.patch
|
|
License: GPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: ldconfig
|
|
BuildRequires: libpciaccess-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: libopen-lldp-devel
|
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
|
|
%description
|
|
Fibre Channel over Ethernet implementation for the Linux operating system.
|
|
|
|
%package -n lib%{name}
|
|
Group: System/Libraries
|
|
Summary: Shared libraries for %{name}
|
|
|
|
%description -n lib%{name}
|
|
This package contains shared libraries for %{name}.
|
|
|
|
%package -n lib%{name}-devel
|
|
Group: Development/Libraries
|
|
Summary: Development files for %{name}
|
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
Requires: pkg-config
|
|
|
|
%description -n lib%{name}-devel
|
|
This package contains libraries and header files for developing applications that use %{name}.
|
|
|
|
%debug_package
|
|
|
|
%prep
|
|
%setup -q -c
|
|
%patch0 -p1
|
|
%patch1 -p1
|
|
cd libHBAAPI
|
|
%patch2 -p1
|
|
cd ..
|
|
cd fcoe-utils
|
|
%patch3 -p1
|
|
%patch4 -p1
|
|
%patch5 -p1
|
|
cd ..
|
|
|
|
%build
|
|
cd libHBAAPI
|
|
./bootstrap.sh
|
|
%configure
|
|
%make
|
|
|
|
cd ../libhbalinux
|
|
./bootstrap.sh
|
|
%configure \
|
|
HBAAPI_LIBS="-L../libHBAAPI/.libs/ -lHBAAPI" HBAAPI_CFLAGS="-I../libHBAAPI"
|
|
%make
|
|
|
|
cd ../fcoe-utils
|
|
./bootstrap.sh
|
|
%configure \
|
|
--with-systemdsystemunitdir=%{_unitdir} \
|
|
HBAAPI_LIBS="-L../libHBAAPI/.libs/ -lHBAAPI" HBAAPI_CFLAGS="-I../libHBAAPI" \
|
|
LIBHBALINUX_CFLAGS="../libhbalinux/" LIBHBALINUX_LIBS="-L../libhbalinux/.libs" \
|
|
CFLAGS="-I../libHBAAPI %{optflags} -Wno-error"
|
|
|
|
%make
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
cd libHBAAPI
|
|
%makeinstall
|
|
|
|
cd ../libhbalinux
|
|
%makeinstall
|
|
|
|
cd ../fcoe-utils
|
|
%makeinstall \
|
|
BASH_COMPLETION_DIR=%{buildroot}%{_sysconfdir}/bash_completion.d/
|
|
|
|
rm -f %{buildroot}%{_sysconfdir}/init.d/fcoe
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%post
|
|
if [ $1 -ge 1 ]; then
|
|
systemctl -q daemon-reload
|
|
fi
|
|
:
|
|
|
|
%post -n lib%{name} -p /sbin/ldconfig
|
|
%postun -n lib%{name} -p /sbin/ldconfig
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%{_sysconfdir}/bash_completion.d/fcoeadm
|
|
%{_sysconfdir}/bash_completion.d/fcoemon
|
|
%dir %{_sysconfdir}/fcoe
|
|
%config(noreplace) %{_sysconfdir}/fcoe/cfg-ethx
|
|
%config(noreplace) %{_sysconfdir}/fcoe/config
|
|
%config(noreplace) %{_sysconfdir}/hba.conf
|
|
%{_sbindir}/fcnsq
|
|
%{_sbindir}/fcoeadm
|
|
%{_sbindir}/fcoemon
|
|
%{_sbindir}/fcping
|
|
%{_sbindir}/fcrls
|
|
%{_sbindir}/fipvlan
|
|
%{_unitdir}/fcoe.service
|
|
%{_unitdir}/fcoemon.socket
|
|
%{_mandir}/man8/fcnsq.8*
|
|
%{_mandir}/man8/fcoeadm.8*
|
|
%{_mandir}/man8/fcoemon.8*
|
|
%{_mandir}/man8/fcping.8*
|
|
%{_mandir}/man8/fcrls.8*
|
|
%{_mandir}/man8/fipvlan.8*
|
|
%doc fcoe-utils/COPYING
|
|
|
|
%files -n lib%{name}
|
|
%defattr(-,root,root)
|
|
%{_libdir}/libHBAAPI.so.*
|
|
%{_libdir}/libhbalinux.so.*
|
|
%doc libHBAAPI/COPYING
|
|
|
|
%files -n lib%{name}-devel
|
|
%defattr(-,root,root)
|
|
%{_includedir}/hbaapi.h
|
|
%{_includedir}/vendorhbaapi.h
|
|
%{_libdir}/libHBAAPI.a
|
|
%{_libdir}/libHBAAPI.la
|
|
%{_libdir}/libHBAAPI.so
|
|
%{_libdir}/libhbalinux.a
|
|
%{_libdir}/libhbalinux.la
|
|
%{_libdir}/libhbalinux.so
|
|
%{_libdir}/pkgconfig/HBAAPI.pc
|
|
%{_libdir}/pkgconfig/libhbalinux.pc
|
|
|
|
%changelog
|
|
* Tue Jun 24 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 3.11-1mamba
|
|
- package created using the webbuild interface
|