automatic version update by autodist [release 0.98.2-1mamba;Sat May 18 2013]
This commit is contained in:
parent
5add48ae2a
commit
ec08d94b98
@ -1,2 +1,4 @@
|
|||||||
# onboard
|
# onboard
|
||||||
|
|
||||||
|
An onscreen keyboard useful for tablet PC users and for mobility impaired users.
|
||||||
|
|
||||||
|
14
onboard-0.97.1-dconf-0.14.patch
Normal file
14
onboard-0.97.1-dconf-0.14.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
=== modified file 'Onboard/osk/osk_util.c'
|
||||||
|
--- Onboard/osk/osk_util.c 2012-06-24 13:11:52 +0000
|
||||||
|
+++ Onboard/osk/osk_util.c 2012-07-18 23:33:20 +0000
|
||||||
|
@@ -609,7 +609,7 @@
|
||||||
|
if (!PyArg_ParseTuple (args, "s:read_dconf_key", &key))
|
||||||
|
return NULL;
|
||||||
|
|
||||||
|
- DConfClient* client = dconf_client_new(NULL, NULL, NULL, NULL);
|
||||||
|
+ DConfClient* client = dconf_client_new();
|
||||||
|
if (client == NULL)
|
||||||
|
{
|
||||||
|
PyErr_SetString(PyExc_ValueError, "failed to create dconf client");
|
||||||
|
|
||||||
|
=== modified file 'debian/control'
|
95
onboard.spec
Normal file
95
onboard.spec
Normal file
@ -0,0 +1,95 @@
|
|||||||
|
%define majver %(echo %version | cut -d. -f1-2)
|
||||||
|
Name: onboard
|
||||||
|
Version: 0.98.2
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: An onscreen keyboard useful for tablet PC users and for mobility impaired users
|
||||||
|
Group: System/Libraries
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: https://launchpad.net/onboard
|
||||||
|
Source: http://launchpad.net/onboard/%{majver}/%{version}/+download/onboard-%{version}.tar.gz
|
||||||
|
Patch0: onboard-0.97.1-dconf-0.14.patch
|
||||||
|
License: GPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libcairo-devel
|
||||||
|
BuildRequires: libdconf-devel
|
||||||
|
BuildRequires: libgdk-pixbuf-devel
|
||||||
|
BuildRequires: libglib-devel
|
||||||
|
BuildRequires: libgtk-devel
|
||||||
|
BuildRequires: libpango-devel
|
||||||
|
BuildRequires: libpython-devel
|
||||||
|
BuildRequires: libX11-devel
|
||||||
|
BuildRequires: libXi-devel
|
||||||
|
BuildRequires: libXtst-devel
|
||||||
|
BuildRequires: python
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: python-distutils-extra
|
||||||
|
Requires: python >= %python_version
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
An onscreen keyboard useful for tablet PC users and for mobility impaired users.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
#%patch0 -p0
|
||||||
|
|
||||||
|
%build
|
||||||
|
CFLAGS="%{optflags}" %{__python} setup.py build
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%{__python} setup.py install \
|
||||||
|
-O1 --skip-build \
|
||||||
|
--root="%{buildroot}" \
|
||||||
|
--install-headers=%{_includedir}/python \
|
||||||
|
--install-lib=%{python_sitearch} \
|
||||||
|
--record=%{name}.filelist
|
||||||
|
|
||||||
|
rm %{buildroot}%{_datadir}/onboard/{AUTHORS,CHANGELOG,COPYING,NEWS,README}
|
||||||
|
#sed -i "\,\.egg-info/,d;s,.*/man/.*,&.gz," %{name}.filelist
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_sysconfdir}/xdg/autostart/onboard-autostart.desktop
|
||||||
|
%{_bindir}/onboard
|
||||||
|
%{_bindir}/onboard-settings
|
||||||
|
%dir %{python_sitearch}/Onboard
|
||||||
|
%{python_sitearch}/Onboard/*
|
||||||
|
%{python_sitearch}/onboard-%{version}*.egg-info
|
||||||
|
%dir %{_datadir}/onboard
|
||||||
|
%{_datadir}/onboard/*.py
|
||||||
|
%{_datadir}/onboard/*.ui
|
||||||
|
%{_datadir}/onboard/onboard-defaults.conf.example
|
||||||
|
%dir %{_datadir}/onboard/docs
|
||||||
|
%{_datadir}/onboard/docs/*
|
||||||
|
%dir %{_datadir}/onboard/layouts
|
||||||
|
%{_datadir}/onboard/layouts/*
|
||||||
|
%dir %{_datadir}/onboard/scripts
|
||||||
|
%{_datadir}/onboard/scripts/*
|
||||||
|
%dir %{_datadir}/onboard/themes
|
||||||
|
%{_datadir}/onboard/themes/*
|
||||||
|
%{_datadir}/GConf/gsettings/onboard.convert
|
||||||
|
%{_datadir}/glib-2.0/schemas/org.onboard.gschema.xml
|
||||||
|
%{_datadir}/icons/ubuntu-mono-dark/status/22/onboard-panel.svg
|
||||||
|
%{_datadir}/icons/ubuntu-mono-light/status/22/onboard-panel.svg
|
||||||
|
%{_datadir}/icons/hicolor/scalable/apps/onboard*.svg
|
||||||
|
%doc AUTHORS COPYING
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sat May 18 2013 Automatic Build System <autodist@mambasoft.it> 0.98.2-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sat May 18 2013 Automatic Build System <autodist@mambasoft.it> 0.98.1-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Wed Oct 17 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.97.1-2mamba
|
||||||
|
- rebuilt with dconf 0.14.0 (added upstream patch)
|
||||||
|
|
||||||
|
* Wed Aug 08 2012 Automatic Build System <autodist@mambasoft.it> 0.97.1-1mamba
|
||||||
|
- update to 0.97.1
|
||||||
|
|
||||||
|
* Mon Dec 12 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.96.1-1mamba
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user