82 lines
2.5 KiB
RPMSpec
82 lines
2.5 KiB
RPMSpec
%define pkgver %(echo %version | tr . -)
|
|
Name: ois
|
|
Version: 1.3
|
|
Release: 1mamba
|
|
Summary: Object Oriented Input System
|
|
Group: System/Libraries
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: http://sourceforge.net/projects/wgois/
|
|
Source: http://downloads.sourceforge.net/project/wgois/Source%20Release/%{version}/ois_v%{pkgver}.tar.gz
|
|
Patch0: ois-1.3-gcc-4.8.patch
|
|
License: zlib/libpng
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libgcc
|
|
BuildRequires: libpthread-stubs-devel
|
|
BuildRequires: libstdc++6-devel
|
|
BuildRequires: libX11-devel
|
|
BuildRequires: libXau-devel
|
|
BuildRequires: libxcb-devel
|
|
BuildRequires: libXdmcp-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
|
|
%description
|
|
Object Oriented Input System (OIS) is meant to be a cross platform, simple solution for using all kinds of Input Devices (Keyboards, Mice, Joysticks, etc) and feedback devices (e.g. force feedback). Written in C++ using Object Oriented Design pattern.
|
|
|
|
%package -n lib%{name}
|
|
Group: System/Libraries
|
|
Summary: Object Oriented Input System
|
|
|
|
%description -n lib%{name}
|
|
Object Oriented Input System (OIS) is meant to be a cross platform, simple solution for using all kinds of Input Devices (Keyboards, Mice, Joysticks, etc) and feedback devices (e.g. force feedback). Written in C++ using Object Oriented Design pattern.
|
|
|
|
%package -n lib%{name}-devel
|
|
Group: Development/Libraries
|
|
Summary: Development files for %{name}
|
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
Requires: pkg-config
|
|
|
|
%description -n lib%{name}-devel
|
|
This package contains libraries and header files for developing applications that use %{name}.
|
|
|
|
%debug_package
|
|
|
|
%prep
|
|
%setup -q -n %{name}-v%{pkgver}
|
|
%patch0 -p1
|
|
|
|
%build
|
|
sh ./bootstrap
|
|
%configure
|
|
%make
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%post -n lib%{name} -p /sbin/ldconfig
|
|
%postun -n lib%{name} -p /sbin/ldconfig
|
|
|
|
%files -n lib%{name}
|
|
%defattr(-,root,root)
|
|
%{_libdir}/libOIS-1.3.0.so
|
|
|
|
%files -n lib%{name}-devel
|
|
%defattr(-,root,root)
|
|
%dir %{_includedir}/OIS
|
|
%{_includedir}/OIS/OIS*.h
|
|
%{_libdir}/libOIS.a
|
|
%{_libdir}/libOIS.la
|
|
%{_libdir}/libOIS.so
|
|
%{_libdir}/pkgconfig/OIS.pc
|
|
|
|
%changelog
|
|
* Thu Nov 28 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3-1mamba
|
|
- package created using the webbuild interface
|